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Quick Start Guide

TM Layout

Quick Access Toolbar:

Allows you to customize the TransMagic interface to suit your needs and workflow.  See the 
Tweak Your TransMagic section for more information.

TransMagic Ribbon:

The TransMagic Ribbon interface is broken up into groups of like functionality.  These groups are
the tabs of the ribbon and include the following:

 Home Tab | Includes the most common TransMagic functions that are used in the majority of
all tasks.  See the Home Tab section for more information.
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 Operations Tab | Includes most common Change, Edit, or Query operations that can be
performed on an entity in TransMagic.  See the Operations Tab section for more information.

 View Tab | Includes most viewing operations and functions.  See the View Tab section for
more information.

 Advanced Tab | Includes most advanced operations and functions.  See the Advanced Tab
section for more information.

Selection Toolbar:

Virtually all operations and functions in TransMagic use the operations on the Selection Toolbar. 
It includes common selection, filter and viewing options.  See the Selection Toolbar section for
more information.  In addition, you can add or remove functions from this toolbar or create your
own unique toolbars altogether that contain commonly used functions by you.  See the Tweak
Your TransMagic section for more information.

Status Bar:

The TransMagic Status Bar will display additional information about TransMagic functions.  Som e
functions in TransMagic require multiple steps.  These steps will also be displayed in the Status
Bar.  The Status Bar can be enabled or disabled by selecting the Tools menu and either checking
or unchecking "Status Bar".

View Axes:

The TransMagic View Axes are more than just a visual orientation.  Notice the grey semi-circle
that connects all three of the axes.  Clicking on the light-grey area will switch the TransMagic
view to that plane.  For example clicking the light-grey semi-circle between the Z & Y axes will
switch the TransMagic view to that viewing plane.  Once in that view clicking on the light-grey ZY
disc will reverse the view on that plane, i.e. Front/Back, Right Side/Left Side, Top/Bottom.  To
switch back to the isometric view at any time click the center dark-grey portion of the disc.

After using this tool for a little bit you will find that you can very quickly switch between all of the
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standard six views: Top, Bottom, Right, Left, Front, Back.

-o-
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TransMagic Hot Keys

There are numerous ways to interact with TransMagic, one of the more efficient ways, with
experience is with Hot Keys.  Hot Keys are keyboard commands that take the place of mouse
clicks and menu options.  Once you became proficient with TransMagic's Hot Key mappings you
could practically turn off all TransMagic icons and run the program with just a large document
window and Hot Keys.

First of all, there are the Function Keys along the Top Row F1 - F12.  The most used functions in
TransMagic are mapped to these function keys.  Then the another group of often used functions
are mapped to SHIFT + F2 through SHIFT + F11.  These function mappings are as follows:

 F1 = Help | Launch the TransMagic Help Docs

 F2 =  Single Select | Select a single part, surface, cutting plane etc. in TransMagic.

 F3 =  Window Select | Draw a rectangular window around a collection of objects in a
document and select them all at once.

 F4 =  Set Color Filter | Set a Color filter for selecting parts of a certain color.  This is
especially useful when you bring in a surface model assembly that contains many parts of
different colors that need to be stitched into solids.  You must first select a part with the color

you want to filter.  Then click either the  Single Select or  Window Select functions
to select the Bodies\Faces of that color.  Only entities of the color specified in the filter will be
selected.

 F5 =  Clear Color Filter | The Color Filter is active until cleared by clicking the Clear
Color Filter function.  Once you're done using the Color Filter, use this function to clear the
Color Filter and turn the filter OFF.

 F6 =  Top | Orient the display to the top view. 

 F7 =  Front | Orient the display to the front view. 

 F8 =  Right | Orient the display to the left view. 

 F9 =  Iso | Orient the display to an isometric view.

 F10 =  Orbit | Select Orbit, depress left mouse button and slide across the screen to
rotate the view.
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 F11 =  Zoom | Select Zoom, depress left mouse button and slide the mouse up and
down to zoom in and out on the view. 

 F12 =  Pan | Select Pan, depress left mouse button and slide the mouse across the
screen to laterally position the view. 

 SHIFT + F2 =  Lite Repair | Run Lite Repair on the current selection.  See the Lite
Repair section for more information.

 SHIFT + F3 =  Full Repair | Run Full Repair on the current selection.  See the Full
Repair section for more information.

 SHIFT + F4 =  Show T-Edges | Highlight (in red) the "T-Edges" or Tolerant Edges the
current selection. This is a good measure of the accuracy of the model. After Full Repair you
should see the number of gaps go down and in many cases go to zero. No T-Edges means
that the surface boundaries of adjacent surfaces intersect precisely. T-Edges are OK and your
translations will be successful; however, less T-Edges will generally mean better performance
in downstream applications.

 SHIFT + F5 =  Move | Click Move to transform the selected entity(ies) by dragging the
left mouse button. Note, the translation direction will always be horizontal to the view
direction. To perform a "perfect" lateral or vertical transformation, try selecting one of the

standard views from the View Tab, Operations Group.  Then select  Orthographic from
the Rendering Group.

 SHIFT + F6 =  Change Color | To change the color of a part or collection of parts, click
Change Color. A standard Windows color dialog window will then be displayed for your to
manipulate the colors.

 SHIFT + F7 =  Scale | Click Scale to apply a scaling factor to the selected entity(ies).
Sometimes an exporting application can inadvertently write out a model scale larger or
smaller than what the part was designed in. This results in a part being translated into
TransMagic very large or very small. For example a part designed in mm that was 100 mm
long and written out to Meters would come into TransMagic as 100 Meters long! In this case
applying a scaling factor of .001 would bring the part back down to mm.  Another useful
feature of scaling is that it allows for non-uniform scaling entries.  This can be used to
accommodate different shrinkages when building molds for parts.

 SHIFT + F8 =  Section Planes | Launches the Section Planes dialog.  For more
information see Section Planes under this section.
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 SHIFT + F9 =  Display B-Box | Select Display B-Box to create a transparent bounding
box that encompasses the selected entity(ies). This box will show the precise dimensions of
the box. This function is useful in determ ining the minimum material required to machine a
part for example.

 SHIFT + F10 =  Mass Props | Calculate a Body's volumetric mass properties.  See
Mass Properties for more information.

 SHIFT + F11 =  Surf Area | Select Check Surface Area to get the selected part or
face's surface area.

 Alt+T =  Auto Repair Wizard | Run the Auto Repair Wizard on the active document.
See the Auto Repair Wizard section for more information.

 Ctrl+A =  Select All | Select all currently displayed entities in the active document.

 Ctrl+C =  Copy Image | Select Copy Image to capture a bitmap image of the currently
selected document. You can now paste this bitmap into any applicable application.  Use 
Ctrl+V to paste the copied image into another document.

 Ctrl+N = New | Create a new document.

 Ctrl+O =  Open... | Read in a supported file type.

 Ctrl+P =  Print... | Send the active document to a printer.

 Ctrl+S =  Save As... | Save the active document to a supported file format.

 Ctrl+G =  Group | Select a collection of bodies, then select the Group to combine the
parts into a single selectable part.

 Ctrl+U =  Ungroup | To ungroup a collection of parts that have been grouped simply
select the group, then select Ungroup. This will separate this collection of "lumps" into
individual parts that can be selected individually.

 Alt+A =  Zoom All | Zoom all the parts in the view so that they all fit in the view. 

 Alt+I =  Zoom | Select Zoom, depress left mouse button and slide the mouse up and
down to zoom in and out on the view. 
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 Alt+O =  Orbit | Select Orbit, depress left mouse button and slide across the screen to
rotate the view.

 Alt+P =  Pan | Select Pan, depress left mouse button and slide the mouse across the
screen to laterally position the view. 

 Alt+S =  Zoom To Selection | After first selecting something, select Zoom To Selection
Icon and the view will update to contain all the selected items centered in the view. 

 Alt+Z =  Zoom To Window | Click button then left mouse button and drag to create
rectangular window in the view, then release the mouse button. The view will then update to
reflect the contents of the window. 

 Del =  Delete Selection | Click  Delete Selection to permanently  delete the
selection.

-o-
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Auto Repair Wizard
When you open a geometric file in TransMagic, the first thing you'll notice is that immediately
after the part has been opened an interrogation process starts.  This process is the Auto Repair
Wizard.  TransMagic is automatically analyzing the geometry that was just opened and is
determining what, if any, additional steps may need to be taken to get the geometry into a high
quality and useable state.

The beauty of the Auto Repair Wizard is that the best course of action is to follow the
recommendations by simply clicking a single button.  Decades of TransMagic  industry knowledge
and expertise are built into this easy to use wizard.

Another nice feature is that Repair operations are only applied to the parts that require them. 
This is a huge time saver as you don't have to check each part individually of a large assembly as
the Auto Repair Wizard will do so.  Different parts may require different levels of Repair as well
which will also be determined by the Auto Repair Wizard.

The Auto Repair Wizard has three states:

The Green Light
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As the wizard states, your file looks good, you can now proceed to work with the file with
confidence whether you're quoting, creating illustrations or translating the file out to another
format.

The Yellow Light
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This state has a different meaning for Solids, Surfaces and Sheet-Bodies:

Solids: For Solids this state means that issues were found with the file but they are not critical
issues.  They are issues that will likely not affect downstream operations.  However, the
recommended course of action at this stage is to perform the recommended action which is Lite
Repair.  See the Lite Repair documentation for more information.

Surfaces: For Surfaces this state means that a surface model was loaded and the first
recommend action is Lite Repair.  In addition to correcting error, a primary function of Liter
Repair is to stitch surfaces into solids automatically.  See the Lite Repair documentation for more
information.

Sheet-Bodies: A Sheet-Body is a collection of surfaces that have been stitched together but they
do not form a solid.  Sometimes this is intentional but most of the time a sheet-body is the result
of missing surfaces.  Missing surfaces are usually the result of a defect in the translator that
created the file.  TransMagic is able to easily Repair these conditions as well with it's
MagicSURFACE technology.  If there are missing surface they will be identified by the Auto Repair
Wizard as "un-stitched edges".  For more information about MagicSURFACE see the Advanced
Tab  documentation.
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The Red Light

This state means that severe issues have been found that will most likely affect downstream
operations and even TransMagic operations.  The recommended course of action at this stage is
to perform the recommended action which is either Full Repair or Advanced Full Repair.  See the
Full Repair documentation for more information.  Advanced Full Repair is only accessible from the
Auto Repair Wizard dialog as it is only necessary in very specific cases.  Advanced Full Repair is
also resource intensive as it does a complete analysis and Repair to every single face (surface) in
the parts that need the Repair.

Additional Notes:
 Notice on the bottom of the dialog "Don't show this dialog during File Loading".  You disable

Auto Repair Wizard during File Loading by checking this box.  

 You can always run the  Auto Repair Wizard from the Home Tab.  Also, if you manually

run  Lite Repair or  Full Repair on a part or assembly, the Auto Repair Wizard
geometric checking and validation functionality will be run automatically afterwards. 
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However, you can also turn off the Auto Repair Wizard by selecting  Settings on the
Home Tab, Repair Page.

 If you turn the Auto Repair Wizard off entirely then TransMagic will operate in a "classic" state
as it has for all previous versions of TransMagic.  This means that instead of the Auto Repair
Wizard, you will see Repair logs and Check Part logs displayed after those operations.

-o-
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New User Tips

 The goal of TransMagic is to be a simple, easy to use and deceptively powerful application for
the translation, visualization & measurement of geometric formats.  Geometric translation is
an extremely intensive process mathematically speaking.  Because of this TransMagic can
consume a large amount of resources during the translation of very large and complex files.

 RAM: TransMagic does not have very heavy processor requirements; however, if you are
dealing with very large files, then you will need a fair amount of RAM.  The rule of thumb is
10x the file size.  In the case of your *.CATProduct assembly for example, this means the size
of the *.CATProduct files plus all of the subordinate *.CATPart files.  So if this total is 200 MB,
you will want to have 2 GB of free RAM.  For even larger files you will want to be sure to use
64-bit TransMagic on a 64-bit native machine and operating system.

 TransMagic includes some very powerful Repair Operations - that when used properly will

help to increase your translation success.  In most cases running the  Auto Repair
Wizard will resolve the majority of all geometric issues fully automatically.

 When translating files consider the application you're getting the file from and the application
you're translating the file to.  When-ever possible use the native file format from the
application you're getting from your customer or vendor.  If they use Pro/E, UG/NX, CATIA
V4, CATIA V5, SolidWorks or Inventor then ask for their native file.  Likewise if they use
SolidEdge, MasterCAM, Visi, or any other Parasolid based application, then ask them for a
Parasolid (*.x_t) file.  If they use AutoCAD, Mechanical Desktop, CADKEY, IronCAD or any
other ACIS based application, then ask them for a ACIS (*.sat) file.

 Use STEP only if no other solid format is available.  Use IGES as your last resort.  If you must
use IGES, see if your customer/vendor has the option to write out an IGES file as an MSBO
(Manifold Solid Boundary Object).  This option is not often available in most IGES writers but
if it is, it's at least a solid IGES format.  The best IGES reader in the world can't help if the
IGES writer created a terrible IGES file.  Unfortunately, this is very often the case.

 Finally, consider the application you're *translating a file to and use the same methodology of
native file formats where possible and then STEP and lastly, IGES.

 This "Native Format Philosophy" will always yield better results than just trying an IGES file to
see how it works.  Save yourself some time and pain and try to get the native format.

 The TransMagic interface has many options that will turn themselves "off" and "on" based on
your selection.  This reactive style interface helps to guide you in learning which functions
work for which selection types.  If a function is not highlighted try selecting an entity.  If it's
still not highlighted then it requires a different selection type like Face, Edge or Vertex.

 You can export individually selected entities or sub-assemblies using the  Export
function.  This is useful for example when you want to extract a single part or sub-assembly

out from a larger assembly.  Whereas  Save As... saves everything in the active

document to a file,  Export... saves only what you have selected.

 When you're looking at file in TransMagic, you're looking at a "TMR" file.  If you ever want to
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save your current progress or even free up some memory by shutting down and re-starting
TransMagic, you can always save to a TransMagic *.tmr file.  The TransMagic TMR format
stores all features that TransMagic currently supports and even undo/redo information.  Also,
the TMR formats, regardless of the size typically restores in seconds vs. minutes like a typical
translation.

 If you ever need to terminate a translation that TransMagic is working on, simply click on the
"Cancel" button in the progress bar.

 If you run into a problem file please submit it to us for review.  Go to www.transmagic.com,
click Support, then Request Support.  This form allows you to securely upload up to 300MB of
data to us along with a description of the issue.

 TransMagic welcomes your Tips and Tricks. If you have a useful Tip or Trick, please send it to
support@transmagic.com and we may add it to this list.

-o-
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TM Ribbon Interface
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Tweak Your TM

Toolbar Customization
Quick Access Toolbar:

The default menu for the Quick Access Toolbar includes the following functions & menu items:

 Settings Button | Launch the Settings Pages dialog.  This is where in TransMagic all
system options for visualization, application function, and translation settings are defined and
stored.  See the Settings Pages section for more information.

 Help Menu
o Help | Launch the TransMagic Help Docs.
o About... | Launch the About TransMagic Dialog which displays information about

technology that TransMagic uses as well as your license configuration.
o Update License Key | Launch the "Update License Key" dialog box.  You can then

upgrade your TransMagic license by entering your new License Key.  Contact your
salesperson to obtain an upgrade to TransMagic.

o Visit TransMagic.com | Visit TransMagic.com - Selecting Visit TransMagic.com will
launch your browser and navigate to www.transmagic.com.

o Reset V5 Environment | When there are other CATIA V5 installations on your
system, TransMagic uses it's own TransMagic V5 Environment which tells our V5
translator where to find it's own files and DLLs.  When TransMagic is run  a
"TransMagic V5 Environment" will be established for which-ever user account is
running TransMagic.  On rare occasions this TransMagic V5 Environment can be
corrupted.  If you run into any issues reading or writing CATIA V5 files, running this
function will re-set the TransMagic CATIA V5 Environment and correct the issue.

 You can customize the Quick Access Toolbar by adding your own often used functions to it
using the Toolbar Customization menu.

Toolbar Customization Menu:
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 Selection | Turn the Selection Toolbar On\Off in the interface.
 Settings | Turn the Settings Pages button On\Off in the Quick Access Toolbar.
 Help | Turn the Help Menu On\Off in the Quick Access Toolbar.
 More Commands... | Launch the Customize Dialog.  This dialog allows you to create toolbars

of your own or edit existing toolbars.  See the Customize Dialog top for more information.
 Show Below the Ribbon | Move the Quick Access Toolbar below the ribbon:

o

 Minimize the Ribbon | Minimize the Ribbon tabs into just their headings.  When you select
any of the headings the tabs will temporarily appear allowing you select functions on the
tabs.



p23

TransMagic R10 User Guide

© TransMagic Inc, 2013

o ...

Application Group:

 On the upper right hand side of the Home Ribbon is the Application Group.  This group
provides three options to help maximize your screen real estate:
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 View Status Bar | Turn On\Off the status bar along the bottom of the TransMagic window.
The status bar provides extra instructions when functions are highlighted.

 Show Workspace | The Workspace is the currently open document represented by a tab
with the name of the file that's open.  You will have several tabs when several documents are
open at once.  Unchecking the Show Workspace box will remove these tabs.  To move
between these tabs you can select the documents on the View tab by tiling the windows
horizontally or vertically and maximizing your desired document.

 Selection Toolbar | Turn On\Off the Selection Toolbar on the left hand side of the screen.

-o-
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About TransMagic Dialog

TransMagic License Properties

Expiration Date - The date at which your license currently expires.

Configuration - Your current TransMagic configuration.

Translation Units - How many Translation Units you have remaining.

-o-
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Customize Dialog
The Customize Dialog is where you can create your own toolbars or edit existing TransMagic
toolbars.  Let's take a look at the dialog:

Toolbar Tab:

 Here is where you will create your own toolbars.  You cannot do anything with the TM Ribbon
bar - the ribbon is "read only".  It can be minimized but not changed.  The Selec tion toolbar
cannot be removed either but it can be disabled by unchecking it.

 New... Button | Create and name your own toolbar(s).  After creation these toolbars will
show up on the upper left of the interface underneath the ribbon.  Initially the will not contain
any functions.  Those will be added from the Commands tab.  Note when a custom toolbar is
highlighted the Rename... and Delete buttons are enabled.  These functions apply to custom
toolbars but not the standard TM Ribbon or Selection toolbars.
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o

 Rename... | Rename a custom toolbar.  This function applies to custom toolbars but not the
standard TM Ribbon or Selection toolbars. 

 Delete | Delete a custom toolbar.  This function applies to custom toolbars but not the
standard TM Ribbon or Selection toolbars. 

 Reset... | Reset the standard TM Ribbon or Selection toolbars.  This function does not apply
to custom toolbars.

Commands Tab:
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 The Commands tab is where you will drag commands to your custom toolbars or you can also
add commands to the standard Selection toolbar.

 The Categories on the left hand side are groups of operations and the Commands on the right
side are the commands in the currently highlighted group.

 You may have noticed already that you can drag and reposition your custom toolbar (or the
Selection) toolbar.  Here we have repositioned our "Custom Toolbar #1" created above and
dragged some commands to it from the Commands bar.
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o

 This new toolbar and all the commands in it will be available every time TransMagic starts. 
You can also disable your toolbars temporarily by unchecking them in the Toolbar tab.

 You can remove functions on your toolbars when the Commands tab is open.  To do this
simply drag the unwanted icon into th TransMagic window and it will be removed.

Quick Access Tab:
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 The Quick Access Tab allows you to add or remove functionality from your Quick Access
Toolbar.  The commands are broken up into groups of functionality.  The "Choose commands
from" menu allows you to select groups of functionality and listed below that are the functions
available in that group.

 The right hand side shows the current standard Quick Access functions Start & Help.  You can
highlight items on the left hand side and click the Add button to move them over to the Quick
Access Toolbar.

 Conversely you can highlight functions currently on the Quick Access Toolbar and click the
Remove button to remove them.

 Reset | Reset the Quick Access Toolbar to its default state of Settings & Help.
 Show Quick Access Toolbar below the Ribbon | As the title suggests this, checking this

will move the Quick Access Toolbar below the Ribbon.

-o-
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Interface Customization
Interface Menu:

 Along the upper right hand side of the TransMagic Ribbon you will find the Interface menu. 
This menu provides several options to customize the look & feel of your TransMagic interface.

Style Submenu:

 The Style submenu allows you to play with the look and feel of your TransMagic.  Each one of
these "skins" will change the appearance of:

o The Ribbon style and color.
o The Window background gradient colors.
o Dialog, button, check & radio styles.
o Progress meter styles.
o Let us know your favorite!

Language Submenu:
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 The Language submenu allows you to select languages other than English.  Currently
supported languages are:

o English
o German
o French
o Spanish
o Portuguese
o If you are fluent in any language other than English and you notice a typo or if a

phrase\sentence doesn't quite make sense please let us know.
o Throughout the R9 series we will be adding more languages including:

 Italian
 Japanese
 Chinese

-o-
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TM Start Menu

Collaboration Guide 

TransMagic provides the ability to link to other computers for the purpose of sharing 3D models
in a Collaboration Session over a network or the Internet. It is an excellent presentation tool.
Despite the detailed instructions below, this is very easy to do. Geometry Repair will not share in
a session, therefore we recommend that you use models that show the quality you wish to
share. 

How to run a Collaboration Session using TransMagic over a
network: 
To launch and run a TransMagic Collaboration Session over a network, follow the same steps as
for over the Internet, except for the need to map to the leader's IP address. The TM Collaboration
Server must be running on a computer on the network so that it is “visible” to the computers
involved in the Collaboration Session. The TM Collaboration Server applet is launched from your
Windows Start Menu under Start->All Programs->TransMagic RX->TM Collaboration Server. 

How to run a Collaboration Session using TransMagic over the
Internet: 
Important Note: The computers involved in the Collaboration Session must each have a license of
TransMagic installed. To start the session, one person must launch the TM Collaboration Server.
That person will be referred to as the “Leader” in this document. All other parties will be referred
to as “ Remote Clients.” 

To Launch and run a TransMagic Collaboration Session over the Internet, follow the steps below: 

1) The Leader of the Collaboration Session should first Launch the TransMagic Collaboration
Server. 

Launch the TM Collaboration Server by clicking Start->All Programs->TransMagic RX->TM
Collaboration Server. A dialog box will open indicating that the Collaboration Server is running.
This can be minimized (and forgotten about until the session is complete). 

2) If TransMagic isn't already running on the collaborators computers, it should now be
launched. 

3) Start a Collaboration Session.  From the TransMagic Start Menu, select Collaborate. The
Network Options dialog box will open:
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4) Inside the Network Options dialog box, the Leader should then enter the IP address of his/her
computer then click on the Connect button.  When successfully connected to, a Dialog box will
pop-up indicating that the "Connection to server up" will appear:

Note: The Leader will need to know the IP address for his computer. (If you do not know your IP
address or if it changes every time you connect to the Internet, it can be determ ined by clicking
the MS Windows “Start” button then click “Run” to get a Command Prompt. Type in the dialog
box “cmd” and press <Enter>. At the Command Prompt type ipconfig and press <Enter>.
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Use of the TM Collaboration Server does not require that anything be entered in the following
fields of the “Network Controls” Window: Server Port (default 11111), Server Admin Pwd, or
Server Access Pwd.

5) Once the connection is up, the Leader should then assign a “Session Name”, “Client Name”
and optional Session Pwd (Password). The Leader should provide this information to the Remote
Client(s).

Note: Do not use spaces in the Session Name or Client Name. 

6) Remote Client(s) should Login to the Collaboration Session. In order for remote Clients to
login to the Collaboration Session, first enter the Leader's IP address, then click on the connect
button. Once connected, select (highlight) the Session Name from the Session window, then
enter a Session Pwd (Password), if any, and a Client Name. Once complete click the “Join”
button. A TransMagic Window will open with information showing the participants and a chat
window. 

7)  Import a Model. The Leader can now  Import a model into the Session and begin to
show the geometry by rotating, zooming, etc to the areas of interest. To do so he MUST use the 

 IMPORT command and then locate the file. The model can be displayed shaded mode
hidden line or wireframe. If an assembly is being viewed, parts may be moved or deleted as
desired. 

Note: The Leader has Control of the Session until it is “Released”. If a Remote Client wishes to
take control of a Session, he/she can click the “Request Control” button. The Leader will get a
message saying that a Remote Client has “Requested Control”. The Leader then can click the
“Release Control” button to allow the Remote Client to take control of the Session. The Remote
Client can manipulate the view locally during a Session, but others will not see these changes in
the Session. A Remote Client can save a file used in a Collaboration Session by clicking File, Save
As and give the file a name. The file will be a polygonal model of the *.hsf type. An HSF file
cannot be translated into a solid model. 

8) To Chat, type your text message in the space provided and press the <ENTER> key. At the
present time you will not see your own text message but will see the other participants messages
displayed in the chat window. 

Note: Not all TransMagic functionality is implemented for a Collaboration Session.

-o-

 



p36

TransMagic R10 User Guide

© TransMagic Inc, 2013

Ribbon Tabs

Home Tab

File Group:

 New | Create a new document. This differs from Open in that you can use 
Import to read in multiple disparate parts into a single document. For example if you create

a New document, you can now use Import to read IGES, STEP, Pro/E, Catia, etc.

parts all into the same document. You can then use  Save As… to translate all the
read-in parts to a new file format.

  Open... | Read in a supported file type.

o  Import | Import another file into the active document.  Limitations:

 CAD\geometric files can be imported into CAD\geometric documents.

 3D polygonal files can be imported into CAD\geometric documents.

 CAD\geometric files CANNOT be imported into polygonal documents.

  Save As... | Save the active document to a supported file format.

o  Export... | Export the current selection to it's own file.  This is useful for
example when you want to extract a single part or sub-assembly out from a larger

assembly.  Whereas  Save As... saves everything in the active document to a

file,  Export... saves only what you have selected.

  Close | Close the active document.

  Print... | Send the active document to a printer.
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o  Print Preview | Preview what will be sent to the printer in a window before
sending to the printer.

o  Print Setup | Launch the Print Setup dialog for your printer.

Selections Group:

  Single Select | Select a single part, surface, cutting plane etc. in TransMagic.

o   Body Level Selection | Selecting Body will enable the selection of only Bodies.
Bodies are the default general selection type in TransMagic and after many operations

the Filter Selection will switch back to  Body selection mode.  When a Body is
selected in TransMagic the interface will react by highlighting only the functions that
apply to that selection type.

o  Face Level Selection | Selecting Face will enable the selection of only faces.
When a Face is selected in TransMagic the interface will react by highlighting only the
functions that apply to that selection type. 

o  Edge Level Selection | Selecting Edge will enable the selection of only edges.
When an Edge is selected in TransMagic the interface will react by highlighting only
the functions that apply to that selection type. 

o  Vertex Level Selection | Selecting Vertex will enable the selection of only
vertices.  When a Vertex is selected in TransMagic the interface will react by
highlighting only the functions that apply to that selection type.

 Note: Vertices are not shown by default.  To enable the showing of vertices and
therefore the selection of them right-click anywhere in the window and select
Show->Vertices or click the Show Vertices button on the View Tab, Rendering
Group.

o  Select Only Solid Bodies | This is an additional selection filter that can be
applied where only enclosed solid bodies will be filtered for selection.

o  Select Only Surface Bodies | This is an additional selection filter that can be
applied where only bodies with open edges will be filtered for selection.  These bodies
can be individual surface bodies or sheet-bodies.

o  Select Only Wire Bodies | This is an additional selection filter that can be
applied where only wire-body independent edge bodies will be filtered for selection.
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  Window Select | Draw a rectangular window around a collection of objects in a
document and select them all at once.

o   Body Level Selection | Selecting Body will enable the selection of only Bodies.
Bodies are the default general selection type in TransMagic and after many operations

the Filter Selection will switch back to  Body selection mode.  When a Body is
selected in TransMagic the interface will react by highlighting only the functions that
apply to that selection type.

o  Face Level Selection | Selecting Face will enable the selection of only faces.
When a Face is selected in TransMagic the interface will react by highlighting only the
functions that apply to that selection type. 

o  Edge Level Selection | Selecting Edge will enable the selection of only edges.
When an Edge is selected in TransMagic the interface will react by highlighting only
the functions that apply to that selection type. 

o  Vertex Level Selection | Selecting Vertex will enable the selection of only
vertices.  When a Vertex is selected in TransMagic the interface will react by
highlighting only the functions that apply to that selection type.

 Note: Vertices are not shown by default.  To enable the showing of vertices and
therefore the selection of them right-click anywhere in the window and select
Show->Vertices or click the Show Vertices button on the View Tab, Rendering
Group.

o  Select Only Solid Bodies | This is an additional selection filter that can be
applied where only enclosed solid bodies will be filtered for selection.

o  Select Only Surface Bodies | This is an additional selection filter that can be
applied where only bodies with open edges will be filtered for selection.  These bodies
can be individual surface bodies or sheet-bodies.

o  Select Only Wire Bodies | This is an additional selection filter that can be
applied where only wire-body independent edge bodies will be filtered for selection.

  Select All | Select all currently displayed entities in the active document.

  Deselect All | Deselect anything that is currently selected in the active document.

  Set Color Filter | Set a Color filter for selecting parts of a certain color.  This is
especially useful when you bring in a surface model assembly that contains many parts of
different colors that need to be stitched into solids.  You must first select a part with the color

you want to filter.  Then click either the  Single Select or  Window Select functions
to select the Bodies\Faces of that color.  Only entities of the color specified in the filter will be
selected.
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  Clear Color Filter | The Color Filter is active until cleared by clicking the Clear Color
Filter function.  Once you're done using the Color Filter, use this function to clear the Color
Filter and turn the filter OFF.

Repair Group:

  Auto Repair Wizard | Run the Auto Repair Wizard on the active document.  See the
Auto Repair Wizard section for more information.

  Lite Repair | Run Lite Repair on the current selection.  See the Lite Repair section for
more information.

  Full Repair | Run Full Repair on the current selection.  See the Full Repair section for
more information.

  Show T-Edges | Highlight (in red) the "T-Edges" or Tolerant Edges the current
selection. This is a good measure of the accuracy of the model. After Full Repair you should
see the number of gaps go down and in many cases go to zero. No T-Edges means that the
surface boundaries of adjacent surfaces intersect precisely. T-Edges are OK and your
translations will be successful; however, less T-Edges will generally mean better performance
in downstream applications.

  Show Open Edges | Show all open edges in all visible entities.  This function will allow
you to visually inspect where open holes are in  a part.  If TransMagic reports that there are
open edges then you may need to apply Semi-Auto Repair using the MagicSURFACE tools or
you may need to delete or hide geometry. 

Browser Group:

  Assembly Browser | Launch the TransMagic Assembly Browser.  See the Assembly
Browser section for more information.

 Hide Selected Entities | After first selecting a  Body or  Face, select this function

to the selection from the view.   Bodies will be hidden in the  Assembly Browser

while  Faces will  only be hidden temporarily until you select  Redraw Faces or
CTRL+R.

 Show All | Show All hidden  Bodies and  Faces.

 Redraw Faces | Show any temporarily hidden  Faces.
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Application Group:

  Settings | Launch the Settings Pages dialog.  This is where all TransMagic system
options for visualization, application function, and translation settings are defined and stored. 
See the  Settings Pages section for a more information.

 Show Status Bar | Turn the Status Bar On\Off.  See the Toolbar Customization section for
more information.

 Show Workspace | Turn the Workspace tabs On\Off.  See the Toolbar Customization section
for more information.

 Show Selection Toolbar | Turn the Selection Toolbar On\Off.  See the Toolbar
Customization section for more information.

Special Group:
 Batch Translation | Launches the TransMagic Batch application.  TransMagic Batch is an

extremely powerful application embedded within TransMagic that allows the Batch translation
of any number of various parts from one format to another.  TransMagic Batch has it's own
documentation.  For more information launch TransMagic Batch and click the "Help" button.

 Special Menu | The Special Menu contains functions that are not easily categorized but may
provide a usefulness to you.

o Calculate Points to Part | The Calculate Points to Part function is a very handy
function for calculating and displaying an as-measured point data set against a CAD
model.  This function requires that you read the part and points into a single
document.  They can come in as a single document or you can use the File->Import
function to bring separate documents together.  To see the points (or vertices as
TransMagic considers them) right-click in the display and then select Show-Vertices. 
When invoked this function will ask you to create a log file - this will contain all the
measure points output.  Then the function will ask you to enter a deviation value to
calculate against and a precision value which determines the precision output
displayed in the log file.  Any points calculated outside of this deviation value will be
highlighted in the TransMagic window.  Finally an output window listing point
coordinates and distances to the part will be shown.  This window is displaying the log
file that was specified in a previous step.

o Output Part Names | To use this function you must first select a single or more parts
and then invoke this function.  You will be asked to specify a log file which will contain
all of the part names for the selected parts.

o Convert To Polygon Point Mesh | A Polygon Point Mesh, also known as a PPM
converts the rendering display triangles to geometric triangular faces.  The result is a
polygonal solid approximation of the original CAD file.

-o-
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Assembly Browser

The Assembly Browser uses easily recognizable icons to identify the following entities:

  Assembly\Sub-assembly

  Part

  Body

  Face

  Edge

  Vertex

  PMI



p43

TransMagic R10 User Guide

© TransMagic Inc, 2013

  Unknown

The Assembly Browser is useful for numerous reasons. Not only is it a good way to view the
structure of a Part or Assembly but when performing Repair operations, it can be very helpful for
selecting individual parts that you want to perform operations on such as Repair, Delete, Move,
etc.  

Also, try loading in a part, opening the  Assembly Browser, check "Always Zoom to
Selection", and then select the first part in the list. You'll see the view zoom into the selected
part. Now use your up or down arrows to cycle through the parts in the assembly. 

When a single part is in the display expand the  Body tree control and again, use the

keyboards up and down arrows to cycle through the part's  Faces.

If the part had a name in the file that was translated into TransMagic, then you will see that
name in the Browser.  If not you will notice that TransMagic will give it an arbitrary name based
on the file name.  For multiple parts TransMagic will give the part's names with an appended (1),
(2), (3), etc. simply numbered in succession for all parts.  You can change the name of the part
at any time by selecting the part and then Right-Click, and then select Change->Rename Part. 
The Change Name function is also available on the Operations Tab.  This new name will now
travel with the part in it's new format.

If the original model had parts on a certain level, this will be displayed in the TransMagic
Assembly Browser preceding the part name in brackets [].  For example, if a part named "Part 1"
were originally on level 100 in it's native CAD file format, this would be shown in the Assembly
Browser as "[L:100] Part 1".  While TransMagic does not currently have level manipulation tools,
the level information will be written to the output file format.

If a part is Hidden it will be identified by an un-checked box next to it in the Assembly Browser.

-o-
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Operations Tab

Delete:

  Delete Selection | Click  Delete Selection to permanently  delete the selection.

 

Change Group:

  Change Color | To change the color of a part or collection of parts, click Change Color.
A standard Windows color dialog window will then be displayed for your to manipulate the
colors.

  Colorize | Click Colorize to apply a random color to each part in the selection list.  This
is very useful when you bring a large assembly into TransMagic and all of the
sub-components are one single color.  Changing the color of all the parts helps to clearly
differentiate between parts in the assembly.

  Make Transparent | Click Make Transparent function to turn the selected parts
transparent.

  Undo Transparency | Click Undo Transparency function to turn transparent parts back
to solid parts.

  Move | Click Move to transform the selected entity(ies) by dragging the left mouse
button. Note, the translation direction will always be horizontal to the view direction. To
perform a "perfect" lateral or vertical transformation, try selecting one of the standard views

from the View Tab, Operations Group.  Then select  Orthographic from the Rendering
Group.

  Scale | Click Scale to apply a scaling factor to the selected entity(ies). Sometimes an
exporting application can inadvertently write out a model scale larger or smaller than what
the part was designed in. This results in a part being translated into TransMagic very large or
very small. For example a part designed in mm that was 100 mm long and written out to
Meters would come into TransMagic as 100 Meters long! In this case applying a scaling factor
of .001 would bring the part back down to mm.  Another useful feature of scaling is that it
allows for non-uniform scaling entries.  This can be used to accommodate different shrinkages
when building molds for parts.

  Flatten Assembly | In certain circumstances it can be beneficial to remove the
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assembly hierarchy of an assembly and convert it to a simple flat list of parts.  This function
does just that.  The parts will still be in the appropriate positions in space but the end result
will be a flat list of parts.  
Caution: One caution when using this function is RAM usage.  TransMagic handles
assemblies very efficiently and capitalizes on instances.  Instances are copies of parts or
even whole assemblies.  Take for example 1 single bolt copied/instanced in 100 different
locations.  TransMagic will represent the geometry of this bolt only once in memory and 99
locations.  When you flatten an assembly you will actually create 100 individual copies of
this bolt.  So one can see how this could cause RAM usage to spike, especially with
assemblies that have a large amount of instanced geometry.

 Change Name | Change Name will launch the Part Name dialog box:

Enter a new part name and click "OK" or "Cancel".  You can see part names in the

Assembly Browser which is accessible by clicking  Assembly Browser on the Home
Tab, Browser Group.

 Change Layer | Change the existing layer\level (if any) that a part or parts currently resides
on.  Enter a new layer number for your selection and click "OK".  Your parts will now be on
this layer\level when saved out to any format that supports layers\levels.  To visually see the

layer that your part or parts reside on open the  Assembly Browser and you will see in
front of the part name the notation [L:X], where "X" is the layer that your part is currently on.
If your part is currently not on a layer you will not see the [L:X] notation.

Inspect Group:

  Display B-Box | Click Display B-Box to create a transparent bounding box that
encompasses the selected entity(ies). This box will show the precise dimensions of the box.
This function is useful in determining the minimum material required to machine a part for
example.

  Mass Props | Click Mass Props to check:
o Cubic Volume
o Weight based on density via a catalog of materials or is user selectable material
o Center of Mass (CoM) and the ability to create a true geometric representation of the

CoM with planar intersection graphs.  The CoM is read/writeable to any supported
TransMagic format.

o Inertial Properties: Principal Axes of Inertia, Principal Moments of Inertia, & Inertia
Tensor.

o For a more complete description of the Mass Props function see Mass Properties under
this section.
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  Surf Area | Click Check Surface Area to get the selected part or face's surface area.

Note: To select an individual face, set your selection filter to  Face.  See the Selection
Toolbar section for more information.

  Section Planes | Launches the Section Planes dialog.  For more information see
Section Planes under this section.

  Query Model | The Query Model dialog box is useful for quickly checking the number of
edges and faces in a model.  Simply run your cursor in front of models to check their TM ID
number, their edge count, their face count and the analytic position of the surface in the
location of the mouse cursor:

 

Annotations & Dimensions Group:

  Delete Annotation or Dimension | When this tool is selected, any Annotation or
Dimension that you left-click on will be permanently deleted.

  Create Annotation | 

o Placement: Select the Annotation Tool. Left-Click anywhere on the part and then drag
the annotation text box to the desired location.

o Edit: Select the Annotation Tool. Left-Click on the text box and start typing. 

o Move: Select the Annotation Tool. Left-Click on the text box and move it to the new
location. 

  Text Markup | 
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o Placement: Select the Redline Tool. Left-Click anywhere on the screen. 

o Edit: Select the Redline Tool. Left-Click on the text box and start typing. 

  Free Markup | Select the Redline Sketch Tool. Left-Click anywhere on the screen and
drag. 

  Rect Markup | Select the Redline Rectangle Tool. Left-Click anywhere on the screen -
the first Left-Click is the upper left hand corner of the rectangle - drag the lower right corner
of the rectangle - stop when the desired size rectangle is reached.

  Circle Markup | Placement: Select the Redline Circle Tool. The first Left-Click will be
the center of the circle - then drag the mouse to form the radius of the circle - stop when the
desired size circle is reached. 

Note: Markups are different from annotations in that they are temporary visual elements
that will be erased when you rotate the view.

Note: You can temporarily save Markup views by using  Snapshots.  See
the View Tab, Snapshot Group for more information.

Note: You can change the color and line weight of the Markups in the  Settings area,

on the Appearance Page.   Settings can be found in the Application Group of the Home
Tab. .

  Interactive Dim | Start the Interactive Dimensioning mode.  For complete instructions
see the section Interactive Dimensioning under this section.

  Manual Dim | Create a manual dimension between two like selection types.  For
complete instructions see the section Manual Dimensioning under this section.

  PMI | This function will be enabled if the part you have loaded into TransMagic contains
PMI data.  The PMI data will be rendered in the same location it was found in the original file.

o This technology is available for CATIA V5, UG/NX and Pro/Engineer Read formats only.
It is not currently possible to write out PMI data.
 Currently the PMI data supported by TransMagic is as follows:

 General Dimensions 
o Length & Distance 
o Tangent, Cylindrical & Edge Radius 
o Angle, Arc Length & Dimension Slope Angular 
o Curvilinear & Circular Length 
o Ordinate 
o GD&T 

 Geometric Dimensioning 
o Manufacturing Tolerancing 
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o Surface Roughness 
o 3D Annotation (text) 
o Manufacturing Notes 
o Materials 
o Could be many things attached as 3D Annotations

 Your TransMagic License Key must support PMI data or this functionality will be
disabled. function.

 See also:

 The "Enable PMI Translation" option on the General Page of the 
Settings dialog.  When this option is checked TransMagic will translate
PMI data contained in the part file.  This is an optional function of
TransMagic and requires the appropriate License Key.

 The No Selection section & PMI Selected section under the Right-Click
Menu section.  Using the special PMI selection filter you can select and
orient your view to specific PMI elements.

 The  Split function on the View Tab, Window Group to create the
split window view as seen here:

TransMagic Displaying PMI Data with a Split Window:

-o-
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Mass Properties

The calculations performed when you click  Mass Props are as follows:

 Cubic Volume

 Weight based on density via a catalog of materials or is user selectable material

 Center of Mass (CoM) and the ability to create a true geometric representation of the CoM
with planar intersection graphs.  The CoM is read/writeable to any supported TransMagic
format.

 Inertial Properties: Principal Axes of Inertia, Principal Moments of Inertia, & Inertia Tensor.

After you invoke the Mass Properties a dialog box will appear as below:
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Volume and Mass
Volume | The volume of the part in cubic units.

Note: To change the units of the Mass Properties calculations click  Settings in the
Application Group of the Home Tab.  Units can be found on the General Page of the

Settings dialog.

 Mass | The mass of the part in mass units.  This value is based on the Material Density.
Changing the Material Density will change the value of this measurement.  See "Material Density"
under "Settings" in this section.
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Center of Mass
The Center of Mass is given in x, y, z coordinates.

Draw Center of Mass (CoM) | Click this button to draw a graphical representation of the Center
of Mass.  The graphic is 3 planes, the xy plane, the xz plane and the yz plane intersecting the
part at the Center of Mass.  If you Single Select the part and then right-click and select Hide
Selection, you'll notice that there is also a precise intersection graph that represents the 3 planar
intersections of the part and the CoM.  You can use these intersections to check edge
measurements, etc.  You can also save this CoM shape out to any supported file format.

Apply "Fudge Factor" If CoM Intersection Fails - Sometimes the Center of Mass planes
coincide identically with existing edges.  These coincident edges are especially common with
symmetrical parts and parts that were mirrored.  In certain cases this coincident geometry to the
intersection planes can cause the CoM intersections to fail.  The "Fudge Factor" will be invoked if
the intersection fails and it will allow you to slightly shift the CoM plane geometry so that the
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intersection will complete.  If the CoM planar intersection fails the following dialog will launch:

This dialog allows you to shift the CoM geometry via global X,Y,Z translations or by rotations
around X,Y,Z global axes.  You can apply any combination of translations and rotations.  These
settings will be saved when you click OK so you don't have to re-enter information every time
this dialog is launched.

Note: If the initial CoM intersection fails you may also want to consider applying  Full
Repair to the part first.  Many times the intersections fail because of precision issues at the
coincident geometry.  Running Full Repair on a part will virtually always increase precision
in these areas and will usually allow the CoM intersections to complete without applying a

Fudge Factor.

Settings
Material Density

Material | This pull-down box allows you to select various materials for your part.  Changing the
Material Density will change the value of the Mass measurement (weight) in the Volume and
Mass section.

Density | This is the value of the currently selected Material.

Enter Custom Density - Check this box if your Material is not in the pull-down list or if you simply



p53

TransMagic R10 User Guide

© TransMagic Inc, 2013

want to enter your own value.  By checking this you will disable the Material Density pull-down
and the system will default to .036 lb/in^3 which corresponds to the industry default of 1.0
gm/cm^3.  You can enter your own value in this box.

Note: After entering a new Custom Density you must click the Recalculate button in order
to update the Mass value calculation to the new Custom Density.

Recalculate | Click this button to update the Mass value calculation after entering a new Custom
Density.

Precision
Decimal Places | Use this pull-down box to change the decimal precision in all Mass Property
calculations from 2 to 6 decimal places.  This value is saved in the TransMagic system settings
and the next time you run a Mass Property calculation, it will calculate based on this precision.

Note: Changing the Decimal Place precision will affect processing time.  If you have a very
complex part and your Decimal Precision is set to 6 places, be patient as it may take a while to
calculate Mass Properties at this level of precision.

Calculate Inertia Properties | Checking this box will enable the calculation of the parts
Principal Axes of Inertia, Principal Moments of Inertia and Inertia Tensor.

Note: The Principal Axes of Inertia and the Principal Moments of Inertia are take at the
Center of Mass.

Note: Calculating the Inertia Properties of a part will add processing time to the Mass
Properties calculations.

Copy to Clipboard | Clicking this button will place all the Mass Properties of the dialog box in
tabulated form to the Windows clipboard.  

Note: The way TransMagic copies text data to the Windows clipboard is called Unicode and
it's very nice for pasting into office documents.  For example if you paste the copied data
from the TransMagic Mass Properties dialog box to a Microsoft Excel spreadsheet, Excel or

any other spreadsheet application will paste the data as a nicely columnized data set.

Reset Defaults | Click this button to reset the Mass Properties dialog box to it's original default
settings.

OK | Click this button when you are done reviewing the Mass Properties data.

-o-
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Section Planes

 

X-Axis | Click the X-Axis button to create a section plane that centered at the center of the part.
To position the cutting plane run your mouse over the Cutting Plane Manipulator graphical icon. 
As your mouse passes over the Cutting Plane Manipulator two rotational axis elements will
highlight or one linear translation element.  Left-Click on any of these graphical elem ents when
highlighted and drag to rotate or linear-translate the Cutting Plane.

Click the X-Axis button again to turn of the Cutting Plane.

Y-Axis | Click the Y-Axis button to create a section plane that centered at the center of the part.
To position the cutting plane run your mouse over the Cutting Plane Manipulator graphical icon. 
As your mouse passes over the Cutting Plane Manipulator two rotational axis elements will
highlight or one linear translation element.  Left-Click on any of these graphical elem ents when
highlighted and drag to rotate or linear-translate the Cutting Plane.

Click the Y-Axis button again to turn of the Cutting Plane.

Z-Axis | Click the Z-Axis button to create a section plane that centered at the center of the part.
To position the cutting plane run your mouse over the Cutting Plane Manipulator graphical icon. 
As your mouse passes over the Cutting Plane Manipulator two rotational axis elements will
highlight or one linear translation element.  Left-Click on any of these graphical elem ents when
highlighted and drag to rotate or linear-translate the Cutting Plane.

Click the Z-Axis button again to turn of the Cutting Plane.

Cutting Plane Manipulators | After you have positioned the Cutting Planes to your liking you
can hold SHIFT and click any  of the X, Y, or Z-Axis buttons to remove the Cutting Plane
Manipulator graphical icon for that plane - leaving just the plane itself and the cross-section it
generates.

Show Axis | Check this box to show a graphical axis element in the lower left-hand corner of the
viewing window.  This is helpful when you have rotated your part around and don't have a good
concept of which direction the X, Y, or Z axis are pointing.



p55

TransMagic R10 User Guide

© TransMagic Inc, 2013

Close | Close the dialog box.

-o-
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Interactive Dimensioning
When you select Interactive Dim you'll see the "Dimension Controls" window appear on the left
hand side of the TransMagic interface:

Dimension Orientation | Click on the "X", "Y" or "Z" button to orient your dimensions in that
reference plane.  To help visualize these planes click on the "Show Axis" check box.  Use the
"Dimension Spacing" to set your initial spacing.  Note that you can always freely click and drag
your dimensions to another position interactively.  This setting simply gives your dimensions a
guide for initial placement.  At any time you can change your spacing or orientation by clicking
on a dimension, and then clicking "Apply" to force that dimension into the spacing and
orientation settings you have chosen.

Interactive Dimension Behaviors | 

 As you move your mouse around the entities in the display you will notice that the applicable
selection types interactively highlight such as Face, Edge and Vertex.

 Click and drag from a Vertex to a Vertex, or a Face to a Face, or an Edge to an Edge to create
the dimension.

Note: Like types must be selected and dragged to create a dimension.  If you click on a
vertex and drag your mouse, for example, the final selection must be another vertex. 

Otherwise you will see the following message:
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 After creating the dimension you can easily move the dimension by simply clicking on the
dimension and dragging it to a new position.  A currently selected dim ension will highlight.
selecting the Cursor Pick Dimension Type, it's usage is as follows:  Select the Dimension Tool.
Left-Click anywhere on the part and drag - then release to show the dimension. 

 If you select a single radius edge then a radius dimension will created.
 If you click on one radius edge and then drag and click on another radius edge then the "Arc

Dimension Behavior" dialog will be launched and you will be prompted to select one of four
possible dimensions:

 If you click on one linear edge and then drag and click on another linear edge: If the edges
are parallel then a distance dimension will be created; however, if the edges are at an angle
to each other then this will launch the "Distance or Angle" dialog and prompt you to choose
which dimension type you wish to create:
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Clear Previous Dimensions | As the name implies check this box to clear any previous
dimensions.  Each time you create a new dimension the previous dimension will be cleared.  In
this way the Interactive Dimensioning interface becomes more of a real-time measuring
interface.

Show Axis | Check this box to show a graphical axis element in the lower left-hand corner of the
viewing window.  This is  helpful when trying to determine the initial dimension placement using
the "Dimension Orientation" function above.

-o-
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Manual Dimensioning

This function is necessary for certain types of dimensions.  When you click  Orbit,  Pan,

 Zoom, or  Window while in Interactive Dimensioning mode - to re-orient a part for
example - this means that your mouse is necessary for this orientation operation and thus
disables and takes control away from the Interactive Dimensioning mouse functions.  An example
of when this function is necessary:

 When you wish to create an overall dimension from a face on top of a part to a face on the
bottom of the part.  Selecting the top face is simple however in order to select the bottom
face the part must be rotated so that the bottom face can be selected.

 In this case Manual Dimensioning is required.

 Click the  Single Select icon.  Then set your selection filter to  Face.  Now you are
ready to select only Faces.  Selection and filter functions can be found on the Home Tab,
Selections Group or typically more conveniently on the Selection Toolbar.

 Click the Face on the top of the part, click the  Orbit icon and orient the part so the
bottom Face can be seen.  View orientation functions can be found on the View Tab, Camera
Group or typically more conveniently on the Selection Toolbar.

 Click the  Single Select icon, hold down the CTRL key on your keyboard and select the
bottom Face on the part.

 Click  Manual Dim to create the dimension.  The dimension will now be created.
 In order to move the dimension to a new location you must re-enter Interactive Dimensioning

mode by clicking  Interactive Dim.

-o-
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View Tab

Orientation Group:

  Top | Orient the display to the top view. 

  Front | Orient the display to the front view. 

  Right | Orient the display to the left view. 

  Iso | Orient the display to an isometric view.

 Bottom | Orient the display to the bottom view.
 Rear | Orient the display to the rear view.
 Left | Orient the display to the left view.

Camera Group:

  Orbit | Select Orbit, depress left mouse button and slide across the screen to rotate the
view.

  Zoom | Select Zoom, depress left mouse button and slide the mouse up and down to
zoom in and out on the view. 

  Pan | Select Pan, depress left mouse button and slide the mouse across the screen to
laterally position the view. 

  Cont...| Select Continuous Orbit, then use the Orbit function to rotate the view, then
release. The view will continue to orbit in the direction of rotation when the mouse button was
released. The speed of rotation depends on the speed that the mouse was moving when the
button was released.

Note: TransMagic supports 3D Connexion devices for camera manipulation.  See
www.3dconnexion.com for more information.

http://www.3dconnexion.com
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Zoom Group:

  Zoom All | Zoom all the parts in the view so that they all fit in the view. 

  Zoom To Window | Click button then left mouse button and drag to create rectangular
window in the view, then release the mouse button. The view will then update to reflect the
contents of the window. 

  Zoom To Selection | After first selecting something, select Zoom To Selection Icon and
the view will update to contain all the selected items centered in the view. 

Snapshot Group:

  Snapshot 1 | Hold down the SHIFT key and simultaneously select Snapshot 1. The
view will be captured in memory so that the next time you select Snapshot 1 (with-out
holding the Shift key), the view will return to the captured orientation with any Redlining you
may have saved as well.

  Snapshot 2  | Hold down the SHIFT key and simultaneously select Snapshot 2. The
view will be captured in memory so that the next time you select Snapshot 2 (with-out
holding the Shift key), the view will return to the captured orientation with any Redlining you
may have saved as well.

  Snapshot 3 | Hold down the SHIFT key and simultaneously select Snapshot 3. The
view will be captured in memory so that the next time you select Snapshot 3 (with-out
holding the Shift key), the view will return to the captured orientation with any Redlining you
may have saved as well.

  Copy Image | Select Copy Image to capture a bitmap image of the currently selected
document. You can now paste this bitmap into any applicable application. 

Rendering Group:

  Shaded | Shaded rendering.
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  Hiddenline | Hidden line rendering.

  Wireframe | Wireframe rendering.

  Phong | Phong rendering.

  Triangulated | Triangulated rendering. 

  Show Hidden Lines | Show occluded edges as dashed.  This only applies if 
Hiddenline rendering is active.  After you select Show Hidden Lines you may need to select 

 Redraw Window for the display to render correctly.

  Redraw Window | This is useful if you have a rendering artifact that appears incorrect.
Select Redraw  Window to re-render the active window. 

  Show Faces | By default part faces are shown.  Toggle to disable the visualization and
selection of part faces.  The result will appear as a wire-frame visualization if part Edges are
turned on.

  Show Edges | By default part edges are shown.  Toggle this to disable the visualization
and selection of part edges.

  Show Vertices | By default part vertices are not shown.  Toggle this to enable the
visualization and selection of vertices.

Window Group:

  New | Open New Window will create another Window of the currently selected
document.  You will notice at the top of the part the two windows will now have the suffix :1
and :2 indicating

  Split Window | Split Window will create 4 symmetric views in the current window.  You
can then treat each new mini-window as an independent window by rotating, zooming or
otherwise repositioning the parts in that particular quadrant.  When you move your mouse
over the window dividers your mouse icon will change - when this occurs you can hold down
the left mouse button and reposition the panes to resize the quadrants.  Also, when your
mouse icon changes you can double-click on the window divider which will remove that
particular window divider changing the view from 4 quadrants to 2 halves.  To remove the
dividers go back and select View->Split Window which will uncheck this option and remove
the dividers.
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  Tile Horz | Select Tile Horizontally to tile the currently open windows horizontally.

o Tile Vertically | Select Tile Vertically to tile the currently open windows vertically.

  Top Color | Select and show a color palette to change the gradient color of the top half
of the window.

o

  Bottom Color | Select and show a color palette to change the gradient color of the
bottom half of the window.

o

-o-
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Advanced Tab*

MagicSURFACE Group:

  Find Next | Select Find Next Open Edge function to find the next open circuit of edges.
This function is the first step in a MagicSURFACE Repair scenario.  This function will find one
of two types of edge circuits:

o A hole in a model - in which case the MagicSURFACE tools are the next logical tools to
cover the hole with a surface.  

o A disjoint surface floating in space which isn't the same as a hole in a model but it is
still considered an open circuit of edges.  In this case the MagicSURFACE tools will no
be applicable; however, you will have possibly identified a useless surface that you
may want to consider Hiding or Deleting.  Many CAD formats will include useless
construction geometry or duplicate surfaces when read into TransMagic.  This can be a
useful too for finding these surfaces and handling them appropriately by deleting or
hiding.

o Whether or not you decide to do anything with the currently highlighted open circuit of
edges, you can continue to click this button to cycle successively through all the open
circuits in a part.  This can be useful for first assessing what type of problems you are
dealing with before proceeding with Repair operations.

  Cover Selection | This function will not highlight until an open circuit of edges has first

been identified using the  Find Next function documented above.  After finding the next
open circuit of edges you would click this button to cover the open hole in a part with a
TransMagic MagicSURFACE.

o When TransMagic creates a surface, note the purple color of the surface.  This surface
color will travel with the model to the export format and it is your visual cue that the
surface was not created by the original CAD system.

o There are many possible surfaces that can be created by the MagicSURFACE tools. 
Pay attention to any messages that TransMagic will display.  In many cases these are
not error messages but rather information messages.  If additional steps are required
to completely Repair the open circuit then TransMagic will offer suggestions via these
messages.

  Set Smooth | This function is intended to be used concurrently with both the 

Cover Selection (above) or  Cover Circuit (below) tools.  When TransMagic creates a
MagicSURFACE it creates what is called a "minimum energy surface" - that is to say the
surface that requires the minimum amount of surface tension to cover the open circuit of
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edges.  However, if the open circuit you intend to cover was a missing radius blend surface,
for example, then it is likely that you want the replacement surface to include adjacent
surface curvature so that the new surface blends in smoothly with adjacent surfaces.

o If you select a single edge and then click this function it will automatically find the
entire open circuit and apply a "smooth" attribute to all of the edges in the circuit.

o TransMagic will identify edges marked with a "smooth" attribute by highlighting them
GREEN.

o If you don't want TransMagic to apply the "smooth" attribute to every edge in the
circuit then hold down the CTRL key and then click this function.  Holding down the
CTRL key while clicking this function will tell TransMagic to only apply the "smooth"
attribute to any currently selected edges.

o To select single edges in TransMagic, first right-click and set your filter selection to
Edge.

o To select more than one disparate edge at a time simply hold down CTRL while
selecting the edges.  The while still holding down the CTRL key, click this function and
it will apply the "smooth" attribute only to the selected edges.

  Set Sharp | This function is intended to be used concurrently with both the  Cover

Selection (above) or  Cover Circuit (below) tools.  All edges to be covered are
automatically considered "sharp" edges and thus don't need this attribute applied manually. 
However, during a MagicSURFACE Semi-Auto Repair operation it is possible that you m ay
have applied a "smooth" or "hole" attribute to an edge and you now want to remove that
attribute from a single edge or from selected edges.  This function will allow you to remove
any previously placed attributes on the selected edges with a "sharp" attribute - that is to say
"none".

  Set Hole Edge | This function is intended to be used concurrently with both the 

Cover Selection (above) or  Cover Circuit (below) tools.  You may encounter situations in
a MagicSURFACE Semi-Auto Repair session that you need to cover a circuit of edges with a
surface; however, there are other edge circuits that would normally exist as "holes" or
"pockets" in the surface that should not be covered.  You would use this function to identify
"hole" or "pocket" surfaces before you create the surface so that the MagicSURFACE that is
created takes into account these internal circuits and instead of covering them, leaves them
open.

o If you select a single edge and then click this function it will automatically find the
entire open circuit and apply a "hole/pocket" attribute to all of the edges in the circuit.

o TransMagic will identify edges marked with a "hole/pocket" attribute by highlighting
them LIGHT BLUE.

o If you don't want TransMagic to apply the "hole/pocket" attribute to every edge in the
circuit then hold down the CTRL key and then click this function.  Holding down the
CTRL key while clicking this function will tell TransMagic to only apply the
"hole/pocket" attribute to any currently selected edges.
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o One interesting feature of applying this attribute to a single edge would be that this
tells TransMagic, instead of this being an edge that belongs to a circuit representing a
hole, it tells TransMagic to create a surfaces that actually PASSES through this edge. 
This is a creative way to "constrain" a surface to pass through curves while being
created.

o To select single edges in TransMagic, first right-click and set your filter selection to
Edge.

o To select more than one disparate edge at a time simply hold down CTRL while
selecting the edges.  The while still holding down the CTRL key, click this function and
it will apply the "smooth" attribute only to the selected edges.

  Clear All | During a MagicSURFACE Repair session you may have applied, "smooth",
"hole/pocket" attributes to edges and decide that you'd like to clear them all at once.  Clicking
this button will remove any MagicSURFACE attributes attached to any edge.  This function will
only be enabled if there is an attribute to be removed.  This function can also be used to clear
out any and all selections in TransMagic - such as clearing out currently set "Split-Trim"
geometry.

  Cover Circuit | This function will not highlight until an edge belonging to an open
circuit has been selected.  After having selected an edge  from an open circuit, you would
click this button to cover the open hole with a TransMagic MagicSURFACE.

o When TransMagic creates a surface, note the purple color of the surface.  This surface
color will travel with the model to the export format and it is your visual cue that the
surface was not created by the original CAD system.

o There are many possible surfaces that can be created by the MagicSURFACE tools. 
Pay attention to any messages that TransMagic will display.  In many cases these are
not error messages but rather information messages.  If additional steps are required
to completely Repair the open circuit then TransMagic will offer suggestions via these
messages.

  Cover Hole or Boss | This is a special condition function that addresses a certain case
of surface covering.  It's possible to see a hole in the top of a surface that represents where a
bore or drill hole should be in the part.  You may also have the bottom surface of this hole;
yet the cylindrical sidewall surface of the bore is missing.  You would select one edge from
each side where the missing surface(s) should connect the two.  Then click this button to
create the cylindrical surface between the two.

o This function works not only with a cylindrical surface but also if you had all of the
surfaces of a pocket or boss missing.  You would still simply select one edge from each
side and TransMagic will automatically find all edges in the circuits and "skin" a
surface between each circuit.

o This function works even if there are not an equal number of edges on either circuit.

o TransMagic will split the surfaces into multiple surfaces if necessary to satisfy the
conditions and create a surface "skin" between both sides.

o If you don't want TransMagic to select the involved circuits automatically but just want
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TransMagic to create a "skin" surface between only the edges that you have selected
then simply down the CTRL key while clicking this function and TransMagic will create
the "skin" surface only between the edges you have selected.

  Recover Face | You may find that well surface may exist, they appear visually incorrect
and in need of replacement.  It is first recommended that you select the Face and then run

the  Full Repair function only on the face first.  If the surface is still visually incorrect,
then select the Face and then click this function to recover the face with a new, high quality,
MagicSURFACE.  If the face still appears erroneous, you should consider deleting the Face
altogether and then re-covering the open circuit with a new MagicSURFACE as covered in the
functions listed above.

  Show Open Edges | Click on the Show Missing Surfaces function to show all open
circuits in all visible entities.  This function will allow you to visually inspect where open holes
are in  a part.  If TransMagic reports that there are open edges then you may need to apply
Semi-Auto Repair using the MagicSURFACE tools or you may even need to delete or hide
geometry.

  Show Bad Geometry | The Show Bad Geometry function launches the Un-Repaired
Geometry Dialog.  This dialog highlights erroneous geometry that remains.  For more
information see the documentation for the Un-Repaired Geometry Dialog.

Geometry Group:

  Create Wire-Body | Wire-Bodies can be used as a "frame" for creating a free floating
surface.  To create a surface on a Wire-Body a Wire-Body must first consist of a closed loop of
Edges.  To use this function you must first set your selection level to Edge and then select a

chain of edges individually.  When doing so it is sometimes helpful to use  Zoom To

Window function and the set the view to  Wire-Frame mode.  When you have a

continuous loop of edges selected, the select  Create Wire-Body to create a Wire-Body.

Tip: You may create Wire-Bodies in TransMagic that do not form closed loops simply by

selecting one ore more edges and clicking the  Create Wire-Body Tool.

Note: When TransMagic creates a new Wire-Body, you can see find this newly created
entity by scrolling to the bottom of the Assembly Browser and looking for the name "TM

Wire-Body".

 Create Linear Edge | Use Create Linear Edge to create a linear edge between two vertices.
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Set your selection filter to  Vertex, select a vertex, press and hold CTRL down as you select
a second vertex.  Once two vertices are selected the Create Linear Edge button will be enabled. 
Select it to create a linear edge between the two vertices.

Note: When TransMagic creates a new edge, you can see find this newly created entity by
scrolling to the bottom of the Assembly Browser and looking for the name "TM Edge".

 Group | Select a collection of bodies, then select the Group to combine the parts into a
single selectable part.  This is very helpful when "piecing together" groups of surfaces that belong

to a single part for the eventual purpose of stitching them together with  Lite Repair.

 Ungroup | To ungroup a collection of parts that have been grouped simply select the
group, then select Ungroup. This will separate this collection of "lumps" into individual parts that
can be selected individually.

 Boolean Union | Select a group of bodies and then select Boolean Union to unite and
intersect them into a unified or several unified bodies.

Note: Although  Lite Repair is the recommended function for stitching surfaces into
existing parts, it is possible to stitch surfaces into  a part using Boolean Union too.

  Set Split-Trim | After first selecting a single Body, Face or Edge select Set Split-Trim.
The selection will highlight and indicate that it is now "Split-Trim" geometry by which you can
Split or Trim other Faces or Bodies against.  This is the first step in a Split/Trim operation. 
The second step will be to select the Face or Body to be Split/Trimmed, then select the
appropriate Split-Trim function below.

  Split Body | This function will Split the selected body by the previously set Split-Trim
geometry.

o  Trim Body | This function will Trim the selected body by the previously set
Split-Trim geometry.

  Split Face | This function will Split the selected face by the previously set Split-Trim
geometry.

o  Trim Face | This function will Trim the selected face by the previously set
Split-Trim geometry.

Note: After a Split-Trim operation the original body will be kept and hidden.  You can delete
this body in the Assembly Browser if it is no longer needed.

Note: You can select multiple Bodies or Faces to be split or trimmed against the Split-Trim
geometry.
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Undo/Redo Group:

  Record | Selecting Record will tell TransMagic to "record" Restore Points.  These
Restore Points will be recorded before any operation that will change or add geometry in the
active document.  During manual or Automatic Repair operations in TransMagic various
factors may contribute to affecting the geometry.  Restore Points allow you to change the
model without fear of trying different things as well as protecting against potential user error.

To recall a Restore Point select  Recall (Undo).

  Recall (Undo) | Select Recall (Undo) to recall a previously recorded Restore Point.
TransMagic will save up to and Recall up to 10 Restore Points.  

Tip: If for some reason TransMagic crashed while the Set Restore Point function was

enabled you can re-start TransMagic, open a New document (File->New) and click the 
Recall Restore Point function to restore the file to its state before the crash occurred.

Tip: Set Restore Point does consume additional processor resources so you may want to
consider this before leaving it on all the time.

Tip: Set Restore Point automatically creates TransMagic native *.tmr file in the users
"TEMP" directory.  You can always manually save your progress by creating your own *.tmr

file.

* Depending on your version of TransMagic you may not have access to the Advanced
Toolbar

-o-
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Selection Toolbar

 The Selection Toolbar contains very commonly used functions for selection and view
manipulation.

 The Selection Toolbar can be moved and is dockable on any side of the TransMagic interface.
 You can add or remove functions to the Selection Toolbar.  See the Toolbar Customization

section for more information.
 By default the Selection Toolbar includes the following functions:

  Single Select | Select a single part, surface, cutting plane etc. in TransMagic.

o   Body Level Selection | Selecting Body will enable the selection of only Bodies.
Bodies are the default general selection type in TransMagic and after many operations

the Filter Selection will switch back to  Body selection mode.  When a Body is
selected in TransMagic the interface will react by highlighting only the functions that
apply to that selection type.

o  Face Level Selection | Selecting Face will enable the selection of only faces.
When a Face is selected in TransMagic the interface will react by highlighting only the
functions that apply to that selection type. 

o  Edge Level Selection | Selecting Edge will enable the selection of only edges.
When an Edge is selected in TransMagic the interface will react by highlighting only
the functions that apply to that selection type. 

o  Vertex Level Selection | Selecting Vertex will enable the selection of only
vertices.  When a Vertex is selected in TransMagic the interface will react by
highlighting only the functions that apply to that selection type.

 Note: Vertices are not shown by default.  To enable the showing of vertices and
therefore the selection of them right-click anywhere in the window and select
Show->Vertices or click the Show Vertices button on the View Tab, Rendering
Group.

o  Select Only Solid Bodies | This is an additional selection filter that can be
applied where only enclosed solid bodies will be filtered for selection.

o  Select Only Surface Bodies | This is an additional selection filter that can be
applied where only bodies with open edges will be filtered for selection.  These bodies
can be individual surface bodies or sheet-bodies.

o  Select Only Wire Bodies | This is an additional selection filter that can be
applied where only wire-body independent edge bodies will be filtered for selection.
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  Window Select | Draw a rectangular window around a collection of objects in a
document and select them all at once.

o   Body Level Selection | Selecting Body will enable the selection of only Bodies.
Bodies are the default general selection type in TransMagic and after many operations

the Filter Selection will switch back to  Body selection mode.  When a Body is
selected in TransMagic the interface will react by highlighting only the functions that
apply to that selection type.

o  Face Level Selection | Selecting Face will enable the selection of only faces.
When a Face is selected in TransMagic the interface will react by highlighting only the
functions that apply to that selection type. 

o  Edge Level Selection | Selecting Edge will enable the selection of only edges.
When an Edge is selected in TransMagic the interface will react by highlighting only
the functions that apply to that selection type. 

o  Vertex Level Selection | Selecting Vertex will enable the selection of only
vertices.  When a Vertex is selected in TransMagic the interface will react by
highlighting only the functions that apply to that selection type.

 Note: Vertices are not shown by default.  To enable the showing of vertices and
therefore the selection of them right-click anywhere in the window and select
Show->Vertices or click the Show Vertices button on the View Tab, Rendering
Group.

o  Select Only Solid Bodies | This is an additional selection filter that can be
applied where only enclosed solid bodies will be filtered for selection.

o  Select Only Surface Bodies | This is an additional selection filter that can be
applied where only bodies with open edges will be filtered for selection.  These bodies
can be individual surface bodies or sheet-bodies.

o  Select Only Wire Bodies | This is an additional selection filter that can be
applied where only wire-body independent edge bodies will be filtered for selection.

  Select All | Select all currently displayed entities in the active document.

  Deselect All | Deselect anything that is currently selected in the active document.

  Orbit | Select Orbit, depress left mouse button and slide across the screen to rotate the
view.

  Zoom | Select Zoom, depress left mouse button and slide the mouse up and down to
zoom in and out on the view. 
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  Pan | Select Pan, depress left mouse button and slide the mouse across the screen to
laterally position the view. 

  Zoom All | Zoom all the parts in the view so that they all fit in the view. 

  Zoom To Window | Click button then left mouse button and drag to create rectangular
window in the view, then release the mouse button. The view will then update to reflect the
contents of the window. 

Note: TransMagic supports 3D Connexion devices for camera manipulation.  See
www.3dconnexion.com for more information.

-o-
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Settings Pages

Appearance Page

Background Color:
The TransMagic default window has a gradient color.  You can change the default colors by
setting the "Top" and "Bottom" colors using the pull-down menu.  You can also set a solid
non-gradient color by selecting the same color for both "Top" and "Bottom" settings.

Highlight Color:
All the default highlight colors in TransMagic are yellow.  You can change these settings here.

Redline:
The default redline color in TransMagic are Red with a line thickness or weight of 4 points.  You
can change these settings here.
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View Settings:
Smooth Transition - You'll notice in TransMagic when you switch between view orientations the
parts will rotate smoothly from view to view.  You can disable this behavior so that the parts
"snap" between views by un-checking this box.

View Axis - Check this box to enable an "XYZ" view axis in the lower left hand corner of
TransMagic's display.

Enable Face Highlighting - When you set your Filter Selection is at the Face level, it's this
option that enables it.  It has a check box because by default it is on.  However, you can slightly
improve File loading times by leaving this setting disabled.  Then when you go to set your Filter
Selection to Face via the Right-Click menu, you'll see that you'll have the option to first "Enable
Face Highlighting".  If you were to select this, TransMagic will process the Faces at that time thus
enabling their selection.

Facet Resolution - This pull-down box determines the visual accuracy of parts loaded into
TransMagic.  The options are Normal, Medium, High and Super High.  Both High and Super High
resolutions can consume massive amounts of memory depending on the size of the
part/assembly.

Set Random Part Color (For Parts W/No Color) - By default if TransMagic read in a part or
assembly of parts with no color attribute attached - it will apply a random color to each part. 
Uncheck to disable this function.  This is very useful when you bring a large assembly into
TransMagic and all of the sub-components are one single color.  Changing the color of all the
parts helps to clearly differentiate between parts in the assembly.

Rendering Options:
Driver
- OpenGL - This is the default setting and specifies that TransMagic uses your OpenGL enabled
graphics card.

- OpenGL2 - This is the default setting and specifies that TransMagic uses your OpenGL 2.0
enabled graphics card.  OpenGL 2.0 is a fairly new standard and not supported by all graphics
cards.  You could expect this standard to be supported on contemporary high-end cards but not
"average" consumer cards.

- Direct3D - Direct3D is a Microsoft specific 3D rendering technology and is often much faster on
Direct3D accelerated graphics cards.  Laptops very often have Direct3D accelerated graphics
cards and this acceleration is usually much faster than OpenGL rendering on these laptops.

- DX9 - DirectX 9 is a Microsoft specific 3D rendering technology and is often much faster on
DirectX 9 accelerated graphics cards.  Laptops very often have DirectX 9 accelerated graphics
cards and this acceleration is typically the fastest rendering context available.  Due to it's
performance and broad support DirectX 9 is the default rendering context for TransMagic.

- WinGDI - This setting is useful for machines with older, non OpenGL graphics cards.  If your
display looks strange for any reason, you may want to try this setting.
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Use Software OpenGL - Sometimes even if you know you do have a OpenGL supported graphics
card, you may see strange rendering behavior.  Checking this box virtually always cures any
hardware OpenGL issue and uses software calls and the processor to render the scene.

Accelerated Phong Shading - Phong shading is a very realistic lighting affect that will give your
display a "higher end" appearance.  However, it's more graphics processor (GPU) intensive than
the default Gouraud Shading.  If you have a good graphics card, you may want to set this option.
Shadows - You'll notice when you open a part in TransMagic, there is a shadow under the part for
a more realistic and high end look.  You can disable this shadow by un-checking this box.

Fast HLR - This setting specifies that Fast Hidden Line Rendering acceleration be used when

rendering in Hidden Line  mode.  Note that Fast HLR only applies to OpenGL.  The Direct3D
rendering context does not yet support Fast HLR.  Without this option checked, the Hidden Line
mode will be slowed yet more accurate.

Shadows:
- Draw Shadows - Shadows are on by default.  Un-check this option to turn off shadows.

- Resolution - This setting controls the precision of the shadow's outline.  A value from 1 - 64 can
be entered where 64 is the highest resolution and 1 is the lowest resolution.

- Blur - This setting controls the blurring of the shadow's edges.  A value from 1 - 32 can be
entered where 1 is the least blurry and 32 is the most blurry.

Reset Defaults - Click this button to Reset to TransMagic default settings for Appearance.

-o-
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File Associations Page

File Associations:
File Associations - File associations enable double-click When you enable this option, a log
report will print out for every read or write operation.  This can sometimes be useful in debugging
a file that either doesn't load or load but there are no entities.  This log file will tell you what kind
of geometry - if any - is contained in the file.

Reset Defaults - Click this button to Reset to File Associations default settings.

Select All - Click this button to associate all supported file types to TransMagic.

De-Select All - Click this button to disassociate all supported file types to TransMagic.

-o-
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Image Output

Image Copy Output:
Use Window Size - This setting will output image files at the resolution of your current
TransMagic display window.

Custom Image Size - This setting will output image files at the resolution specified.

Print Output:
Print Area:
Use Window Proportions - This setting will print image files at the resolution of your current
TransMagic display window.

Use Full Printable Area - This setting will print image files maximized to fit your paper size.

Print DPI:
Use Print Device DPI - This setting will output image files at the resolution of your display
device, which is typically a monitor and is typically 96.  So this setting will output a What You
See Is What You Get (WYSIWYG) image.

Use Specific DPI - This setting will output at the resolution specified.  The higher this setting,
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the more system RAM that will be consumed.  This is typically not an issue running TransMagic
64-bit versions but when running a 32-bit version of TransMagic the highest tested value that
can typically be set is 1000 DPI.  If many documents are open or if the facet resolution is set to
Very High - this can drastically reduce the amount of RAM available to generate the TIF image.

What is the difference between DPI and PPI - and why is my image so large with a
higher DPI?  DPI refers to Dots Per Inch and is a printer-specific term.  PPI refers to Pixels
Per Inch and is a screen-specific term.  When an image is created at anything higher than
72-100 DPI, it's going to display much larger on your monitor than the original picture or
page.  Windows will also report this size as a larger pixel size.  That's because your monitor
can only display a fixed number of pixels per inch, usually 96 while a printer can print at a
much higher dots per inch resolution. When you place the image into a page layout
program, most software will be able to read the DPI information and will place your image
into the page at the proper size. Some of the low-end printing software may not, however,
and you'll have a very large image placed into your page. When that happens, you'll have
to size the image in your layout program to the printed size you based your calculations on.

Include Window Background - Included the TransMagic window background color in the
output print.

Reset Defaults - Click this button to Reset to TransMagic default settings for Image
Output.

-o-
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General Page

Translation Log - When you enable this option, a log report will print out for every read or write
operation.  This can sometimes be useful in debugging a file that either doesn't load or load but
there are no entities.  This log file will tell you what kind of geometry - if any - is contained in the
file.

Filter Out WCS Entities - By default TransMagic does not read WCS (Working Coordinate
System) entities; however, these are supported.  To read and translate WCS entities, uncheck
this box.

*Enable PMI Translation - When this option is checked TransMagic will translate PMI data
contained in the part file.  This is an optional function of TransMagic and requires the appropriate
License Key.  For more information about PMI see also:

  "Show/Hide Product Manufacturing" function in the Index.
 Under the "Contents" tab, see Menu Functions->Right-Click Menu->No Selection for

instructions on selecting the PMI data and operations that can be performed with the PMI
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data.
 Under the "Contents" tab, see Menu Functions->Right-Click Menu->PMI Selected for

instructions on orienting the view to the PMI views.
 Under the "Contents" tab, see Menu Functions->View Menu->Split Window for creating

multi-view docs as seen here:

Set Random Part Color (For Parts W/No Color) - By default if TransMagic read in a part or
assembly of parts with no color attribute attached - it will apply a random color to each part. 
Uncheck to disable this function.  This is very useful when you bring a large assembly into
TransMagic and all of the sub-components are one single color.  Changing the color of all the
parts helps to clearly differentiate between parts in the assembly.

Translation Log - When you enable this option, a log report will print out for every read or write
operation. This can sometimes be useful in debugging a file that either doesn't load or load but
there are no entities. This log file will tell you what kind of geometry - if any - is contained in the
file.

Filter Out WCS Entities - By default TransMagic does not read WCS (Working Coordinate
System) entities; however, these are supported.  To read and translate WCS entities, uncheck
this box.

Enable PMI Translation - When this option is checked TransMagic will translate PMI data
contained in the part file.  This is an optional fuction of TransMagic and requires the appropriate
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License Key.  Currently the PMI data is only viewable from within the TransMagic GUI or output
to the TransMagic PMIXML file which requires a certain level of development skill to make useful. 
Currently the PMI data supported by TransMagic is as follows:
 General Dimensions 

o Length & Distance 
o Tangent, Cylindrical & Edge Radius 
o Angle, Arc Length & Dimension Slope Angular 
o Curvilinear & Circular Length 
o Ordinate 
o GD&T 

 Geometric Dimensioning 
o Manufacturing Tolerancing 
o Surface Roughness 
o 3D Annotation (text) 
o Manufacturing Notes 
o Materials 
o Could be many things attached as 3D Annotations

Set Random Part Color (For Parts W/No Color) - By default if TransMagic read in a part or
assembly of parts with no color attribute attached - it will apply a random color to each part. 
Uncheck to disable this function.  This is very useful when you bring a large assembly into
TransMagic and all of the sub-components are one single color.  Changing the color of all the
parts helps to clearly differentiate between parts in the assembly.

Part Name Trimming - By default TransMagic will append part names so that they are not
longer than 233 characters minus file extenstion.  This is because many CAD systems will import
a file, say a STEP assembly, and when they do they will create individual files for each part in the
assembly.  They will also name the file based on the part name.  So if the part name is longer
than 233 characters and they try to use a Windows function to save it, the function will fail as
Windows will not allow parts to be created that are longer than 233 characters.  The part names
will also be given an arbitrary "(1)", "(2)", "(3)" based on the order they were read in.  This
prevents duplicate file names and it helps to identify that name trimming has taken place.

Output Units - Use this pull-down menu to set your preferred application units.  These units will
be set to any file you write to.

Output Assembly XML - This option is intended for PDM\PLM integration or other "enterprise
style" usage.  It will output what ever format you select into an atomic (individual file) assembly
with assembly structure and part transforms contained in an external XML file.

Output PMI XML - This option is intended for PDM\PLM integration or other "enterprise style"
usage.  This option requires that the above "Output Assembly XML" option is check.  This option
will output a separate PMI XML file for each part, assembly, or sub-assembly with any (or none)
PMI information attached to that level (part or assembly).

Atomize - This command is designed to be sent along with the XML Assembly File option.  The
atomize operation will further break down 
part files that contain multiple bodies into discretized part files that each contain only one single
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body per file.  Following is a break-down of the behaviors of this option:
o For part files with multiple bodies, this option will instruct TransMagic to create

individual files for each body in the part.  Each new file created will be named the
same as the "top-level" part file appended with -01.*, -02.*, -03.*, and so on.

o You can currently specify the XML Assembly File option even for a non-assembly or
flattened file such as SAT.  The current behavior is that a single XML file will get
created along with the single output file format.  If the XML Atomize option is specified
in conjuction with the XML Assembly File option then TransMagic will create the -01.*,
-02.*, -03.* files as above for each body in the file.

o If a part file contains only a single body then TransMagic will create that single file
with no appended -01.*, -02.*...

o When the XML Atomize option is specified, add a new sub-level "Body", "/Body" is
added to the XML assembly file which lists the body by both the appended file name
with -01.*, -02.*, etc. and also by the actual attribute name of the body in that file.

Mass Properties - This option is designed to be sent along with the XML Assembly File option
above.  The XML Mass Properties options will calculate the the mass properties for each part (or
body) in a file including Volume, Center Of Mass, Principal Axes, Inertia Tensor and Principal
Moments.  It will create a new sub-category in the XML file: Mass

Surface Area - This option is designed to be sent along with the XML Assembly File option
above.  The XML Surface Area option will calculate the surface area for each part (or body) in a
file.  It will create a new sub-category in the XML file: Surface_Area

Bounding Box - This option is designed to be sent along with the XML Assembly File option
above.  The XML Bounding Box option will calculate the m inimum Bounding Box size relative to
the global origin for each part (or body) in a file.  It will create a new sub-category in the XML
file: Bounding_Box

Part Name Trimming - By default TransMagic will append part names so that they are not
longer than 233 characters minus file extension.  This is because many CAD systems will import
a file, say a STEP assembly, and when they do they will create individual files for each part in the
assembly.  They will also name the file based on the part name.  So if the part name is longer
than 233 characters and they try to use a Windows function to save it, the function will fail as
Windows will not allow parts to be created that are longer than 233 characters.  The part names
will also be given an arbitrary "(1)", "(2)", "(3)" based on the order they were read in.  This
prevents duplicate file names and it helps to identify that name trimming has taken place.

Part Name Character Mapping - Many CAD systems will give automatic individual part names
to each part in a file if the user did not explicitly do so.  For example, let's say you have a CATIA
V4 file with 3 solid parts in it.  CATIA V4 will automatically name the parts *SOL1, *SOL2,
*SOL3.  To see the part names in TransMagic go to Tools->Assembly Browser.  Now let's say you
want to translate this CATIA V4 file with the 3 parts in it into a Parasolid file so you can bring the
file into SolidWorks.  SolidWorks will create a 3 part assembly from this file.  Each individual part
will be save as a *.sldprt file automatically upon reading into SolidWorks.  SolidWorks and
presumably other CAD systems that operate in this way will create a file name based on the part
name.  So when SolidWorks automatically tries to save a file with a name of *SOL.sldprt,
Windows will not allow this because "*" is an illegal file name character - as well as "\/:*?"<>|". 
None of these characters can be used in a file name.  So TransMagic will automatically re-map
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these illegal characters to part names so as to prevent this scenario from occurring.  If your CAD
system does not save individual files by part names then you may wish to un-check the
"Re-name Parts With Supported Characters" box and your part names will come through as
originally created by the originating CAD system.

Calculate Fast Bounding Box - By default TransMagic uses a fast Bounding Box calculation.
This Bounding Box is good for most needs.  Un-checking this option will enable the calculation of
a super-precise Bounding Box.  However, the cost of this precision can be a longer processing
time for complex parts.

Reset Defaults - Click this button to Reset to General TransMagic default settings.

* Enable PMI Translation requires that the PMI option has been licensed.

** The Un-Repaired Geometry Dialog requires the MagicSURFACE Advanced Toolkit.

-o-
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Repair Page

Repair Error Reporting - Per the instructions under the check box, this option will disable Error
Reporting during Repair.  Sometimes Repairing a model will return many error depending on the
quality of the file.  You will often be able to fully Repair a file even when there are errors.  So
disabling this option will eliminate the error checking and avoid multiple error reports.  However,
by disabling the error reporting can allow a crash that would not have occurred if the error
reporting was turned on.  This is generally rare.

Auto Repair Wizard During Repair and Geometry Checking - Enabled by default when you
run the Lite Repair, Full Repair, or Check Geometry functions, the TransMagic is  and autom ated
analysis tool that will provide you with what, if any, additional steps may need to be taken to get
the geometry into a high quality and useable state.  See the Auto Repair Wizard. documentation
for more information.

Auto Repair Wizard RAM Threshold - This is an important setting when you're dealing with
very large parts or assemblies.  TransMagic's geometric checking and Repair algorithms, while as
efficient as possible, are still CPU and RAM intensive depending on the data being analyzed or
Repaired.  As such, when dealing with very large assemblies the Auto Repair Wizard can take a
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long time to run and this might not always be the best practice when your RAM is limited.  The
best practice depending on your RAM is typically to hide portions or sub-assemblies and then run
the Auto Repair Wizard on the visible portions or sub-assemblies.  This piecemeal approach can
save processing time and RAM.  The minimum setting of this value is 0 which would effectively
turn off the Auto Repair Wizard.  The maximum value is the amount of physical RAM in the
system.  The default maximum value is 1 GB RAM or if your system has less than 1 GB (not
recommended) of RAM then the default is what-ever your system RAM is.

Regarding file size and RAM:  If you are dealing with very large files, then you will need a fair
amount of RAM. The rule of thumb is that part/assembly files on a disc drive  will expand to
about 10x their size in RAM.  So a 1 GB maximum setting means that the Auto Repair Wizard will
be enabled up to file sizes of about 100 MB, setting this to 2 GB would mean file sizes of 200 MB
and so on.

Auto Repair Wizard During File Loading - When you open a geometric file in TransMagic, the
first thing you'll notice is that immediately after the part has been opened an interrogation
process starts.  This process is the TransMagic Recommends Wizard.  TransMagic is automatically
analyzing the geometry that was just opened and is determining what, if any, additional steps
may need to be taken to get the geometry into a high quality and useable state.  See the Auto
Repair Wizard. documentation for more information.

**Show Un-Repaired Geometry Dialog After Repair and Geometry Checking - The Show
Un-Repaired Geometry dialog highlights erroneous geometry that has been found during
geometric checking or after Repair.  For more information see the documentation for the 
Un-Repaired Geometry Dialog.

Reset Defaults - Click this button to Reset to General TransMagic default settings.

** The Un-Repaired Geometry Dialog requires the MagicSURFACE Advanced Toolkit.

-o-
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ACIS Write Page*

ACIS Version Number - Use this pull-down menu to set the ACIS (*.sat) version that will be
saved when you save as a *.sat file.  By default this version is 7.0 as this offers the greatest
compatibility with ACIS based products.  It's recommended that you set the ACIS version to the
latest version supported by your ACIS based product.  Likewise, you may also need to set the
ACIS version to an earlier version (i.e. AutoCAD R12 = ACIS v1.6) to be compatible with your
ACIS based product.

Reset Defaults - Click this button to Reset to TransMagic default settings for ACIS.

* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com

-o-
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CATIA V4 Read Page*

Read:
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Read Free Edges - Check this to enable the reading of edge (wire-frame) data.

Read Free Points - Check this to enable the reading of point data.

Read NoShow Entities - By default TransMagic does not read "NoShow" entities.  For CATIA V4,
this is analogous to "hidden" entities.  NoShow entities are typically construction geometry and
other unnecessary entities.  However, periodically the person you received the CATIA V4 file from
may have inadvertently marked the entities you're interested in as NoShow.  If this is the case,
you can check this option and re-read the file.  NoShow entities will then be read in.

Read No Pick Entities -  By default TransMagic does not read "NoPick" entities.  For CATIA V4,
this is also analogous to "hidden" entities.  NoPick entities are typically construction geometry
and other unnecessary entities.  However, periodically the person you received the CATIA V4 file
from may have inadvertently marked the entities you're interested in as NoPick.  If this is the
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case, you can check this option and re-read the file.  NoShow entities will then be read in.

Read Only Root Entities - By default TransMagic only reads in the Root entities on the Master
Workspace.  To read in all Root entities un-check this.

Read Only Master Workspace - By default TransMagic only read in the Master Workspace.  To
read in any other Workspaces, un-check this.

Check For Extra Root Entities - By default TransMagic only reads the Root entities on the
Master Workspace.  To check for extra Root entities not on the Master Workspace, check this
option in conjunction with un-checking Read Only Root Entities.  Setting these two options will
read any available Root entities.

Hide Construction Geometry - CATIA V4 files very often have construction geometry remaining
in the file.  This construction geometry can confuse the primary geometry and if the model is a
surface model that requires Lite Repair - this construction geometry can especially confuse the
Lite Repair operation and extend the processing time.  Hiding the construction geometry does not
delete the geometry but rather simply hides it from view so that it can not be inc luded in Repair
operations.  To view this construction geometry simply right-click in the display and select
Show->Show All Hidden Entities.

Layer Transfer
Default Layer
- All Layers - Specifying All Layers will inform TransMagic to allow the translation of all entities on
all layers.  This means that entities on all layers will be considered in the translation provided
that they are not "filtered out" by other CATIA V4 Read options listed above such as NoShow
entities, etc.

- Current Layer - Specifying Current Layer will inform TransMagic to allow the translation of any
entities that were on the layer that was last active when the file was saved.  This means that
entities on the last active layer will be considered in the translation provided that they are not
"filtered out" by other CATIA V4 Read options listed above such as NoShow entities, etc.

User Defined Layer
- Enter Layer Name Manually - Specifying Enter Layer Name Manually will inform TransMagic to
allow the translation of any entities that were on the user-specified layer.  By default this will be
"ALL" which is the same as "All Layers" above.  Note that these layer names are case-sensitive. 
This means that entities on the user-specified layer will be considered in the translation provided
that they are not "filtered out" by other CATIA V4 Read options listed above such as NoShow
entities, etc.

Reset Defaults - Click this button to Reset to TransMagic default settings for CATIA V4.  We
recommend that after you have modified the File->Settings for CATIA V4 and achieved the
desired results for the current file, that you Reset Defaults and always use default settings in
general as this will ensure the greatest chance of success.
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* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com

-o-
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CATIA V4 Write Page*

Write:
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Write Free Edges - Check this to enable the writing of edge (wire-frame) data.

Write Free Points - Check this to enable the writing of point data.

Write Hidden Entities - Check this to write out entities marked as "hidden". 

Solid Output Type - By default TransMagic will write out the SOLIDE output type.  SOLIDE is
the most commonly used output type.  When SOLIDE: a multi-lump solid is written as a single
SOLIDE having many SOLIDDEF.  When VOLUME: a multi-lump solid is written as many
VOLUMEs.

CATIA V4 Version - By default TransMagic writes out CATIA version 4.2.4 which is the latest
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available release of CATIA V4 and this is also the most widely used version.  TransMagic can
write out CATIA V4 4.1.9 through 4.2.4.

Reset Defaults - Click this button to Reset to TransMagic default settings for CATIA V4.  We
recommend that after you have modified the File->Settings for CATIA V4 and achieved the
desired results for the current file, that you Reset Defaults and always use default settings in
general as this will ensure the greatest chance of success.

* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com

-o-
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CATIA V5 Read Page*

Read:
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Read Free Edges - Check this to enable the reading of edge (wire-frame) data.

Read Free Points - Check this to enable the reading of point data.

Read Hidden Entities - Check this to read in entities marked as "hidden" in the CATIA V5 file. 

Read Last Save State - The Last Save State is called the "In Work Object" in CATIA
nomenclature.  In most cases the user wants the file as it was last saved by the engineer who
last "touched" the file.  However, you can also retrieve the "Final State" version of the file by
un-checking this option.

Add Assembly Structure To Part Names - By default TransMagic will transfer part names as
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they were in the original engineering software.  With this option checked if the part is part of an
assembly the part name will reflect this Assembly Hierarchy.  Each level of the assembly is
denoted by a "!".  Depending on the size of the assembly tree this can result in long part names.

* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com

-o-
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CATIA V5 Write Page*

Write:
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Write Free Edges - Check this to enable the writing of edge (wire-frame) data.

Write Free Points - Check this to enable the writing of point data.

Write Hidden Entities - Check this to write out entities marked as "hidden". 

V5 Version Number - Use this pull-down menu to set the CATIA V5 version that will be saved
when you save as a *.CATPart file. By default this version is R18 as most CATIA V5 installations
are not immediately current. It's recommended that you set the CATIA V5 version to the latest
version supported by the CATIA V5 installation that the file is going to. Likewise, you may also
need to set the CATIA V5 version to an earlier version to be compatible with the CATIA V5
installation that the file is going to. 
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Output Body Type: Use this pull-down to select the CATIA V5 Body Type.  Hybrid Body
(PartBody) means that the geometry gets created under Part Body.   Non-Hybrid Body
(Geometrical Set) means that the geometry gets created in a Geometrical Set.

Hybrid: Non-Hybrid: 

Reset Defaults - Click this button to Reset to TransMagic default settings for CATIA V5.

* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com
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Creo | Pro/E Read Page*

Read
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Resurface Splines - By default TransMagic will re-create erroneous spline surfaces that are
common in some Pro/E files.  Though there is no reason to disable this option, you may. 
Disabling this option will cause TransMagic to read in the erroneous spline surfaces.

Free Surfaces - By default TransMagic reads both solid and surface geometry from Pro/E files.
To disable the reading of surface geometry and only read solids, un-check this option.

Read Free Curves - By default TransMagic reads in Free Curves (wire-frames). To disable the
reading of wire-frame entities, un-check this option. 

Read Hidden Entities - By default TransMagic does not read Blanked or "Hidden" entities from
the file; however, to read hidden entities, check this option.
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Read Suppressed Entities - By default TransMagic does not read parts that have been
suppressed in the original CAD system although these parts are still present in the file.  Enabling
this option will instruct TransMagic to process these entities.  This applies to assemblies with
suppressed parts. This does not currently apply to parts with suppressed bodies.

Reset Defaults - Click this button to Reset to TransMagic default settings for Pro/E Read.

-o-
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DWG Read Page

Read B-Rep Data - Many DWG files contain the Visualization model (Viz-Rep) and many also
contain true CAD geometry (B-Rep).  By default TransMagic will read both types.  Un-check this
option to ONLY read the Viz-Rep type.

DWG Texture File Location - TransMagic supports the reading and visualization of textures
attached to a DWG file but the texture directory must be specified first.  By default this directory
is: C:\Program Files (x86)\Common Files\Autodesk Shared\Materials\Textures\2\Mats" and is
installed with Autocad.

Import XData  - XData = Extended Entity Data and is a legacy mechanism to attach additional
information to AutoCAD entities such as:
 Color attributes
 Add any type of information like point, integer, binary data etc.
 The size limit is 16 KB and thus doesn't support extensive extra data.

-o-
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DWG Write Page

Write B-Rep Vs. Viz-Rep Data - The DWG format can contain both "true" CAD geometry, called
Boundary Representation or B-Rep data or it can contain 3D polygonal data called Viz-Rep data. 
By default if a CAD file is loaded into TransMagic then a B-Rep DWG file will be written out. 
B-Rep data is much heavier than Viz-Rep data though and if the intent is to bring the data into a
polygonal environment like an architectural application, then you may want to uncheck this
option so that only the lighter weight Viz-Rep DWG file is created.

 - Check this to enable the writing of point data.

DWG Version - Use this pull-down menu to set the DWG version that will be saved when you
save the DWG version.  By default this version is  DWG 2000 as this offers the greatest
compatibility with DWG based products.  It's recommended that you set the DWG version to the
latest version supported by your DWG based product.

-o-
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HSF Write Page*

HSF Write:
Compress Vertices - By default TransMagic applies advanced compression to vertices to reduce
their file size.  Though there is really no reason to disable this, you may.  You will not notice a
difference in the HSF file though the file size will grow.

Compress Normals - By default TransMagic applies advanced compression to normal's to
reduce their file size.  Though there is really no reason to disable this, you may.  You will not
notice a difference in the HSF file though the file size will grow.

Include File Dictionary - The file dictionary is a piece of data in the HSF file that contains
entries for the file locations of various representations of entities.  If this is enabled then the
location of the original file is written to the HSF file.  Though there is really no reason to disable
this, you may. 

Include Line/Edge Data - The HSF file is a polygonal format with the ability to represent
topological data as well (Face, Edge, Vertex, & Connectivity).  For this reason the HSF file is
much more suited to engineering visualization than other polygonal formats such as *.stl and
*.wrl (VRML).  TransMagic uses the HSF file to offer a lightweight engineering visualization
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format.  This is why Line/Edge data is checked by default.  To write a pure polygonal HSF file,
first uncheck Include Topology Information, then un-check Include Line/Edge Data.  This will
result in lighter weight yet less informative HSF file.

Use Advanced Compression - By default TransMagic applies Advanced Compression to the HSF
file to reduce the file size.  Though there is really no reason to disable this, you may.  You will
not notice a difference in the HSF file though the file size will grow.

Include Topology Information - The HSF file is a polygonal format with the ability to represent
topological data as well (Face, Edge, Vertex, & Connectivity).  For this reason the HSF file is
much more suited to engineering visualization than other polygonal formats such as *.stl and
*.wrl (VRML).  TransMagic uses the HSF file to offer a lightweight engineering visualization
format.  This is why Include Topology Information is checked by default.  To write a pure
polygonal HSF file, first uncheck Include Topology Information, then un-check Include Line/Edge
Data.  This will result in lighter weight yet less informative HSF file.

Bits Per Vertex - The Bits Per Vertex setting controls the level of compression for vertices.
Though there is really no reason to change this setting, you may.  You will not notice a difference
in the HSF file though this setting will affect the file size.

Bits Per Normal - The Bits Per Normal setting controls the level of compression for normal's.
Though there is really no reason to change this setting, you may.  You will not notice a difference
in the HSF file though this setting will affect the file size.

HSF Version - Use this pull-down menu to set the HSF version that will be saved when you save
as a *.hsf file.

Reset Defaults - Click this button to Reset to TransMagic default settings for HSF.  We
recommend that after you have modified the File->Settings for HSF and achieved the desired
results for the current file, that you Reset Defaults and always use default settings in general as
this will ensure the best possible HSF file.

* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com
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IGES Read Page*

IGES Read:
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Auto-Lite Repair - This option is intended for the automatic stitching and Repair of single parts.
If you are loading single parts only in your IGES files, then this option will automatically stitch
together the surfaces of the IGES file and apply some limited Repair.  This can save a lot of time. 
However, if your IGES files contain assemblies - or collection of parts - then this option is not a
good idea as it will stitch all the parts together into a large unusable "lump" of surfaces.  For
loading and Repairing IGES assemblies see the "Surface Model Assembly Repair" tutorial.

Read Free Edges - Check this to enable the reading of edge (wire-frame) data. 

Read Free Surfaces - By default TransMagic reads in Free Surfaces, which are the majority of
IGES files.  However if, for instance, you were only interested in reading the wire-frame data
contained in an IGES file, then you would un-check Read Free Surfaces and make sure Read Free
Curves was checked.
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Read Free Points - By default TransMagic does not read in free points.  To read in Free Points
check this option.

Read Trimmed Surfaces - There are two surface types in an IGES file, trimmed and bounded
surfaces.  By default TransMagic reads in Trimmed Surfaces.  Though there is not much use in
disabling this option in most cases, you may.  If this option is disabled, TransMagic will not read
in Trimmed Surfaces.

Read Blanked Entities - By default TransMagic reads in Blanked or "Hidden" entities.  To
disable the read of Hidden entities un-check this option.

Read IGES Solids - IGES supports and entity type called the MSBO or Manifold Solid Boundary
Object.  This is an IGES solid.  Though virtually no application supports this IGES entity type, we
consider it the best possible IGES file.  If you wish not to read in MSBOs then you can un-check
this option.

Read IGES Associativity Entities - IGES Associativity Entities are generally used in assemblies
where one part is associated to another part.  By disabling this option, an IGES assembly file will
generally not read in.  Though there is generally no reason to disable this option, you may.

Read IGES Subfigure Entities - IGES Subfigure Entities can be considered "sub-assembly"
entities.  They denote a dependence between IGES entities.  By disabling this option, an IGES
assembly file will generally not read in.  Though there is generally no reason to disable this
option, you may.

Use Topology For Trim Curves - By default TransMagic will use the trim curves written to by
the IGES file.  If this option is disabled, TransMagic will project the edges to the surfaces and use
the projected curves as trim curves.  If an IGES file reads in but appears to have a surface
trimming error, disabling this option and re-loading the file may correct the problem.  In general,
this option should be left checked and the IGES trim curves should be used.

IGES Flavor
AutoCAD - If AutoCAD created the IGES file you're reading in, then you should set the
Flavor to AutoCAD.  However, you are trying to bring in a file from AutoCAD, then you
should use the ACIS *.sat format as this is native to both AutoCAD and TransMagic and
will offer a much more reliable translation.
SolidWorks - If SolidWorks create the IGES file you're reading in, then you should set
the Flavor to SolidWorks.  However, you are trying to bring in a file from SolidWorks, then
you should use the Parasolid *.x_t format that is native to SolidWorks.  This will offer a
much more reliable translation than IGES.
JAMA - If the IGES file you're reading in was created using the JAMA protocol - a
Japanese automotive protocol used widely - then you should set the Flavor to JAMA.

Trimming Curve Preference
As specified in file - Use the type of trimming curve that is specified in the IGES file for
trimming surfaces.
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Use 2D parameter curves - Use the 2D (two-space) parameter curves for trimming
surfaces.
Use 3D edge curves - Use the 3D (three-space) edge curves for trimming surfaces.
Use both 2D parameter & 3D edge curves - Use both 2D parameter and 3D edge
curves for trimming surfaces.

Reset Defaults - Click this button to Reset to TransMagic default settings for IGES Read. We
recommend that after you have modified the IGES Read settings and achieved the desired
results for the current file, that you Reset Defaults and always use default settings in general as
this will ensure the greatest chance of success.

-o-
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IGES Write Page*

IGES Write:
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Write Trimmed Surfaces - By default TransMagic writes out trimmed surfaces to the IGES file.
Though generally there is no reason not to write out trimmed surfaces - as this is generally what
an IGES file contains - by un-checking this option trimmed surfaces will not be written out.  This
may be useful if the file your writing out has both surfaces and wire-frames and you only want to
write out wire-frame entities.

Write All Surfaces As Spline Surfaces - By default TransMagic writes out many surfaces types
supported by IGES such as spline, sphere, plane, cone, torus, etc.  However, many IGES readers
only support spline surfaces.  If after writing out an IGES file, the file does not read into the
receiving application, then checking this option to force the conversion of all surfaces to spline
surfaces, will often help.

Write All Curves As Spline Curves - By default TransMagic writes out many curve types
supported by IGES such as spline, arc, line, etc.  However, many IGES readers only support
spline curves.  If after writing out an IGES file, the file does not read into the receiving



p107

TransMagic R10 User Guide

© TransMagic Inc, 2013

application, then checking this option to force the conversion of all curves to spline curves, will
often help.

Write Free Points - Check this to enable the writing of point data.

Write Free Points - By default TransMagic does not write out free points.  To write out Free
Points check this option.

Write Hidden Entities - Check this to write out entities marked as "hidden". 

Solid Output Type
Solids (IGES MSBO) - The IGES specification supports an entity type called an MSBO, or
Manifold Solid Boundary Object.  This is the best of all possible IGES file types because it
allows the transfer of true solid parts.  However, very few applications support this IGES
MSBO.  So while it's worth a try, most applications do not read this type.
Surfaces - This is the most commonly form of IGES files - surface only.
Wire-frames - By selecting this option, all the edges of the model will be written out as
wire-frames without surfaces.

Surface Output Type
Trimmed Surface (144) - A trimmed surface is a surface whose mathematical domain is
outside of the actual edges of the surface.  This is the most common type of surface
written out to an IGES file.
Bounded Surface (143) - A bounded surface is where a trimmed surface is converted so
that the domain of the surface exactly matches up with it's boundary curves.  Though
rare, some IGES readers require this surface type.

Trim Curve Preference - By default TransMagic writes out "3D Trim Curves Only", which is the
most common Trim Curve type.  However, certain IGES readers may require a different Trim
Curve output type.  TransMagic supports all possible Trim Curve output types.  Refer to the IGES
readers requirement and set this option to the appropriate setting if necessary.  

IGES Flavor
AutoCAD - If you intend to bring an IGES file into AutoCAD, then you should set the
Flavor to AutoCAD.  However, if you are trying to bring a file into AutoCAD, then you
should use the ACIS *.sat format as this is native to both AutoCAD and TransMagic and
will offer a much more reliable translation.
SolidWorks - If you intend to bring an IGES file into SolidWorks, then you should set the
Flavor to SolidWorks.  However, if you are trying to bring a file into SolidWorks, then you
should use the Parasolid *.x_t format that is native to SolidWorks.  This will offer a much
more reliable translation than IGES.
JAMA - If you intend to bring an IGES file into an application that supports the JAMA
protocol, then you should set the Flavor to JAMA.

Reset Defaults - Click this button to Reset to TransMagic default settings for IGES Write.  We
recommend that after you have modified the File->Settings for IGES Write and achieved the
desired results for the current file, that you Reset Defaults and always use default settings in
general as this will ensure the greatest chance of success.
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JT Read Page*

JT Read:
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Read In Point Bodies (Points) - By default TransMagic does not read in points.  Check this to
read in points.

Read B-Rep Data - Most JT files contain only the Visualization model (Viz-Rep); however, some
files also contain true CAD geometry (B-Rep).  By default TransMagic only reads the Viz-Rep
version of the model as this is extremely fast and is also what the typical user is looking for. 
Checking the "Read B-Rep Data" will instruct TransMagic to extract the true B-Rep data.  The
B-Rep data can then be queried for mass properties, surface area, etc. like other CAD parts.  It
can also be exported out to other CAD models as well.  By comparison a Viz-Rep can only be
output to other Visualization formats.  Note: if B-Rep is checked and the JT file does not contain
a B-Rep then TransMagic will warn the user of this and continue to load the Viz-Rep.

Tip: If you are primarily interested in reading in the B-Rep parts contained in a JT file then
it is always safe to leave the "Read B-Rep Data" option checked.  TransMagic will warn you
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if a file does not contain a B-Rep.
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JT Write Page*

JT Write:
Write Out Point Bodies (Points) - By default TransMagic does not write out points.  Check this
to write out points.

Write B-Rep Data - The typical JT file will typically contain only the Visualization model
(Viz-Rep); however, the JT format also supports the storage of true CAD geometry (B-Rep).  By
default TransMagic only writes the Viz-Rep version of the model as this is extremely fast and is
also what the typical user is looking for.  Checking the "Write B-Rep Data" will instruct
TransMagic to also include the B-Rep data in the JT file.  

JT Version Number - By default TransMagic writes out JT version 8.0 to address the largest
group of current users; although, TransMagic currently supports JT versions 6.4 through 9.3.

JT Faceting Options:
Please note that ANY faceting option listed here is relative to Visualization Representation
(V-Rep) JT files ONLY.  For JT files with B-Reps we use the JT Open recommended option
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"JtkSMART_LODS" in our translator, which automatically creates several LODs based on the
B-Rep data.  With B-Rep JT files it is presumed that the applications importing them will use the
B-Rep data to generate a facet mesh on the importing application side and thus faceting options
are irrelevant.

Assembly Output Type:
JT supports multiple assembly types.  These are as follows:
Single File Assembly = Entire assembly in one file.
Typical Assembly = Assembly JT files + part JT files.
Typical Assembly w/Directory = Typical assembly JT file + directory.
All Assembly Files = Each assembly is a JT file including parts.

Standard Faceting Option:
The majority of all JT faceting needs will be handled by the standard Faceting option:

Facet Resolution - The JT Facet Resolution can be one of five settings: Lowest, Low, Normal,
High, Highest.  These settings refer to the common facet resolution setting "normal deviation"
and correspond to the following settings: Lowest = 45 degrees, Low = 30 degrees, Normal = 15
degrees, High = 10 degrees, Highest = 5 degrees.
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Advanced Faceting Options:

Normal Deviation - Every facet position (x,y,z), also called a node, rests exactly on the surface
of a part.  At every facet node a surface normal can be created.  Normal Deviation specifies that
at every facet-node-surface-normal the maximum deviation angle in degrees between any other
facet-node-surface-normal can not exceed this degree value.

Maximum Surface Deviation - Maximum Surface Deviation specifies a value based on the
application units specified under the File->Settings dialog and General tab.  This value is the
maximum perpendicular distance from the center (centroid) of any facet to where this
perpendicular ray intersects with the true surface of the part.

Maximum Edge Length Preference
Maximum Edge Length By Percent - Maximum Edge Length By Percent specifies the
edge length of the triangles based on a percentage of the length of the diagonal of the
bounding box of the part.  This is a much simpler way to establish edge length because
subdividing facets based on length generally only occurs on planar faces which should
preferably contain fewer facets than curved surfaces.  Curved surfaces are generally
subdivided based on the Maximum Surface Deviation and Normal Deviation settings and
usually override the Maximum Edge Length.
Maximum Edge Length By Unit - Maximum Edge Length By Unit specifies the edge
length of the triangles based on a unit value based on the application units specified
under the File->Settings dialog and General tab.  This setting is purposely set to a high
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value because if a very small unit is specified the processing time and file size can grow
unnecessarily large.  This setting is better suited to very specific cases when generating
an FEA mesh vs. a Rapid Prototype file.  Even as such this setting is generally not even
used when generating an FEA mesh as the Maximum Edge Length By Percent is usually
the preferred way to control this value.

Reset Defaults - Click this button to Reset to TransMagic default settings for JT.

* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com
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Inventor Read Page*

Read:
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.
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NGRAIN Write Page*

NGRAIN Write Options

NGRAIN Model Generation Options

Dimension - The default dimension of 500 pixels means that the resultant NGRAIN file will have
a dimension of 500x500x500 pixels.  Think of this as a bitmap whose  resolution is 3 dimensions
instead of two.  A larger value = higher quality, a smaller value = lower quality.  The maximum
value is 10000 Units.

Visual Quality - The visual quality setting is an oversampling setting. Oversampling is a quality
setting during the conversion process that involves scaling the resolution of the model upwards
by a specified factor to determine more accurate settings of which voxels are occupied, what their
color values are, and what their normal value is when the model is scaled back down to its
intended size. The range of values for this setting is 1 to 7.  
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Facet Generation Options

Max Normal Deviation - Every facet position (x,y,z), also called a node, rests exactly on the
surface of a part. At every facet node a surface normal can be created. Normal Deviation specifies
that at every facet-node-surface-normal the maximum deviation angle in degrees between any
other facet-node-surface-normal can not exceed this degree value. 

Maximum Surface Deviation - Maximum Surface Deviation specifies a value based on the
application units specified under the File->Settings dialog and General tab. This value is the
maximum perpendicular distance from the center (centroid) of any facet to where this
perpendicular ray intersects with the true surface of the part. 

Note: that the smaller the value, the longer the conversion times and larger the RAM
needs, but the file size and performance of the resultant NGRAIN file will not be affected

within Producer/Viewer.

Format Options

NGRAIN Write Format

3KO - The 3KO format is NGRAIN's default format for their applications that make use of the
Knowledge Object features of this format.  The 3KO format is an NGW Voxel Space format
with additional meta data such as part knowledge.

NGW - The NGW format is NGRAIN's core Voxel Space format.

Version - Specifies the version of the NGRAIN format to write out to.  Currently available
versions are 4.1, 4.0 or 3.2.

Advanced Options - Depending on which format is currently selected this button will launch to
either the "Advanced 3KO Options" tab or the "Advanced NGW Options" tab in the dialog:

Advanced 3KO Options:
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Part Axis Alignment - Applies To Version: 4.1.  Optimize orientation of parts.  Convert parts
using their local orientation rather than model orientation.

Geometry Instancing - Applies To Version: 4.1.  Duplicate parts will be converted once
and reused where possible.  Enable "Part Axis Alignment" to make sure parts are
instanced regardless of their orientation in the model.

Min Resolution -  Applies To Version: 4.1, 4.0.  The minimum size that the longest axis
of a converted part should be.  This value should be between 0 and the "Max Resolution".

Max Resolution - Applies To Version: 4.1, 4.0.  The maximum size that the longest axis
of a converted part should be.  This value should be between the "Min Resolution" and the
"Voxel Cube Size".

Advanced NGW Options:
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Include Raw Poly Data - Applies To Version: 4.1, 4.0.  Include source polygon data for
use in post conversion processing of surface data.

Enable Large Parts Subdivision - Applies To Version: 4.1, 4.0.  Checking this option
enables the special functionality "Large Parts Subdivision" and also enables the "Part Size
Threshold" and "Max Subdivision Size" boxes for the user to tailor this features behavior.

 Part Size Threshold – Criteria for applying sub-division on a particular part: if
max. dimension of a part is larger than or equal to this number (4000), the
part will be subdivided.  The maximum value is 10000.

 Maximum Subdivision Size – Criteria for specifying the maximum dimension
of a subdivision. This value specifies that the max sub-division’s dimension will
not exceed this number (1000).  The maximum value is 10000.

NGRAIN Groups - Applies To Version: 4.1, 4.0.  NGRAIN Groups apply to wire-body
(edge) entities only.  They work by searching for user define strings to search entity
names and group these entities in the NGW format.  Another side effect of enabling this
option is that it will automatically set the following options for CATIA V5 Read:

 Read Free Edges
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 Add Assembly Structure To Part Names

Group Names Box:

 The NGRAIN Groups dialog allows you to enter groups in the "Group Names:"
field.  

 For every group there is an associated search string with which TransMagic will
search entity names for an add those entities to that group.

 You can search for multiple strings by adding a semicolon ";" between search
strings.

 The same entity can be added to more than one group.

 Click the "New" button to create a new group.

 Click the "Delete" button to delete the currently highlighted group.

 Click the "Move Up" button to move the currently highlighted group up in
the list.  The order of the list does determine the order of processing for
NGRAIN Groups and will affect the "VPC ID" number of the group inside the
NGRAIN NGW file.  However, the benefit to the user will be to organize the list
for clarity.

 Click the "Move Down" button to move the currently highlighted group down
in the list.  However, the benefit to the user will be to organize the list for
clarity.

 NGRAIN Groups are stored in a file on the hard drive named "GroupName.grp"
in the following folder:

 XP: %USERPROFILE%\My Documents\TransMagic  NGRAIN Groups

 Visa & Win7: %USERPROFILE%\Documents\TransMagic  NGRAIN Groups

 This file can be copied to other machines that need to use these groups
into that folder on a different machine and TransMagic will read the
groups from that file.

Download Viewer - This link will launch your browser and navigate to the download page for
the NGRAIN Mobilizer Viewer.  NGRAIN’s free viewer, Mobilizer, operates within HTML pages,
Microsoft Word documents, and other materials to deliver unsurpassed real-time interactivity
with 3D Knowledge Objects (3KO Files), on common desktop, laptop, and Tablet computers.

Note: To download the free NGRAIN Viewer go to:

www.ngrain.com/download/viewer

-o-
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Parasolid Read Page*

Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Read Free Edges - Check this to enable the reading of edge (wire-frame) data.

Read Free Points - Check this to enable the reading of point data.

Read Hidden Entities - Check this to read in entities marked as "hidden". 

Reset Defaults - Click this button to Reset to TransMagic default settings for Parasolid.

* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com

-o-
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Parasolid Write Page*

Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Write Free Edges - Check this to enable the writing of edge (wire-frame) data.

Write Free Points - Check this to enable the writing of point data.

Write Hidden Entities - Check this to write out entities marked as "hidden". 

Parasolid Version Number - Use this pull-down menu to set the Parasolid (*.x_t) version that
will be saved when you save as a *.x_t file.  By default this version is 17.0 as this offers the
greatest compatibility with Parasolid based products such as UG/NX, SolidWorks, SolidEdge,
IronCAD, etc.  It's recommended that you set the Parasolid version to the latest version
supported by your Parasolid based product.  Likewise, you may also need to set the Parasolid
version to an earlier version to be compatible with your Parasolid based product.

Reset Defaults - Click this button to Reset to TransMagic default settings for Parasolid.
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* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com
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SolidWorks Read Page*

Read:
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Read Free Edges - Check this to enable the reading of edge (wire-frame) data.

Read Free Points - Check this to enable the reading of point data.

Read Hidden Entities - By default TransMagic does not read Blanked or "Hidden" entities from
the file; however, to read hidden entities, check this option.

Read Suppressed Entities - By default TransMagic does not read parts that have been
suppressed in the original CAD system although these parts are still present in the file.  Enabling
this option will instruct TransMagic to process these entities.

Free Surfaces - By default TransMagic does not free surfaces from SolidWorks files.  Enabling
this option will instruct TransMagic to read free surfaces.
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Reset Defaults - Click this button to Reset to TransMagic default settings for Parasolid.

* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com

-o-
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STEP Read Page*

Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Read Free Points - By default TransMagic does not read in free points.  To read in Free Points
check this option.

Read Free Edges - Check this to enable the reading of edge (wire-frame) data.

Reset Defaults - Click this button to Reset to TransMagic default settings for STEP.

* Depending on your version of TransMagic you may not have the ability to read in or write
out to certain file formats.  For any questions on your version or to upgrade your version,

please send your inquiries to info@transmagic.com

-o-

 



p128

TransMagic R10 User Guide

© TransMagic Inc, 2013

STEP Write Page*

Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Write Free Points - Check this to enable the writing of point data.

Write Free Edges - Check this to enable the writing of edge (wire-frame) data.

Application Protocol

AP203: CONFIG_CONTROL_DESIGN schema.

AP214: AUTOMOTIVE_DESIGN schema.

Reset Defaults - Click this button to Reset to TransMagic default settings for STEP.

* Depending on your version of TransMagic you may not have the ability to read in or write
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out to certain file formats.  For any questions on your version or to upgrade your version,
please send your inquiries to info@transmagic.com

-o-
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STL Write Page*

Write
Normal Deviation - Every facet position (x,y,z), also called a node, rests exactly on the surface
of a part.  At every facet node a surface normal can be created.  Normal Deviation specifies that
at every facet-node-surface-normal the maximum deviation angle in degrees between any other
facet-node-surface-normal can not exceed this degree value.

Maximum Surface Deviation - Maximum Surface Deviation specifies a value based on the
application units specified under the File->Settings dialog and General tab.  This value is the
maximum perpendicular distance from the center (centroid) of any facet to where this
perpendicular ray intersects with the true surface of the part.

Maximum Edge Length Preference
Maximum Edge Length By Percent - Maximum Edge Length By Percent specifies the
edge length of the triangles based on a percentage of the length of the diagonal of the
bounding box of the part.  This is a much simpler way to establish edge length because
subdividing facets based on length generally only occurs on planar faces which should
preferably contain fewer facets than curved surfaces.  Curved surfaces are generally
subdivided based on the Maximum Surface Deviation and Normal Deviation settings and
usually override the Maximum Edge Length.
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Maximum Edge Length By Unit - Maximum Edge Length By Unit specifies the edge
length of the triangles based on a unit value based on the application units specified
under the File->Settings dialog and General tab.  This setting is purposely set to a high
value because if a very small unit is specified the processing time and file size can grow
unnecessarily large.  This setting is better suited to very specific cases when generating
an FEA mesh vs. a Rapid Prototype file.  Even as such this setting is generally not even
used when generating an FEA mesh as the Maximum Edge Length By Percent is usually
the preferred way to control this value.

Procedural Faceting - Normally all facets are based on spline approximations of surfaces - this
results in a higher performance faceting; however, it's not as accurate as possible.  Procedural
Faceting will cause the faceter will facet surfaces based on their procedural definition where
possible (i.e. spheres planes, cylinders, tori, cones, etc.) which is more accurate.

Adaptive Faceting - Adaptive Faceting is employed to lay a grid of non-equidistant lines, rather
than a regular grid, for surfaces. This non-regular grid is based on the maximum surface
deviation.  Higher curvature areas get a greater number of grid lines, while lower curvature areas
get fewer lines. In all cases, this setting tries to satisfy the facet settings to generate more
uniform triangle sizing.  This is a processor intensive option and is well suited to generating
uniformly triangulated *.stl files for the purposes of generating an FEA mesh vs. a Rapid
Prototype mesh.

FEA Example
To create an FEA style surface mesh in *.stl form, change the settings like the dialog below, save
your file as *.stl and re-load for review.
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UG/NX Read Page*

Read
Transfer Attributes - This option enables the transfer of Name, Layer & Color information.

Read Blanked Parts - By default TransMagic does not read Blanked or "Hidden" entities from a
UG/NX file as these are typically construction geometry and other geometry not necessary to
represent the main part or assembly.  However, to read Blanked entities, check this option.

Read Visible Layers Only - By default TransMagic does not read Invisible Layers.  If you want
to read entities from Invisible Layers into TransMagic, un-check this option.

Read Suppressed Entities - By default TransMagic does not read parts that have been
suppressed in the original CAD system although these parts are still present in the file.  Enabling
this option will instruct TransMagic to process these entities.

Resurface Splines - By default TransMagic will re-create erroneous spline surfaces that are
common in some UG/NX files.  Though there is no reason to disable this option, you may. 
Disabling this option will cause TransMagic to read in the erroneous spline surfaces.
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Read Free Edges - Check this to enable the reading of edge (wire-frame) data. 

Read Free Points - By default TransMagic does not read in free points.  To read in Free Points
check this option.

Apply Tolerance Attributes - Sometimes the kernel behind UG/NX, Parasolid, will allow
tolerances too large for some formats.  If you read in a UG/NX file, write it out to another format,
and the importing application has problems bringing that file in, then you can un-chec k this
option, re-read the UG/NX file and re-write it out.  This will often cure this tolerance anomaly.

Reset Defaults - Click this button to Reset to TransMagic default settings for UG.

-o-
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Right-Click Menu

No Selection

Orbit View - Select Orbit View then depress the left mouse button and slide across the screen to
rotate the view.

Zoom In/Out - Select Zoom In/Out then depress left mouse button and slide the mouse up and
down to zoom in and out on the view.

Pan View - Select Pan View then depress left mouse button and slide the mouse across the
screen to laterally position the view.

Zoom All - Select Zoom all to zoom all the parts in the view so that they all fit in the view.

Zoom To Window - Select Zoom To Window then left mouse button and drag to create
rectangular window in the view, then release the mouse button. The view will then update to
reflect the contents of the window.

Single Select - Single Select allows you to select one entity at a time depending on what filter
you have set in the Filter Selection menu.  You can select multiple single entities by holding down
the Shift key and clicking on the entities individually.

Window Select - Window Select allows you to drag a window around a collection of entities.
Using the left mouse button depress and drag your mouse across the screen to create a
rectangular selection window.

Filter Selection - The Filter Selection function allows the selection of seven different entity
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types.

Vertex - Selecting Vertex will enable the selection of only vertices.
Note: Vertices are not shown by default.  To enable the showing of vertices and therefore
the selection of them right-click anywhere in the window and select Show->Vertices.

Edge - Selecting Edge will enable the selection of only edges.

Face - Selecting Face will enable the selection of only faces.

Body - Selecting Body will enable the selection of only Bodies.  Bodies are the default
general selection type in TransMagic and after many operations the Filter Selection will
switch back to Body selection mode.

PMI - The PMI selection menu will be added to the Filter Selection right-click menu if the
following cases:
o You have the correct License Key which allows the translation of PMI data.
o You have selected "Enable PMI Translation" on the File->Settings, General Tab.  This is

off by default and must be selected before TransMagic will translate PMI data.
o The file you've read in contains PMI data.

When PMI data is present and visible you can set this filter to PMI and use Single Select
to select the PMI data.  There are two operations that can be performed on PMI data
currently:
o Right-Click and select "Orient View To PMI" which will orient the view normal to the

PMI data.  This is very handy for generating print outs of the PMI data.
o Click the "Delete" key on your keyboard to remove the selected PMI data.

Window Selection Options - These options allow you to use Window Select to select
only certain types of geometry.  This is very useful when grouping different types of
geometry together for various purposes.  For a better understanding of how using
Filtering can benefit you see the "Advanced Manual Repair" tutorial under Tutorials.

Enable Face Selection - When this option is disabled you will not be able to select faces.
Depending on the size of part(s) or assembly(ies) you're loading into TransMagic,
disabling the Enable Face Selection can relieve some processor load when loading
parts/assemblies into TransMagic and speed up the loading process.

Show - The Show menu lists the currently visible items with a check mark and permits the user
to show or hide these items by checking or unchecking the items.  In order to select an item
using the Filter Selection function, the item must first be Shown.  The only visualization item that
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is not Shown by default are Vertices.  The available items for showing or hiding are:

Vertices - By default part vertices are not shown.  Check this to enable the visualization
and selection of vertices.

Edges - By default part edges are shown.  Uncheck this to disable the visualization and
selection of part edges.

Faces - By default part faces are shown.  Uncheck this to disable the visualization and
selection of part faces.  The result will appear as a wire-frame visualization if part Edges
are turned on.

Lights - By default rendering lights are on.  Lights are what gives the shading a realistic
appearance.  Turning lights off will make the part appear "flat" and un-shaded.

Window Select By Color - The Window Select By Color function will enable you to select and
highlight parts of a certain color.  You must first select a part with the color you want to filter. 
Then click the Set Color Filter icon.  Now any selection you make will filter for this color and only
select and highlight the parts whose color match that specified by the Set Color Filter function.

Shade Surface - The Shade Surface submenu allows you to change which side of the surface is
rendered.  The choices are:

Front - Shade the front of the surface.  The front of the surface is used for shading solids
as rendering only one side (the outside) of the surface is the most efficient way to
visualize a solid part.

Back - Shade the back of the surface (inside).

Both - Shade both sides of the surfaces.  This shading mode is enabled whenever a
surface is loaded into TransMagic.  While this consumes more graphics power, it creates a
better visualization for rendering surface models.  If Both were not enabled you would
only see one side of surface models - the "material bearing" or "normal" side of the
surface.

Render Mode - The Render Mode submenu allows you to between the four following rendering
modes:
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Triangulated - When rendering a scene what is actually being shaded is an
approximation of the actual part geometry.  These approximations are triangles. 
Switching to Triangulated mode allows you to see these triangles.

Wireframe - Switch to wireframe rendering mode where faces are not shaded and edges
are.

Gouraud Shaded - Gouraud shading is an industry standard mathematic calculation of
the light and shading in a scene.  This can simply be referred to as shaded.

Hidden Line - Hidden line mode is where a part is shaded in wireframe mode and
occluded edges are removed and   silhouette edges are added giving the appearance of a
2D model drawing.

Phong Shaded - Phong shading is a more realistic mathematic shading calculation.  It
looks "high end" especially when combined with a Medium High or High Facet Resolution. 
It requires more graphics processor power than Gouraud shading.

Flatten Assembly - In certain circumstances it can be beneficial to remove the assembly
hierarchy of an assembly and convert it to a simple flat list of parts.  This function does just that.
The parts will still be in the appropriate positions in space but the end result will be a flat list of
parts.  
Caution: One caution when using this function is RAM usage.  TransMagic handles assemblies
very efficiently and capitalizes on instances.  Instances are copies of parts or even whole
assemblies.  Take for example 1 single bolt copied/instanced in 100 different locations. 
TransMagic will represent the geometry of this bolt only once in memory and 99 locations. 
When you flatten an assembly you will actually create 100 individual copies of this bolt.  So one
can see how this could cause RAM usage to spike, especially with assemblies that have a large
amount of instanced geometry.

-o-
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Vertex Selected
To invoke the Vertex Selected Right-Click Menu, your Filter Selection must be set to Vertex and
an Vertex(s) must first have been selected.  In addition Vertices are not Shown by default so in
order to select a Vertex, you must first right-click and select Show->Vertices.

Orbit View - Select Orbit View then depress the left mouse button and slide across the screen to
rotate the view.

Zoom In/Out - Select Zoom In/Out then depress left mouse button and slide the mouse up and
down to zoom in and out on the view.

Pan View - Select Pan View then depress left mouse button and slide the mouse across the
screen to laterally position the view.

Zoom All - Select Zoom all to zoom all the parts in the view so that they all fit in the view.

Zoom To Window - Select Zoom To Window then left mouse button and drag to create
rectangular window in the view, then release the mouse button. The view will then update to
reflect the contents of the window.

Deselect All - Deselects any currently selected item.  When the right-click menu is invoked after
Deselect All, the No Selection Menu will appear.

-o-
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Edge Selected
To invoke the Edge Selected Right-Click Menu, your Filter Selection must be set to Edge and an
Edge(s) must first have been selected.

Orbit View - Select Orbit View then depress the left mouse button and slide across the screen to
rotate the view.

Zoom In/Out - Select Zoom In/Out then depress left mouse button and slide the mouse up and
down to zoom in and out on the view.

Pan View - Select Pan View then depress left mouse button and slide the mouse across the
screen to laterally position the view.

Zoom All - Select Zoom all to zoom all the parts in the view so that they all fit in the view.

Zoom To Window - Select Zoom To Window then left mouse button and drag to create
rectangular window in the view, then release the mouse button. The view will then update to
reflect the contents of the window.

Deselect All - Deselects any currently selected item.  When the right-click menu is invoked after
Deselect All, the No Selection Menu will appear.

Change - The Change menu contains functions related to the modification of the selected Edge.
The available Change functions are:

Split Edge - This function will launch the "Split Edge At Location" dialog which will allow
you to specify either a percentage or length by which to split an edge along.  The result of
this function will be two edges and an extra vertex at the specified location.
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Query - The Query menu contains functions related to the verification and measurements of a
Edge.  The available Query functions are:

Check Edge(s) Length\Arc Properties - The Check Edges Length function calculates
the length of all of the edges of the selected Face or Faces.  If an arc is selected this
function will also calculate the radius and center position of the arc.

Display bounding Box - The Display Bounding Box function will create a transparent
bounding shape that encompasses the selected entity(ies). This box will show the precise
dimensions of the box.

-o-
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Face Selected
To invoke the Face Selected Right-Click Menu, your Filter Selection must be set to Face and a
Face(s) must first have been selected.

Orbit View - Select Orbit View then depress the left mouse button and slide across the screen to
rotate the view.

Zoom In/Out - Select Zoom In/Out then depress left mouse button and slide the mouse up and
down to zoom in and out on the view.

Pan View - Select Pan View then depress left mouse button and slide the mouse across the
screen to laterally position the view.

Zoom All - Select Zoom all to zoom all the parts in the view so that they all fit in the view.

Zoom To Window - Select Zoom To Window then left mouse button and drag to create
rectangular window in the view, then release the mouse button. The view will then update to
reflect the contents of the window.

Deselect All - Deselects any currently selected item.  When the right-click menu is invoked after
Deselect All, the No Selection Menu will appear.

Change - The Change menu contains functions related to the modification of the selected
Face(s).  The available Change functions are:
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Colorize - Single Select or Window Select a face or multiple faces and then select the
Colorize function to apply a random color to each face in the selection list.  

Unhook Faces - The Unhook Faces function unhooks the selected face(s) from the Body.

Split Face By Percentage - This function will launch the "Split Face" dialog which will
allow you to split the face in the U or V direction by the user-specified value:

 

Split Face By Split-Trim Geometry - This function will Split the selected face by the
previously set Split-Trim geometry.  To set geometry as Split-Trim geometry see the "Set
As Split-Trim Part" function at the bottom of this document.

Trim Face By Split-Trim Geometry - This function will Trim the selected face by the
previously set Split-Trim geometry.  To set geometry as Split-Trim geometry see the "Set
As Split-Trim Part" function at the bottom of this document.

Query - The Query menu contains functions related to the verification and measurements of a
Face.  The available Query functions are:

Check Surface(s) Area - The Check Surface(s) Area function calculates the surface area
of the selected Face or Faces.

Check Total Edges Length - The Check Edges Length function calculates the length of
all of the edges of the selected Face or Faces.

Display bounding Box - The Display Bounding Box function will create a transparent
bounding shape that encompasses the selected entity(ies). This box will show the precise
dimensions of the box.
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Hide - This function will Hide (only temporarily) the selected Face or Faces.  This function is
extremely useful when performing Manual Repair.  You are able to hide fac e temporarily while
inspecting geometry underneath the faces.  To re-render the faces after hiding click CTRL+R to
Redraw the window.

Show Face Curvature - After selecting a Face or Faces, select this function to render the face
curvature.  The curvature rendering is a gradient from Green = lowest curvature to Red =
Highest curvature.  This function is useful when inspecting surface to surface boundary
conditions.

Set As Split-Trim Face - After first selecting a Face, click this function.  The Face will highlight
and indicate that it is now "Split-Trim" geometry by which you can Split or Trim other Faces or
Bodies against.  This is the first step in a Split/Trim operation.  The second step will be to select
the Face or Body to be Split/Trimmed, then right-click and select Change->Split Face By
Split-Trim Geometry to Split the selected part by the Split-Trim geometry or select
Change->Trim Face By Split-Trim Geometry to Trim the selected Face by the Split-Trim
geometry.

-o-
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Body Selected
To invoke the Body Selected Right-Click Menu, your Filter Selection must be set to Body and a
Body(s) must first have been selected.

Orbit View - Select Orbit View then depress the left mouse button and slide across the screen to
rotate the view.

Zoom In/Out - Select Zoom In/Out then depress left mouse button and slide the mouse up and
down to zoom in and out on the view.

Pan View - Select Pan View then depress left mouse button and slide the mouse across the
screen to laterally position the view.

Zoom All - Select Zoom all to zoom all the parts in the view so that they all fit in the view.

Zoom To Window - Select Zoom To Window then left mouse button and drag to create
rectangular window in the view, then release the mouse button. The view will then update to
reflect the contents of the window.

Deselect All - Deselects any currently selected item.  When the right-click menu is invoked after
Deselect All, the No Selection Menu will appear.

Lite Repair - After first selecting a part or multiple surfaces with either the Single or Window
Select function, select Lite Repair to perform Lite Repair on the selected part(s)/surfaces.  For a
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more complete description of Lite Repair see "Lite Repair" under the "Repair Operations" section.

Full Repair - After first selecting a part with the Single Select function, select Full Repair to
perform Full Repair on the selected part.  For a more complete description of Full Repair see "Full
Repair" under the "Repair Operations" section.

Change - The Change menu contains functions related to the modification of the selected
Body(s).  The available Change functions are:

Change Color - To change the color of a part or collection of parts after first selecting
them with Single/Window Select, select the Change Color function button. A standard
Windows color dialog window will then be displayed for your to manipulate the colors.

Change Layer - This function allows you to change the existing layer\level (if any) that a
part or parts currently resides on.  After first selecting a part or multiple parts you can
access this function via the Geometry  menu or by right click (under Change).  Enter a
new layer number for your selection and click "OK".  Your parts will now be on this
layer\level when saved out to any format that supports layers\levels.  To visually see the
layer that your part or parts reside on open the Assembly Browser and you will see in
front of the part name the notation [L:X], where "X" is the layer that your part is currently
on.  If your part is currently not on a layer you will not see the [L:X] notation.

Change Name - The Rename Part function will launch the Part Name dialog box:

Enter a new part name and click "OK" or "Cancel".  You can see part names in the
Assembly Browser which is accessible by selecting the Tools menu and then selecting
Assembly Browser.

Colorize - Single Select or Window Select a part or multiple parts and then select the
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Colorize function to apply a random color to each part in the selection list.  This is very
useful when you bring a large assembly into TransMagic and all of the sub-components
are one single color.  Changing the color of all the parts helps to clearly differentiate
between parts in the assembly.

Move Selection - After first selecting a part or multiple parts with either the Single or
Window Select function, select the Move Selection function to transform the selected
entity(ies) by dragging the left mouse button. Note, the translation direction will always
be horizontal to the view direction. To perform a perfect lateral or vertical transformation
make sure you first select on the Top, Front or Right Side View buttons to first orient the
view into a standard perpendicular orientation.

Scale Part - After first selecting a part or multiple parts with either Single or Window
Select, select the Scale Part function to apply a scaling factor to the part(s). Sometimes
an exporting application can inadvertently write out a model scale larger or smaller than
what the part was designed in. This results in a part being translated into TransMagic very
large or very small. For example a part designed in mm that was 100 mm long and
written out to Meters would come into TransMagic as 100 Meters long! In this case
applying a scaling factor of .001 would bring the part back down to mm.

Unhook Faces - The Unhook Faces function is useful if you want to take a solid body and
reduce it to surfaces.  You can then Group or stitch together a group of surface, for
example the contoured surfaces of a mold cavity, using Lite Repair.  You could then select
this contoured surface group and use File->Export to save just the group to a new file.  To
use the Unhook Faces function simply select a part and then select Geometry->Unhook
Faces.

Reverse Face Normals - Sometimes after model repair, instead of orienting all of the
model's faces to point outward and describe an enclosed void, the faces get all reoriented
inwards. This can also happen without Repair but simply due to a poorly executed export
of a model to *.IGES, *.STEP, etc. from a modeling system. To reverse this condition,
select the Select Tool and select the affected model, then select the Reverse Face Normals
function to reverse the faces.

Split Part By Split-Trim Geometry - This function will Split the selected part by the
previously set Split-Trim geometry.  To set geometry as Split-Trim geometry see the "Set
As Split-Trim Part" function at the bottom of this document.

Trim Part By Split-Trim Geometry - This function will Trim the selected part by the
previously set Split-Trim geometry.  To set geometry as Split-Trim geometry see the "Set
As Split-Trim Part" function at the bottom of this document.

Query - The Query menu contains functions related to the verification and measurements of a
Body.  The available Query functions are:
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Check Part - After selecting a part using the Single Select function, select the Check Part
function to perform a geometric integrity check on the selected part. Refer to the output
window for repair results.

Note: Before using this function, please read the “Getting Started Guide” for the intended
usage of this function in the proper context. 

Show Gaps - After selecting a part using the Single Select function, select the Show
Gaps function to highlight (in red) gaps in the model. This is a good measure of the
accuracy of the model. After Full Repair or Super Repair you should see the number of
gaps go down and in many cases go to zero. No gaps, or tolerant edges, means that the
surface boundaries of adjacent surfaces intersect precisely. Gaps are OK and your
translations will be successful; however, less gaps will generally mean better translations
out of TransMagic.

Display Part bounding Box - Select a part or a collection of parts using Single or
Window Select. Then select the Display Part Bounding Box function to create a
transparent bounding shape that encompasses the selected entity(ies). This box will show
the precise dimensions of the box. This function is useful in determ ining the minimum
material required to machine a part for example.

Calculate Part Mass Properties - After selecting a part using Single or Window Select,
select the Calculate Part Mass Properties function.  The Calculate Part Mass Properties
function allows you to check:

o Cubic Volume
o Weight based on density via a catalog of materials or is user selectable material
o Center of Mass (CoM) and the ability to create a true geometric representation of the

CoM with planar intersection graphs.  The CoM is read/writeable to any supported
TransMagic format.

o Inertial Properties: Principal Axes of Inertia, Principal Moments of Inertia, & Inertia
Tensor.

For a more compile description of the Check Part Mass Properties function see "Mass
Properties" under the "Operations Toolbar" in the "Toolbars" section.

Check Surface Area - The Check Surface Area function calculates the surface area of the
selected Body.

Check Edges Length - The Check Edges Length function calculates the length of all of
the edges of the selected Body.

Set Color Filter - The Set Color Filter function enables you to select a Color filter for selecting
parts of a certain color.  This is especially useful when you bring in a surface model assembly
that contains many parts of different colors that need to be stitched into solids.  You must first
select a part with the color you want to filter.  Then click the Set Color Filter icon.  Now any
selection you make will filter for this color and only select and highlight the parts whose color
match that specified by the Set Color Filter function.



p149

TransMagic R10 User Guide

© TransMagic Inc, 2013

Group Selection - After first selecting a collection of models using the Single Select Tool or
Window Select Tool, then click the Group Selection function to combine the parts into a single
selectable part.  This is very helpful when "piecing together" groups of surfaces that belong to a
single part for the eventual purpose of stitching them together with Lite Repair.

Ungroup Selection - To ungroup a collection of parts that have been group simply select the
group with the Single Select Tool, then click the Ungroup Selection function. This will separate
this collection of "lumps" into individual parts that can be selected individually.

Hide Selection - After first selecting a part or multiple parts with either the Single or Window
Select function, click the Hide Selection function to hide the part(s) from the view.  You can use
the Show Selection function to show the part(s) again later.  If the Assembly Browser is open the
name of the part will read as "(Hide)" in front of the part name.

Show Selection - To show a part that has been hidden you must first open the Assembly
Browser via the Tools->Assembly Browser menu function.  Select a part labeled "(Hide)" and
then select the Show Selection function to add the part back to the display.

Change Facet Resolution - The Change Facet Resolution submenu offers four options:
Note: TransMagic uses what is called a "Normal Deviation" for setting the facet resolution

of a part.  Facets are the triangles that get shaded by TransMagic's visualization engine and
give the part a realistic appearance.  The Normal Deviation refers to the deviation between
any two surface normal's.  This deviation is measured in degrees.  So the Normal Deviation

between any two facet nodes, inclusive of the actual geometric surface, will not vary
greater in degree than the amount specified by Normal, Medium High, High or Super High

facet settings.

Normal - A Normal Deviation of 15 degrees.

Medium High - A Normal Deviation of 10 degrees.

High - A Normal Deviation of 5 degrees.

Super High - A Normal Deviation of 1 degree.

Note: Setting the Facet Resolution to High or Super High can consume massive amounts of
memory depending on the complexity and size of the part(s) selected.
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Set As Split-Trim Part - After first selecting a Body, click this function.  The Body will highlight
and indicate that it is now "Split-Trim" geometry by which you can Split or Trim other Faces or
Bodies against.  This is the first step in a Split/Trim operation.  The second step will be to select
the Face or Body to be Split/Trimmed, then right-click and select Change->Split Part By
Split-Trim Geometry to Split the selected part by the Split-Trim geometry or select
Change->Trim Part By Split-Trim Geometry to Trim the selected Body by the Split-Trim
geometry.

-o-
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PMI Selected

Orbit View - Select Orbit View then depress the left mouse button and slide across the screen to
rotate the view.

Zoom In/Out - Select Zoom In/Out then depress left mouse button and slide the mouse up and
down to zoom in and out on the view.

Pan View - Select Pan View then depress left mouse button and slide the mouse across the
screen to laterally position the view.

Zoom All - Select Zoom all to zoom all the parts in the view so that they all fit in the view.

Zoom To Window - Select Zoom To Window then left mouse button and drag to create
rectangular window in the view, then release the mouse button. The view will then update to
reflect the contents of the window.

Deselect All - Deselects any currently selected item.  When the right-click menu is invoked after
Deselect All, the No Selection Menu will appear.

Orient View To PMI - Once you have set the Filter Selection to PMI and selected a PMI data
entity, this function will orient the view normal to the PMI data.  This is very handy for
generating print outs of the PMI data.

-o-

 



p152

TransMagic R10 User Guide

© TransMagic Inc, 2013

Repair Operations

Auto Repair Wizard
When you open a geometric file in TransMagic, the first thing you'll notice is that immediately
after the part has been opened an interrogation process starts.  This process is the Auto Repair
Wizard.  TransMagic is automatically analyzing the geometry that was just opened and is
determining what, if any, additional steps may need to be taken to get the geometry into a high
quality and useable state.

The beauty of the Auto Repair Wizard is that the best course of action is to follow the
recommendations by simply clicking a single button.  Decades of TransMagic  industry knowledge
and expertise are built into this easy to use wizard.

Another nice feature is that Repair operations are only applied to the parts that require them. 
This is a huge time saver as you don't have to check each part individually of a large assembly as
the Auto Repair Wizard will do so.  Different parts may require different levels of Repair as well
which will also be determined by the Auto Repair Wizard.

The Auto Repair Wizard has three states:

The Green Light
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As the wizard states, your file looks good, you can now proceed to work with the file with
confidence whether you're quoting, creating illustrations or translating the file out to another
format.

The Yellow Light



p154

TransMagic R10 User Guide

© TransMagic Inc, 2013

This state has a different meaning for Solids, Surfaces and Sheet-Bodies:

Solids: For Solids this state means that issues were found with the file but they are not critical
issues.  They are issues that will likely not affect downstream operations.  However, the
recommended course of action at this stage is to perform the recommended action which is Lite
Repair.  See the Lite Repair documentation for more information.

Surfaces: For Surfaces this state means that a surface model was loaded and the first
recommend action is Lite Repair.  In addition to correcting error, a primary function of Liter
Repair is to stitch surfaces into solids automatically.  See the Lite Repair documentation for more
information.

Sheet-Bodies: A Sheet-Body is a collection of surfaces that have been stitched together but they
do not form a solid.  Sometimes this is intentional but most of the time a sheet-body is the result
of missing surfaces.  Missing surfaces are usually the result of a defect in the translator that
created the file.  TransMagic is able to easily Repair these conditions as well with it's
MagicSURFACE technology.  If there are missing surface they will be identified by the Auto Repair
Wizard as "un-stitched edges".  For more information about MagicSURFACE see the Advanced
Tab  documentation.
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The Red Light

This state means that severe issues have been found that will most likely affect downstream
operations and even TransMagic operations.  The recommended course of action at this stage is
to perform the recommended action which is either Full Repair or Advanced Full Repair.  See the
Full Repair documentation for more information.  Advanced Full Repair is only accessible from the
Auto Repair Wizard dialog as it is only necessary in very specific cases.  Advanced Full Repair is
also resource intensive as it does a complete analysis and Repair to every single face (surface) in
the parts that need the Repair.

Additional Notes:
 Notice on the bottom of the dialog "Don't show this dialog during File Loading".  You disable

Auto Repair Wizard during File Loading by checking this box.  

 You can always run the  Auto Repair Wizard from the Home Tab.  Also, if you manually

run  Lite Repair or  Full Repair on a part or assembly, the Auto Repair Wizard
geometric checking and validation functionality will be run automatically afterwards. 
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However, you can also turn off the Auto Repair Wizard by selecting  Settings on the
Home Tab, Repair Page.

 If you turn the Auto Repair Wizard off entirely then TransMagic will operate in a "classic" state
as it has for all previous versions of TransMagic.  This means that instead of the Auto Repair
Wizard, you will see Repair logs and Check Part logs displayed after those operations.

-o-
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*Un-Repaired Geometry Dialog

The Un-Repaired Geometry Dialog will be shown in four cases provided you have licensed the
MagicSURFACE Advanced Toolkit:

1) If the Auto Repair Wizard is not in a "Green Light" state and the user clicks Exit.

2) All levels of automated Repair have been attempted by the Auto Repair Wizard and the user
needs to resolve some geometric errors manually using TransMagic's Advanced Toolbar tools.

or

3) If TransMagic is running in Classic Mode (i.e. the Auto-Repair Wizard is disabled) AND the
option "Show Un-Repaired Geometry Dialog After Repair and Geometry Checking" is enabled on
the Repair tab of the Settings Pages as shown below:
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AND there are Geometry Check or Repair Errors that remain after running these operations.

4) The  Show Bad Geometry function has been clicked on the Advanced Toolbar.

The Un-Repaired Geometry Dialog informs the user that there is Un-Repaired Geometry as the
name implies but it also highlights the problem geometry ORANGE.  Problem geometry can be a:
Vertex, Edge or Face.

Geometry attached to this problem geometry will be highlighted WHITE.  This simplifies the
process of identifying the problem geometry and facilitates the user in manually resolving the
problem areas:
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To Re-Draw the display and remove the highlighted geometry you may simply click the "Redraw
Window" button or click CTRL+R.

A useful option when dealing with very large parts and potentially only a few bad geometric area
highlights is to check the "Render In Wire-Frame Mode" check-box which as the name suggests

will switch the rendering to  Wire-Frame Rendering.  This can make the highlighted geometry
much easier to find:
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Click "OK" to exit the Un-Repaired Geometry Dialog.

Click the "Don't Show This Message Again" check box to disable this dialog.  You can always
enable the dialog again later in the General Page.

* The Un-Repaired Geometry Dialog requires the MagicSURFACE Advanced Toolkit.

-o-
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Lite Repair
Note: Before using this tool, please read the “Getting Started Guide” for the intended usage

of this function in the proper context. 

After selecting a part(s) or a collection of surfaces with the Single or Window Select Tool, click
the Lite Repair Tool to perform Lite Repair on the selected entities. Refer to the output window
for repair results.

Lite Repair performs the following functions on a part:

1) Repair Initialization.  Examines the part and attaches intelligent attributes that are used to
establish tolerances for stitching, simplification and Repair.

2) Repair Pre-processing.  Find and remove zero-length edges, zero-area faces, and duplicate
vertices.  These are common, extraneous, & unnecessary geometry.

3) Geometric Simplification. The intelligent attributes established in Repair Initialization are
analyzed for the purposes of Geometric Simplification.  Geometric Simplification attempts to
simplify spline surfaces into analytic surfaces (planes, cylinders, cones, tori, and spheres). 

4) Geometric Stitching. The intelligent attributes established in Repair Initialization are analyzed
for the purposes of Geometric Stitching.  Geometric Stitching attempts to "pair up" edges of free
faces and stitch them together.  No stitching is performed if two faces are farther away than the
minimum tolerance established in Step 1, meaning, they are presumed to be free floating
surfaces.

5) Repair Post-processing.  After Geometric Simplification, Geometric Stitching, and Geometric
Creation and Repair, there are often artifacts left over from the operations that can affect the
fidelity of the translation.  These artifacts can be zero-length edges, zero-area faces, negative
area faces, duplicate vertices, or duplicate edges.  All of these artifacts are again analyzed and
removed during this phase.  Finally, "tolerant attributes" are placed on gaps in the model that
could not be Repaired.  There are several reasons for a gap not being able to be properly
Repaired such surface domains that could not be extended, surface domain boundaries that are
coincident with trimming curve boundaries, varying speed tangent normal's at surfaces
boundaries (can't be extended because they would result in a surface self-intersection).  Gaps
that can not be fully "closed" to within TransMagic's extremely high 10e-6 mm, are given a
tolerance that indicate that the gap is still closed, though not accurate to 10e-6.  These gaps can

be seen by Selecting the model and then selecting the Show Gaps Tool .  It's important to
note; however, that what TransMagic perceives as a gap, the receiving application may deem to
be more than accurate enough based on it's own tolerances.  For this reason it should be noted
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that the "gaps" in a model are only a measure relative to TransMagic only that help to illustrate
what corrections have been made.

6) Geometric Cleaning.  After Repair Post-processing, the part is again analyzed for unnecessary
faces, edges, vertices, and associated data.  These unnecessary geometries are then removed. 

7) Repair Termination.  All intelligent attributes created during Repair Initialization are rem oved.

Note: If your surface model or assembly contains colors, a more advanced and quite often
more successful technique of isolating surfaces to stitch into individual solids is to use the 

 Set Color Tool to create a color filter to use in conjunction with TransMagic's 

Single Select and Window Select tools to isolate and select surfaces of only a certain
color and stitch them into a solid using Lite Repair.  See the "Surface Assembly Repair

Using Colors" in the "Tutorials" section.

Note: TransMagic will notify you of un-stitched edges with a dialog box.  These edges can
be either "holes" in the part or simply surfaces floating in space, such as construction

geometry, that do not belong to a solid.  When you are done viewing these open edges you
should refresh the display with Ctrl+R before proceeding.  You can always show open edges

again by selecting the part and clicking the  Show Missing Surfaces icon.  If your part
has "holes" that you need to cover see the "Advanced Manual Repair" tutorial in the

"Tutorials" section.

Note: TransMagic will also attempt to notify you of duplicate surfaces by highlighting them
in White and adding the letter "D" in the center of the surface.  These are sometimes more

clearly visible when viewed in  wire-frame rendering as the duplicate surfaces will
remain shaded white while the rest of the model is in wire-frame rendering.  In most cases

duplicate surfaces are not necessary and can be deleting by selecting them (hold Ctrl to
select more than one) and deleting them (use the "delete" key on your keyboard).

Note: One of the phases of Lite Repair is to orient surfaces so that they are all "facing out". 
In rare cases, instead of orienting all of the faces outward, Lite Repair will orient the faces
inward resulting in a "negative" looking model in your application.  You can easily correct

this by bringing the model back into TransMagic  Single Selecting or  Window
Selecting the model, right-click and select Change->Reverse Face Normals.

-o-
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Full Repair
Note: Before using this tool, please read the “Getting Started Guide” for the intended usage

of this function in the proper context. 

After selecting a part using the Single Select Tool, click the Full Repair Tool to perform  Full Repair
on the selected entities. Refer to the output window for repair results.

Full Repair performs the following functions on a Body or
Face:

1) Repair Initialization.  Examines the part and attaches intelligent attributes that are used to
establish tolerances for stitching, simplification and Repair.

2) Repair Pre-processing.  Find and remove zero-length edges, zero-area faces, and duplicate
vertices.  These are common, extraneous, & unnecessary geometry.

3) Geometric Simplification. The intelligent attributes established in Repair Initialization are
analyzed for the purposes of Geometric Simplification.  Geometric Simplification attempts to
simplify spline surfaces into analytic surfaces (planes, cylinders, cones, tori, and spheres). 

4) Geometric Stitching. The intelligent attributes established in Repair Initialization are analyzed
for the purposes of Geometric Stitching.  Geometric Stitching attempts to "pair up" edges of free
faces and stitch them together.  No stitching is performed if two faces are farther away than the
minimum tolerance established in Step 1, meaning, they are presumed to be free floating
surfaces.

5) Geometric Creation and Repair. The intelligent attributes established in Repair Initialization
are analyzed for the purposes of Geometry Creation and Repair.  Geometry Creation and Repair
performs all the geometry related Repair operations, including fixing of edge geometries by
intersections, snapping surfaces for fixing tangencies, and refitting spline surfaces.

6) Repair Post-processing.  After Geometric Simplification, Geometric Stitching, and Geometric
Creation and Repair, there are often artifacts left over from the operations that can affect the
fidelity of the translation.  These artifacts can be zero-length edges, zero-area faces, negative
area faces, duplicate vertices, or duplicate edges.  All of these artifacts are again analyzed and
removed during this phase.  Finally, "tolerant attributes" are placed on gaps in the model that
could not be Repaired.  There are several reasons for a gap not being able to be properly
Repaired such surface domains that could not be extended, surface domain boundaries that are
coincident with trimming curve boundaries, varying speed tangent normal's at surfaces
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boundaries (can't be extended because they would result in a surface self-intersection).  Gaps
that can not be fully "closed" to within TransMagic's extremely high 10e-6 mm, are given a
tolerance that indicate that the gap is still closed, though not accurate to 10e-6.  These gaps can

be seen by Selecting the model and then selecting the Show Gaps Tool .  It's important to
note; however, that what TransMagic perceives as a gap, the receiving application may deem to
be more than accurate enough based on it's own tolerances.  For this reason it should be noted
that the "gaps" in a model are only a measure relative to TransMagic only that help to illustrate
what corrections have been made.

7) Geometric Cleaning.  After Repair Post-processing, the part is again analyzed for unnecessary
faces, edges, vertices, and associated data.  These unnecessary geometries are then removed. 

8) Repair Termination.  All intelligent attributes created during Repair Initialization are rem oved.

Note: One of the phases of Full Repair is to orient surfaces so that they are all "facing out". 
In rare cases, instead of orienting all of the faces outward, Lite Repair will orient the faces
inward resulting in a "negative" looking model in your application.  You can easily correct

this by bringing the model back into TransMagic  Single Selecting or  Window
Selecting the model, right-click and select Change->Reverse Face Normals.

-o-
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Contact Information 
Address: 

TransMagic, Inc.

P.O. Box 35079

Westminster, CO  80035-0759

Phone: 303-460-1406 

General Information: 

info@transmagic.com 

Technical Support: 

http://www.transmagic.com/support
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Formats

3D ACIS Bidirectional 

Version: Up to R23

3D CATIA V4 Bidirectional 

Read: Up to 4.2.4

Write: 4.1.9 - 4.2.4

3D CATIA V5 Bidirectional

Version: Up to R23

3D DWG Bidirectional

Version: R9 to 2013

3D HSF Bidirectional 

Version: Up to 19.0

3D IGES Bidirectional

Version: 4.0, 4.2, 5.2, 5.3 

JT Bidirectional

Version: 6.4 to 9.5

Autodesk Inventor Read Only

Version: Up to Inventor 2013

3D NGRAIN Write Only

Version: 3.2, 4.0, 4.1
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3D Parasolid Bidirectional 

Version: Up to V25.0

3D Pro/E Read only 

Version: Up to Wildfire 5.0

3D Creo Read only 

Version: Creo 2.0

3D SolidWorks Read only 

Version: SolidWorks98 - SolidWorks 2013

3D STEP Bidirectional 

Version: AP203, AP214 

Note: The TransMagic STEP translator reads both AP203 & AP214 Application Protocols,
though only Geometry, Name, Layer, & Color data is translated.

3D TransMagic Bidirectional

Version: Up to R9

3D UG/NX Read only 

Version: Up to NX8.5

* Depending on TransMagic license you may not have the ability to read in or write out to
certain file formats.  For any questions on your version or to upgrade your version, please

send your inquiries to info@transmagic.com

-o-
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Technical Support 
 If you run into a problem file please submit it to us for review.  Go to www.transmagic.com,

click Support, then Request Support.  This form allows you to securely upload up to 300MB of
data to us along with a description of the issue.

 For general questions you can send an e-mail to support@transmagic.com.

-o-

 

www.transmagic.com


p170

TransMagic R10 User Guide

© TransMagic Inc, 2013

System Requirements
Recommended System 
 Windows 7 Business (64-bit)
 64-bit Processor
 1 GB Graphics Card w/ Open GL or Direct3D acceleration
 12 GB RAM

Note: In general as translation is such a memory intensive process we recommend that you
set your RAM requirement based on the model sizes you will be translating.  We call this

the 10/4 rule.  RAM = 10x model size during translation and 4x model size after
translating.  This means that if you're translating a 50 MB file, you'll want 500 MB during

translation - not including any other running applications & 200 MB after translation.

 400 MB Free Hard Drive Space for TransMagic
 750 MB Free Hard Drive Space for TransMagic with V5

Minimum System Requirements 
 Windows XP Professional sp1 +
 Pentium II 
 Video Card (If you don't have an OpenGL card you can select software rendering, which will

speed up display drastically, under File->Settings->Appearance) 
 512 MB RAM

Note: In general as translation is such a memory intensive process we recommend that you
set your RAM requirement based on the model sizes you will be translating.  We call this

the 10/4 rule.  RAM = 10x model size during translation and 4x model size after
translating.  This means that if you're translating a 50 MB file, you'll want 500 MB during

translation - not including any other running applications & 200 MB after translation.

 400 MB Free Hard Drive Space for TransMagic
 750 MB Free Hard Drive Space for TransMagic with V5

-o-
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Automated Distribution Instructions
TransMagic has advanced distribution options built into it's standard
installer which support a multitude of distribution scenarios.

For reference simply running the standard TransMagic installer has the following effects:
 Displays the TransMagic End User License Agreement (EULA).
 Removes any previous version of TransMagic that may be present on the system.
 Installs all necessary TransMagic redistributables.
 Installs itself on the system and integrates into Windows in the following ways:

o Installs all core program functionality into the %ProgramFiles% directory by default,
which will have the form:
 %ProgramFiles%\TransMagic Inc\TransMagic RX

o Installs the TransMagic license manager program functionality into the
CSIDL_COMMON_APPDATA directory, which will have the form:
 CSIDL_COMMON_APPDATA\TransMagic\Licensing
 This directory structure must never be modified.

o Installs the TransMagic Sample Files into the CSIDL_COMMON_DOCUMENTS
directory, which will have the form:

 CSIDL_COMMON_DOCUMENTS\TransMagic\Sample Files
 This directory structure is optional.

o Populates the Windows application paths registry key:
 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App

Paths\TransMagic.exe
 Values (Value name \ Value data):

 (Default) \ %ProgramFiles%\TransMagic Inc\TransMagic
R9\System\TransMagic.exe

 InstallDir \ %ProgramFiles%\TransMagic Inc\TransMagic  R9\
 You can query the InstallDir value for the current TransMagic end-user install

path.
o Registers the TransMagic license mangers on the system.
o Registers the NCE.DLL on the system.
o All other component registration, environment establishment and registry entries are

created at run-time.

However, the TransMagic installer will accept command line switches for fully automated
installations. The following are the list of installers switches currently available for standard
non-OEM installations:

Parameter Description
-SILENT Use to specify a silent install. Progress meters will still be displayed but

no use input is required.

-INSTALLDIR<DIR
>...</DIR>

Use to specify the install directory to anything other than the default
%ProgramFiles% directory.  The actual directory needs to be between the
and delimiters to identify the actual directory. For example, to specify the
directory “D:\Unique Install Dir” as the new install directory this option
would look like the following:

-INSTALLDIR<DIR>Any Install Directory</DIR>
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The actual directory needs to be between the < DIR> and </DIR>
delimiters to identify the actual directory. For example, to specify the
directory “D:\Unique Install Dir” as the new install directory this option
would look like the following:

-INSTALLDIR<DIR>D:\Unique TransMagic Dir</DIR>

-FLOAT Specify Floating Network license install vs. default Node-Lock.

-SWADDIN Installs the SW Add-Ins if -SILENT or -NOPROG was specified.

-INVADDIN Installs the Inv Add-Ins if -SILENT or -NOPROG was specified.

-SKIPNET351 Skips installation of the .NET 3.5 Sp1 Framework. WARNING: TransMagic
WILL NOT function properly without this component. Use this switch only
if you intend to automate installation of this component after the install of
TransMagic.

-SKIPPRQS Skips installation of the TransMagic required prerequisite components. 
WARNING: TransMagic WILL NOT function properly without these
component. Use this switch only if you intend to automate installation of
these components after the install of TransMagic.

The TransMagic installer is a compressed collection of an InstallShield
installer, TransMagic authored install utilities, prerequisites and other files
required by the installer.  The install package is a self-extracting
executable (SFX) file which you can extract using WinRAR or any other
RAR utility.  In the resulting directory will be all of the required
TransMagic prerequisite installers.  TransMagic prerequisite components
start with "TMPRQ".  For 32-bit TransMagic on 32-bit machines only the
x86 versions need to be installed.  For 32-bit TransMagic on a 64-bit
machine both x86 and x64 versions need to be installed.  For 64-bit
TransMagic on 64-bit machines only the x64 versions need to be installed.

-NOPROG  Remove desktop icon and TM program group.
 Does not install CAD Add-Ins unless specified.
 Creates a "Powered By TransMagic" web link on the desktop.

-NOLINK Only applies if -NOPROG is sent, removes the "Powered By TransMagic"
web link.

-NOEULA Only applies if a silent install is sent.  Does not display EULA.  When
sending this option the company employing this option, by using it, is
accepting the terms of the EULA on behalf of the company and any user
of the machine and\or software.

TransMagic installer command line usage:
The TransMagic command line switches need to be wrapped in the -sp switch in between TRIPLE
QUOTES and can include any of the options listed above with A SINGLE SPACE BETWEEN
OPTIONS. 
Here are some examples. Let's say we wanted a simple SILENT install. The command line would
like the following:

TransMagicR9sp00_x64.exe -sp"""-SILENT"""

Let's say we wanted a SILENT install of the SolidWorks Add-In. Let's also say this is a floating
network license. Usage would be as follows:

TransMagicR9sp00_x64.exe -sp"""-SILENT -FLOAT -SWADDIN"""
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Let’s say we wanted a SILENT install, floating network license, and to specify the unique install
directory “D:Unique Install Dir”. Usage would be as follows:

TransMagicR9sp00_x64.exe -sp"""-SILENT -FLOAT -INSTALLDIR<DIR>D:Unique Install
Dir</DIR>"""

Any of the above options can be sent in any order so long as they are in TRIPLE QUOTES
following -sp and with spaces between the options.

Served Model Distribution
The usage of "served model" distribution requires a special license of TransMagic Workgroup or
TransMagic Enterprise.  TransMagic can simply be run from it's own run directory anywhere on a
system by following these instructions:

 The TransMagic installer is a compressed collection of an InstallShield installer, TransMagic
authored install utilities, prerequisites and other files required by the installer.  You can use
WinRAR or any other RAR extraction utility to extract the TransMagic Self-Extracting
Executable (SFX) file to a folder.  When extracted the folder structure will appear as follows:

 You can directly copy the TransMagic run directory "CD-ROM\program files\TransMagic
Inc\TransMagic RX" to the user's machine and create a desktop shortcut for TransMagic.exe.

 You are very likely running a Network\Floating license of TransMagic so open the file
"...\TransMagic RX\System\TMInfo.txt" and change the "Network=false" setting to
"Network=true".

 You MUST copy the files in the directory "CD-ROM\CommonAppData\TransMagic\Licensing" to
the user's system to this directory:
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o CSIDL_COMMON_APPDATA\TransMagic\Licensing
o You MUST create the directory if necessary.
o You MUST copy each file individually and ONLY overwrite existing files with newer

versions.  This is because the TransMagic license manager runs from this directory and
all TransMagic license managers are backward compatible but not necessarily forward
compatible.  By copying only newer versions over you ensure that new versions of
TransMagic can run on with the newer TransMagic license manager as well as older
versions.

 In the "...\TransMagic RX\System" directory, run the "RegisterAllComponents.vbs" script. 
This is a very quick process and will register the proper components for TransMagic to run.

 Contact TransMagic Support at support@transmagic.com if you need any assistance with an
VBS scripts to accomplish any of the above tasks as we have scripts on hand that accomplish
all of these tasks that we'd be happy to share with you.

-o-
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Tutorials
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TM Classic Icon Interface (CII)
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Quick Start Guide - CII

Auto Repair Wizard - CII
When you open a geometric file in TransMagic, the first thing you'll notice is that immediately
after the part has been opened an interrogation process starts. This process is the Auto Repair
Wizard. TransMagic is automatically analyzing the geometry that was just opened and is
determining what, if any, additional steps may need to be taken to get the geometry into a high
quality and useable state.

The beauty of the Auto Repair Wizard is that the best course of action is to follow the
recommendations by simply clicking a single button. Decades of TransMagic industry knowledge
and expertise are built into this easy to use wizard.

Another nice feature is that Repair operations are only applied to the parts that require them.
This is a huge time saver as you don't have to check each part individually of a large assembly as
the Auto Repair Wizard will do so. Different parts may require different levels of Repair as well
which will also be determined by the Auto Repair Wizard.

The Auto Repair Wizard has three states:

The Green Light
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As the wizard states, your file looks good, you can now proceed to work with the file with
confidence whether you're quoting, creating illustrations or translating the file out to another
format.

The Yellow Light
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This state has a different meaning for Solids, Surfaces and Sheet-Bodies:

Solids: For Solids this state means that issues were found with the file but they are not critical
issues. They are issues that will likely not affect downstream operations. However, the
recommended course of action at this stage is to perform the recommended action which is Lite
Repair. See the Lite Repair documentation for more information.

Surfaces: For Surfaces this state means that a surface model was loaded and the first
recommend action is Lite Repair. In addition to correcting error, a primary function of Lite Repair
is to stitch surfaces into solids automatically. See the Lite Repair documentation for more
information.

Sheet-Bodies: A Sheet-Body is a collection of surfaces that have been stitched together but they
do not form a solid. Sometimes this is intentional but most of the time a sheet-body is the result
of missing surfaces. Missing surfaces are usually the result of a defect in the translator that
created the file. TransMagic is able to easily Repair these conditions as well with it's
"MagicSurface" technology. If there are missing surface they will be identified by the Auto Repair
Wizard as "un-stitched edges". For more information about MagicSurface see the Advanced
Toolbar documentation.
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The Red Light

This state means that severe issues have been found that will most likely affect downstream
operations and even TransMagic operations. The recommended course of action at this stage is to
perform the recommended action which is either Full Repair or Advanced Full Repair. See the Full
Repair documentation for more information. Advanced Full Repair is only accessible from the
Auto Repair Wizard dialog as it is only necessary in very specific cases. Advanced Full Repair is
also resource intensive as it does a complete analysis and Repair to every single face (surface) in
the parts that need the Repair.

Additional Notes:

 Notice on the bottom of the dialog "Don't show this dialog during File Loading". You disable
Auto Repair Wizard during File Loading by checking this box.

 You can always run the Auto Repair Wizard at your leisure by simply clicking  Auto Repair
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Wizard. Also, if you manually run  Lite Repair or  Full Repair, the TransMagic
Recommends dialog will be invoked automatically. However, you can also turn TransMagic
Recommends off entirely via the File->Settings Pages, General Page. 

 If you turn the Auto Repair Wizard off entirely then TransMagic will operate in a "classic" state
as it has for all previous versions of TransMagic. This means that instead of the Auto Repair
Wizard, you will see Repair logs and Check Part logs displayed after those operations. 

-o-
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Hot Keys - CII
There are numerous ways to interact with TransMagic, one of the more efficient ways, with
experience is with Hot Keys.  Hot Keys are keyboard commands that take the place of mouse
clicks and menu options.

First of all, there are the Function Keys along the Top Row F1 - F12.  The most used functions in
TransMagic are grouped along the top row of icons and left side row of icons.  The top icons,
starting with F2 and Single Select go in a row from F2-F12.  F1 in Windows is generally reserved
for Help.  Likewise, starting with the Delete Selection icon on the left side icon row, hold down
the Shift key and then use the F1-F12 Function Keys.  Below is map:

Additionally, TransMagic also supports the following Hot Keys for using TransMagic:

Auto Repair Wizard: Alt+T ( )

Copy: Ctrl+C ( )
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Delete Selection: Del ( ) 

File New: Ctrl+N ( )

File Open: Ctrl+O ( )

File Print: Ctrl+P ( )

File Save: Ctrl+S ( )

Orbit: Alt+O ( )

Pan: Alt+P ( )

Paste: Ctrl+V (Paste copied image into another document)

Zoom: Alt+I ( )

Zoom All: Alt+A ( )

Zoom To Selection: Alt+S ( )

Zoom To Window: Alt+Z ( )

Group: Ctrl+G ( )

Ungroup: Ctrl+U ( )

Next Window: Page Down

Previous Window: Page Up

-o-
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TM Layout - CII

Menu Bar:

The TransMagic Menu Bar is dockable and can be repositioned anywhere in the TransMagic frame.
The Menu Bar contains all TransMagic functionality.  For a description of all of the Menu Bar
functions see the topic Menu Functions.

TransMagic Toolbars:

The TransMagic Toolbars are subsets of TransMagic functionality broken up into separate
functional Toolbars.  TransMagic uses dockable Toolbars.  You can click and drag Toolbars to any
area of the TransMagic frame or next to other Toolbars, etc.  You can also leave them undocked
and floating.  TransMagic Toolbars use Tooltips.  Leave your mouse positioned over any icon for a
couple sections and the name of that function will appear under the mouse.  A description of that
function will appear in the Status Bar.  See Status Bar below.

To disable or enable specific Toolbars, right-click on any blank area of the TransMagic frame and
this will bring up the Toolbars menu:
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From the Toolbars menu you can select or de-select any of TransMagic's Toolbars.  See the
Toolbars topic for descriptions of each Toolbar.

Status Bar:

The TransMagic Status Bar will display additional information about TransMagic functions.  Som e
functions in TransMagic require multiple steps.  These steps will also be displayed in the Status
Bar.  The Status Bar can be enabled or disabled by selecting the Tools menu and either checking
or unchecking "Status Bar".

View Axes:

The TransMagic View Axes are more than just a visual orientation.  Notice the grey semi-circle
that connects all three of the axes.  Clicking on the light-grey area will switch the TransMagic
view to that plane.  For example clicking the light-grey semi-circle between the Z & Y axes will
switch the TransMagic view to that viewing plane.  Once in that view clicking on the light-grey ZY
disc will reverse the view on that plane, i.e. Front/Back, Right Side/Left Side, Top/Bottom.  To
switch back to the isometric view at any time click the center dark-grey portion of the disc.

After using this tool for a little bit you will find that you can very quickly switch between all of the
standard six views: Top, Bottom, Right, Left, Front, Back.
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Menu Functions - CII

File Menu - CII

Open... - Opens a file and creates a new document with that file name.  For available formats
see "Formats" under "File Menu" in this section.

Close - Closes the currently selected document.

Collaborate - Starts a Collaboration session.  See the "Collaboration Guide" under the "File
Menu" section of "Menu Functions" for a more complete description.

Import... - Imports a new part into the currently selected document.  This is very handy for
bringing various parts together into a single file.  For example, bringing together components of
an assembly that were created in the different CAD applications.  For available formats see
"Formats" under "File Menu" in this section.

Export... - Exports what-ever is currently selected to a new file.  Export will only save what is
currently selected so this is a handy function for breaking apart various components of an
assembly into individual parts or sub-assemblies.  To select multiple individual parts hold down
the Shift key while selecting parts using Single Select.  For available formats see "Formats" under
"File Menu" in this section.

Settings... - This brings up the TransMagic "File Settings" dialog box.  This is where in
TransMagic all system options for visualization, application function, and translation settings are
defined and stored.  See the "File->Settings" section for a more complete description of the
various pages.
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Save As... - Saves the currently selected document to a new file format.  For available formats
see "Formats" under "File Menu" in this section.

Print... - Prints the currently selected document.

Print Preview - Generates a Print Preview window that approximates what the currently
selected document will look like when printed.

Print Setup... - Launches the Windows Print Setup dialog box where your various printer options
are defined and stored.

Last opened files - TransMagic will store a list of the last 4 files that were opened.  You can
select these files by name at the bottom of the File Menu to quickly re-load the file.

Exit - Close all documents and shut-down TransMagic.

-o-

 



p189

TransMagic R10 User Guide

© TransMagic Inc, 2013

Edit Menu - CII

Copy Image - Copies a bitmap of the currently selected window in TransMagic to the Windows
clipboard which you can paste into another application.

-o-
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Tools Menu - CII

View Status Bar - The Status Bar is the bar along the bottom of the main TransMagic
application window.  As you move your cursor over icons the Status Bar will provided additional
information/instructions for the icon that your cursor is currently over.  This is a handy tool for
learning the functions of the TransMagic icons.

Markup Submenu

The markup submenu list 4 redlining tools for marking up the currently selected
document.  For a more complete description of TransMagic's Markup tools see the
"Redline Sketch" (Freehand), "Redline Circle" (Circle), "Redline Rectangle" (Rectangle), &
"Redline Text" (Note) documentation in the "Toolbars" section under "Annotate Toolbar".

Query Model - The Query Model dialog box is useful for quickly checking the number of edges
and faces in a model.  Simply run your cursor in front of models to check their TM ID number,
their edge count, their face count and the analytic position of the surface in the location of the
mouse cursor.

Assembly Browser - Launch the TransMagic Assembly Browser.  For a more complete
description of the TransMagic Assembly Browser see "Assembly Browser" under the "Tools Menu"
in this section.

Rename Part - Renames a part.  To use this function Single Select a part then select Rename
Part to give the part a new name.  The new name will show up in the Assembly Browser and will
travel with the part when saved out to a new format.

Batch Translate - Launches the TransMagic Batch application.  TransMagic Batch is an
extremely powerful application embedded within TransMagic that allows the Batch translation of
any number of various parts from one format to another.  TransMagic Batch has it's own
documentation.  For more information launch TransMagic Batch and click the "Help" button.
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Query Model - CII

The Query Model dialog box is useful for quickly checking the number of edges and faces in a
model.  Simply run your cursor in front of models to check their TM ID number, their edge count,
their face count and the analytic position of the surface in the location of the mouse cursor.

-o-
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Assembly Browser - CII 

The Assembly Browser is useful for numerous reasons. Not only is it a good way to view a part
but when performing Repair operations, it can be very helpful for selecting individual parts that
you want to perform operations on such as Repair, Delete, Move, etc. 

Also, try loading in a part, opening Tools->Assembly Browser, check "Always Zoom to Selection",
and then select the first part in the list. You'll see the view zoom into the selected part. Now use
your up or down arrows to cycle through the parts in the assembly. 

When a single part is in the display, try checking the "Enable Face Highlighting" option, expand
the Body tree control and again, use the keyboards up and down arrows to cycle through the
part's faces.

If the part had a name in the file that was translated into TransMagic, then you will see that
name in the Browser.  If not you will notice that TransMagic will give it an arbitrary name based
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on the file name.  For multiple parts TransMagic will give the part's names with an appended (1),
(2), (3), etc. simply numbered in succession for all parts.  You can change the name of the part
at any time by selecting the part and then Right-Click, and then select "Rename Part".  The
"Rename Part" function is also available under the "Tools" menu.  This new name will now travel
with the part in it's new format.

If the original model had parts on a certain level, this will be displayed in the TransMagic
Assembly Browser preceding the part name in brackets [].  For example, if a part named "Part 1"
were originally on level 100 in it's native CAD file format, this would be shown in the Assembly
Browser as "[L:100] Part 1".  While TransMagic does not currently have level manipulation tools,
the level information will be written to the output file format.

If a part is Hidden it will be identified with "(Hide)" in the Assembly Browser.

-o-
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View Menu - CII

Top View - Orients the display to the Top View.

Front View - Orients the display to the Front View.

Right Side View - Orients the display to the Right Side View.

Isometric View - Orients the display to the top View.

Orbit View - Select Orbit View then depress the left mouse button and slide across the screen to
rotate the view.

Zoom In/Out - Select Zoom In/Out then depress left mouse button and slide the mouse up and
down to zoom in and out on the view.

Pan View - Select Pan View then depress left mouse button and slide the mouse across the
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screen to laterally position the view.

Continuous Orbit - Select Continuous Orbit then use the Orbit Icon to rotate the view, then
release. The view will continue to orbit in the direction of rotation when the mouse button was
released. The speed of rotation depends on the speed that the mouse was moving when the
button was released.

Zoom All - Select Zoom all to zoom all the parts in the view so that they all fit in the view.

Zoom To Window - Select Zoom To Window then left mouse button and drag to create
rectangular window in the view, then release the mouse button. The view will then update to
reflect the contents of the window.

Zoom To Selection - After first selecting anything with the Single Select Tool or the Window
Select Tool, select Zoom To Selection and the view will update to contain all the selected items
centered in the view.

Redraw Window - Redrawing a window is useful when un-highlighting any visual cues or
elements that TransMagic displays after various operations, checks, queries while using the
program.

Create Cutting Planes - Launches the "Cutting Planes" dialog box.  For more information see
"Cutting Planes" under the "View Menu" in this section.

Close: Close the Cutting Planes Dialog.

Open New Window - Open New Window will create another Window of the currently selected
document.  You will notice at the top of the part the two windows will now have the suffix :1 and
:2 indicating

Split Window - Split Window will create 4 symmetric views in the current window.  You can then
treat each new mini-window as an independent window by rotating, zooming or otherwise
repositioning the parts in that particular quadrant.  When you move your mouse over the window
dividers your mouse icon will change - when this occurs you can hold down the left mouse button
and reposition the panes to resize the quadrants.  Also, when your mouse icon changes you can
double-click on the window divider which will remove that particular window divider changing the
view from 4 quadrants to 2 halves.  To remove the dividers go back and select View->Split
Window which will uncheck this option and remove the dividers.

Orthographic Projection - Select Orthographic Projection to switch the view into a parallel
projection mode.  Parallel Projection looks less realistic but it is good for printing Top, Front, &
Right Side Views for example.
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Perspective Projection - Select Perspective Projection to switch the view into a more realistic
Perspective Projection mode where the geometry closer to the viewer's eye appears larger, which
is how the eye sees objects in real life.

Options... - The View->Options... submenu contains rendering and visualization options.

Frame Rate Test - This function tests the speed at which your graphics card is currently
operating on the currently selected document.  This function will list the frames per
second (fps) and triangles per second (tps) in addition to TransMagic's visualization
engine details.

Shade Surface - The Shade Surface submenu allows you to change which side of the
surface is rendered.  The choices are:

Front - Shade the front of the surface.  The front of the surface is used for shading solids
as rendering only one side (the outside) of the surface is the most efficient way to
visualize a solid part.

Back - Shade the back of the surface (inside).

Both - Shade both sides of the surfaces.  This shading mode is enabled whenever a
surface is loaded into TransMagic.  While this consumes more graphics power, it creates a
better visualization for rendering surface models.  If Both were not enabled you would
only see one side of surface models - the "material bearing" or "normal" side of the
surface.

Show - The Show menu lists the currently visible items with a check mark and permits
the user to show or hide these items by checking or unchecking the items.  In order to
select an item using the Filter Selection function, the item must first be Shown.  The
available items for showing or hiding are:

Edges - By default part edges are shown.  Uncheck this to disable the visualization and
selection of part edges.

Faces - By default part faces are show.  Uncheck this to disable the visualization and
selection of part faces.  The result will appear as a wire-frame visualization if part Edges
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is turned on.

Lights - By default rendering lights are on.  Lights are what gives the shading a realistic
appearance.  Turning lights off will make the part appear "flat" and un-shaded.

Render Mode - The Render Mode submenu allows you to between the four following
rendering modes:

Triangulated - When rendering a scene what is actually being shaded is an
approximation of the actual part geometry.  These approximations are triangles. 
Switching to Triangulated mode allows you to see these triangles.

Wireframe - Switch to wireframe rendering mode where faces are not shaded and edges
are.

Gouraud Shaded - Gouraud shading is an industry standard mathematic calculation of
the light and shading in a scene.  This can simply be referred to as shaded.

Hidden Line - Hidden line mode is where a part is shaded in wireframe mode and
occluded edges are removed and   silhouette edges are added giving the appearance of a
2D model drawing.

-o-
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Cutting Planes - CII

 

X-Axis: Click the X-Axis button to create a section plane that centered at the center of the part.
To position the cutting plane run your mouse over the Cutting Plane Manipulator graphical icon. 
As your mouse passes over the Cutting Plane Manipulator two rotational axis elements will
highlight or one linear translation element.  Left-Click on any of these graphical elem ents when
highlighted and drag to rotate or linear-translate the Cutting Plane.

Click the X-Axis button again to turn of the Cutting Plane.

Y-Axis: Click the Y-Axis button to create a section plane that centered at the center of the part.
To position the cutting plane run your mouse over the Cutting Plane Manipulator graphical icon. 
As your mouse passes over the Cutting Plane Manipulator two rotational axis elements will
highlight or one linear translation element.  Left-Click on any of these graphical elem ents when
highlighted and drag to rotate or linear-translate the Cutting Plane.

Click the Y-Axis button again to turn of the Cutting Plane.

Z-Axis: Click the Z-Axis button to create a section plane that centered at the center of the part.
To position the cutting plane run your mouse over the Cutting Plane Manipulator graphical icon. 
As your mouse passes over the Cutting Plane Manipulator two rotational axis elements will
highlight or one linear translation element.  Left-Click on any of these graphical elem ents when
highlighted and drag to rotate or linear-translate the Cutting Plane.

Click the Z-Axis button again to turn of the Cutting Plane.

Cutting Plane Manipulators: After you have positioned the Cutting Planes to your liking you
can hold SHIFT and click any  of the X, Y, or Z-Axis buttons to remove the Cutting Plane
Manipulator graphical icon for that plane - leaving just the plane itself and the cross-section it
generates.

Show Axis: Check this box to show a graphical axis element in the lower left-hand corner of the
viewing window.  This is helpful when you have rotated your part around and don't have a good
concept of which direction the X, Y, or Z axis are pointing.
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Close: Close the dialog box.

-o-
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Selection Menu - CII

Single Select - Select Single Select to select a single part, surface, cutting plane etc. in
TransMagic.

Window Select - Select Window Select to draw a rectangular window around a collection of
objects in a document and select them all at once.

Set Color Filter - The Set Color Filter function enables you to select a Color filter for selecting
parts of a certain color.  This is especially useful when you bring in a surface model assembly
that contains many parts of different colors that need to be stitched into solids.  You must first
select a part with the color you want to filter.  Then click either the Single Select or Window
Select functions to select the parts\surfaces of that color.  Only entities of the color specified in
the filter will be selected.

Clear Color Filter - The Color Filter is active until cleared by clicking the Clear Color Filter
function.  Once you're done using the Color Filter, use this function to clear the Color Filter and
turn the filter OFF.

Delete Selection - After first selecting a part or multiple parts with either the Single or Window
Select function, click the Delete Selection function permanently from the display.

Note: You can also use the Delete key on your keyboard to invoke the Delete Selection
function.

Zoom to Selection - After first selecting anything with the Single Select Tool or the Window
Select function, select the Zoom To Selection function and the view will update to contain all the
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selected item(s) centered in the view.

Select All - The Select All function will as the name suggests select all currently displayed
entities.

Deselect All - The Deselect All function will as the name suggests deselect anything that is
currently selected in the document.

Group Selection - After first selecting a collection of models using the Single Select Tool or
Window Select Tool, then click the Group Selection function to combine the parts into a single
selectable part.  This is very helpful when "piecing together" groups of surfaces that belong to a
single part for the eventual purpose of stitching them together with Lite Repair.

Ungroup Selection - To ungroup a collection of parts that have been group simply select the
group with the Single Select Tool, then click the Ungroup Selection function. This will separate
this collection of "lumps" into individual parts that can be selected individually.

Hide Selection - After first selecting a part or multiple parts with either the Single or Window
Select function, click the Hide Selection function to hide the part(s) from the view.  You can use
the Show Selection function to show the part(s) again later.  If the Assembly Browser is open the
name of the part will read as "(Hide)" in front of the part name.

Show Selection - To show a part that has been hidden you must first open the Assembly
Browser via the Tools->Assembly Browser menu function.  Select a part labeled "(Hide)" and
then select the Show Selection function to add the part back to the display.

Show All Hidden Entities - This function will show all currently Hidden entities.

-o-
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Geometry Menu - CII

Run TM Recommends - Runs the TransMagic Recommends Wizzard.  See the documentation
for the TransMagic Recommends Wizzard for more information.

Lite Repair - After first selecting a part or multiple surfaces with either the Single or Window
Select function, select Lite Repair to perform Lite Repair on the selected part(s)/surfaces.  For a
more complete description of Lite Repair see the Lite Repair doumentation.

Full Repair - After first selecting a part with the Single Select function, select Full Repair to
perform Full Repair on the selected part.  For a more complete description of Full Repair see the 
Full Repair documentation.

Check Part - After selecting a part using the Single Select function, select the Check Part
function to perform a geometric integrity check on the selected part. Refer to the output window
for repair results.
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Show Gaps - After selecting a part using the Single Select function, select the Show Gaps
function to highlight (in red) gaps in the model. This is a good measure of the accuracy of the
model. After Full Repair or Super Repair you should see the number of gaps go down and in
many cases go to zero. No gaps, or tolerant edges, means that the surface boundaries of
adjacent surfaces intersect precisely. Gaps are OK and your translations will be successful;
however, less gaps will generally mean better translations out of TransMagic.

Move Part - After first selecting a part or multiple parts with either the Single or Window Select
function, select the Move Part function to transform the selected entity(ies) by dragging the left
mouse button. Note, the translation direction will always be horizontal to the view direction. To
perform a perfect lateral or vertical transformation make sure you first select on the Top, Front or
Right Side View buttons to first orient the view into a standard perpendicular orientation.

Change Part Color - To change the color of a part or collection of parts after first selecting them
with Single/Window Select, select the Change Part Color function button. A standard Windows
color dialog window will then be displayed for your to manipulate the colors.

Change Layer - This function allows you to change the existing layer\level (if any) that a part or
parts currently resides on.  After first selecting a part or multiple parts you can access this
function via the Geometry  menu or by right click (under Change).  Enter a new layer number for
your selection and click "OK".  Your parts will now be on this layer\level when saved out to any
format that supports layers\levels.  To visually see the layer that your part or parts reside on
open the Assembly Browser and you will see in front of the part name the notation [L:X], where
"X" is the layer that your part is currently on.  If your part is currently not on a layer you will not
see the [L:X] notation.

Colorize - Single Select or Window Select a part or multiple parts and then select the Colorize
function to apply a random color to each part in the selection list.  This is very useful when you
bring a large assembly into TransMagic and all of the sub-components are one single color. 
Changing the color of all the parts helps to clearly differentiate between parts in the assembly.

Scale Part - After first selecting a part or multiple parts with either Single or Window Select,
select the Scale Part function to apply a scaling factor to the part(s). Sometimes an exporting
application can inadvertently write out a model scale larger or smaller than what the part was
designed in. This results in a part being translated into TransMagic very large or very small. For
example a part designed in mm that was 100 mm long and written out to Meters would com e
into TransMagic as 100 Meters long! In this case applying a scaling factor of .001 would bring the
part back down to mm.

Change Part Facet Resolution - The Change Part Facet Resolution submenu offers four
options:

Note: TransMagic uses what is called a "Normal Deviation" for setting the facet resolution
of a part.  Facets are the triangles that get shaded by TransMagic's visualization engine and
give the part a realistic appearance.  The Normal Deviation refers to the deviation between
any two surface normal's.  This deviation is measured in degrees.  So the Normal Deviation

between any two facet nodes, inclusive of the actual geometric surface, will not vary
greater in degree than the amount specified by Normal, Medium High, High or Super High

facet settings.
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Normal - A Normal Deviation of 15 degrees.

Medium High - A Normal Deviation of 10 degrees.

High - A Normal Deviation of 5 degrees.

Super High - A Normal Deviation of 1 degree.
Note: Setting the Facet Resolution to High or Super High can consume massive amounts of

memory depending on the complexity and size of the part(s) selected.

Display Part bounding Box - Select a part or a collection of parts using Single or Window
Select. Then select the Display Part Bounding Box function button to create a transparent
bounding shape that encompasses the selected entity(ies). This box will show the precise
dimensions of the box. This function is useful in determ ining the minimum material required to
machine a part for example.

Check Part Mass Properties - After selecting a part using Single or Window Select, select the
Check Part Mass Properties function.  The Check Part Mass Properties function allows you to
check:

 Cubic Volume

 Weight based on density via a catalog of materials or is user selectable material

 Center of Mass (CoM) and the ability to create a true geometric representation of the CoM
with planar intersection graphs.  The CoM is read/writeable to any supported TransMagic
format.

 Inertial Properties: Principal Axes of Inertia, Principal Moments of Inertia, & Inertia Tensor.

For a more compile description of the Check Part Mass Properties function see "Mass Properties"
under this section.

Check Surface Area - After first selecting a part, or face of a part, select on Check Area function
to get the part or face's surface area.

Note: To select an individual face, simply Right-click on the display and select Filter
Selection->Face.  If a Body is selected, the surface area will be that of the entire part.

Make Part Transparent - After first selecting a part or multiple parts using Single or Window
Select, select the Make Part Transparent function to turn the selected parts transparent.

Undo Part Transparency - After first selecting a part or multiple parts using Single or Window
Select, select the Undo Part  Transparency function to turn transparent parts back to solid parts.



p206

TransMagic R10 User Guide

© TransMagic Inc, 2013

Reverse Faces - Sometimes after model repair, instead of orienting all of the model's faces to
point outward and describe an enclosed void, the faces get all reoriented inwards. This can also
happen without Repair but simply due to a poorly executed export of a model to *.IGES, *.STEP,
etc. from a modeling system. To reverse this condition, select the Select Tool and select the
affected model, then select the Reverse Faces function to reverse the faces.

Unhook Faces - The Unhook Faces function is useful if you want to take a solid body and reduce
it to surfaces.  You can then Group or stitch together a group of surface, for example the
contoured surfaces of a mold cavity, using Lite Repair.  You could then select this contoured
surface group and use File->Export to save just the group to a new file.  To use the Unhook
Faces function simply select a part and then select Geometry->Unhook Faces.

Flatten Assembly - In certain circumstances it can be beneficial to remove the assembly
heirarchy of an assembly and convert it to a simple flat list of parts.  This function does just that.
The parts will still be in the appropriate positions in space but the end result will be a flat list of
parts.  
Caution: One caution when using this function is RAM usage.  TransMagic handles assemblies
very efficiently and capitalizes on instances.  Instances are copies of parts or even whole
assemblies.  Take for example 1 single bolt copied/instanced in 100 different locations. 
TransMagic will represent the geometry of this bolt only once in memory and 99 locations. 
When you flatten an assembly you will actually create 100 individual copies of this bolt.  So one
can see how this could cause RAM usage to spike, especially with assemblies that have a large
amount of instanced geometry.

Caution: One caution when using this function is RAM usage.  TransMagic handles assemblies
very efficiently and capitalizes on instances.  Instances are copies of parts or even whole
assemblies.  Take for example 1 single bolt copied/instanced in 100 different locations. 
TransMagic will represent the geometry of this bolt only once in memory and 99 locations.  When
you flatten an assembly you will actually create 100 individual copies of this bolt.  So one can see
how this could cause RAM usage to spike, especially with assemblies that have a large amount of
instanced geometry.

Special - The Special menu contains functions that are not easily categorized but may provide a
usefulness to you.

Calculate Points to Part - The Calculate Points to Part function is a very handy function for
calculating and displaying an as-measured point data set against a CAD model.  This function
requires that you read the part and points into a single document.  They can come in as a
single document or you can use the File->Import function to bring separate documents
together.  To see the points (or vertices as TransMagic considers them) right-click in the
display and then select Show-Vertices.  When invoked this function will ask you to create a
log file - this will contain all the measure points output.  Then the function will ask you to
enter a deviation value to calculate against and a precision value which determines the
precision output displayed in the log file.  Any points calculated outside of this deviation value
will be highlighted in the TransMagic window.  Finally an output window listing point
coordinates and distances to the part will be shown.  This window is displaying the log file
that was specified in a previous step.

Output Part Names - To use this function you must first select a single or more parts and
then invoke this function.  You will be asked to specify a log file which will contain all of the
part names for the selected parts.
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 Mass Properties - CII

After selecting a part using the Single or Window Select Tool, click the  Mass Properties Tool.
The Mass Properties Tool allows you to check:

 Cubic Volume

 Weight based on density via a catalog of materials or is user selectable material

 Center of Mass (CoM) and the ability to create a true geometric representation of the CoM
with planar intersection graphs.  The CoM is read/writeable to any supported TransMagic
format.

 Inertial Properties: Principal Axes of Inertia, Principal Moments of Inertia, & Inertia Tensor.

After you invoke the Mass Properties a dialog box will appear as below:
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Volume and Mass
Volume - The volume of the part in cubic units.

Note: To change the units of the Mass Properties calculations see "Units" in the
documentation for the "General Page" under "File->Settings Pages".  The Units settings can

be found under File->Settings, General Tab, Units pull-down.

Mass - The mass of the part in mass units.  This value is based on the Material Density.
Changing the Material Density will change the value of this measurement.  See "Material Density"
under "Settings" in this section.

Center of Mass
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The Center of Mass is given in x, y, z coordinates.

Draw Center of Mass (CoM) - Click this button to draw a graphical representation of the Center
of Mass.  The graphic is 3 planes, the xy plane, the xz plane and the yz plane intersecting the
part at the Center of Mass.  If you Single Select the part and then right-click and select Hide
Selection, you'll notice that there is also a precise intersection graph that represents the 3 planar
intersections of the part and the CoM.  You can use these intersections to check edge
measurements, etc.  You can also save this CoM shape out to any supported file format.

Apply "Fudge Factor" If CoM Intersection Fails - Sometimes the Center of Mass planes
coincide identically with existing edges.  These coincident edges are especially common with
symmetrical parts and parts that were mirrored.  In certain cases this coincident geometry to the
intersection planes can cause the CoM intersections to fail.  The "Fudge Factor" will be invoked if
the intersection fails and it will allow you to slightly shift the CoM plane geometry so that the
intersection will complete.  If the CoM planar intersection fails the following dialog will launch:
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This dialog allows you to shift the CoM geometry via global X,Y,Z translations or by rotations
around X,Y,Z global axes.  You can apply any combination of translations and rotations.  These
settings will be saved when you click OK so you don't have to re-enter information every time
this dialog is launched.

Note: For reference you can turn on the global X,Y,Z axes on in TransMagic by going into
the File->Settings area, select "Appearance", find the "View Settings" section and check the

"View Axis" check box.

Note: If the initial CoM intersection fails you may also want to consider applying  Full
Repair to the part first.  Many times the intersections fail because of precision issues at the
coincident geometry.  Running Full Repair on a part will virtually always increase precision
in these areas and will usually allow the CoM intersections to complete without applying a

Fudge Factor.

Settings
Material Density

Material - This pull-down box allows you to select various materials for your part.  Changing the
Material Density will change the value of the Mass measurement (weight) in the Volume and
Mass section.

Density - This is the value of the currently selected Material.
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Enter Custom Density - Check this box if your Material is not in the pull-down list or if you simply
want to enter your own value.  By checking this you will disable the Material Density pull-down
and the system will default to .036 lb/in^3 which corresponds to the industry default of 1.0
gm/cm^3.  You can enter your own value in this box.

Note: After entering a new Custom Density you must click the Recalculate button in order
to update the Mass value calculation to the new Custom Density.

Recalculate - Click this button to update the Mass value calculation after entering a new Custom
Density.

Precision
Decimal Places - Use this pull-down box to change the decimal precision in all Mass Property
calculations from 2 to 6 decimal places.  This value is saved in the TransMagic system settings
and the next time you run a Mass Property calculation, it will calculate based on this precision.

Note: Changing the Decimal Place precision will affect processing time.  If you have a very
complex part and your Decimal Precision is set to 6 places, be patient as it may take a while to
calculate Mass Properties at this level of precision.

Calculate Inertia Properties - Checking this box will enable the calculation of the parts
Principal Axes of Inertia, Principal Moments of Inertia and Inertia Tensor.

Note: The Principal Axes of Inertia and the Principal Moments of Inertia are take at the
Center of Mass.

Note: Calculating the Inertia Properties of a part will add processing time to the Mass
Properties calculations.

Copy to Clipboard - Clicking this button will place all the Mass Properties of the dialog box in
tabulated form to the Windows clipboard.  

Note: The way TransMagic copies text data to the Windows clipboard is called Unicode and
it's very nice for pasting into office documents.  For example if you paste the copied data
from the TransMagic Mass Properties dialog box to a Microsoft Excel spreadsheet, Excel or

any other spreadsheet application will paste the data as a nicely columnized data set.

Reset Defaults - Click this button to reset the Mass Properties dialog box to it's original default
settings.

OK - Click this button when you are done reviewing the Mass Properties data.

-o-
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Window Menu - CII

Cascade - Select Cascade to cascade the currently open windows from top left to bottom right.

Tile Horizontally - Select Tile Horizontally to tile the currently open windows horizontally.

Tile Vertically - Select Tile Vertically to tile the currently open windows vertically.

Window Selection - At the bottom of the Window menu is a list of the currently open windows.
You can switch between the open windows by selecting on them in the Window Selection area.

-o-
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Help Menu - CII

About... - The About menu launches the "About TransMagic" dialog box.  For more complete
information on the "About TransMagic" dialog box, see "About TransMagic Dialog" under "Help
Menu" in this section.

Visit TransMagic.com - Selecting Visit TransMagic.com will launch your browser and navigate to
www.transmagic.com.

Help - Select Help to launch the TransMagic Help system.

Update License Key - Selecting the Update License Key will launch the "Update License Key"
dialog box.  You can then upgrade your TransMagic license by entering your new License Key. 
Contact your salesperson to obtain an upgrade to TransMagic.

Set V5 Environment - When there are other CATIA V5 installations on your system, TransMagic
uses it's own TransMagic V5 Environment which tells our V5 translator where to find it's own files
and DLLs.  When TransMagic is run  a "TransMagic V5 Environment" will be established for
which-ever user account is running TransMagic.  On rare occasions this TransMagic V5
Environment can be corrupted.  If you run into any issues reading or writing CATIA V5 files,
running this function will re-set the TransMagic CATIA V5 Environemnt and correct the issue.

-o-
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Toolbars - CII
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Annotate Toolbar - CII

 Delete Annotation or Dimension - CII
Usage: When this tool is selected, any Annotation or Dimension that you left-click on will be
permanently deleted.

-o-
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 Annotate - CII
Placement: Select the Annotation Tool. Left-Click anywhere on the part and then drag the
annotation text box to the desired location.

Edit: Select the Annotation Tool. Left-Click on the text box and start typing. 

Move: Select the Annotation Tool. Left-Click on the text box and move it to the new location. 

-o-
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 Redline Text - CII
Placement: Select the Redline Tool. Left-Click anywhere on the screen. 

Edit: Select the Redline Tool. Left-Click on the text box and start typing. 

Note: You can change the color of the Redline Text and marks and the line weight of the
redlining marks by going to the File->Settings->Appearance menu and modifying these

values in the Redline box. 

Note: If you rotate the view with the Orbit Tool, the Redline marks and text will disappear.

You can save desired Redline views by using the  Preset Camera Tools. For
usage of these please see the Zoom Toolbar documentation.

-o-
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 Redline Sketch - CII
Placement: Select the Redline Sketch Tool. Left-Click anywhere on the screen and drag. 

Note: You can change the color of the Redline Text and marks and the line weight of the
redlining marks by going to the File->Settings->Appearance menu and modifying these

values in the Redline box. 

Note: If you rotate the view with the Orbit Tool, the Redline marks and text will disappear.

You can save desired Redline views by using the  Preset Camera Tools. For
usage of these please see the Zoom Toolbar documentation.

-o-
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 Redline Rectangle - CII
Placement: Select the Redline Rectangle Tool. Left-Click anywhere on the screen - the first
Left-Click is the upper left hand corner of the rectangle - drag the lower right corner of the
rectangle - stop when the desired size rectangle is reached.

Note: You can change the color of the Redline Text and marks and the line weight of the
redlining marks by going to the File->Settings->Appearance menu and modifying these

values in the Redline box. 

Note: If you rotate the view with the Orbit Tool, the Redline marks and text will disappear.

You can save desired Redline views by using the  Preset Camera Tools. For
usage of these please see the Zoom Toolbar documentation.

-o-
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 Redline Circle - CII
Placement: Select the Redline Circle Tool. The first Left-Click will be the center of the circle -
then drag the mouse to form the radius of the circle - stop when the desired size circle is
reached. 

Note: You can change the color of the Redline Text and marks and the line weight of the
redlining marks by going to the File->Settings->Appearance menu and modifying these

values in the Redline box. 

Note: If you rotate the view with the Orbit Tool, the Redline marks and text will disappear.

You can save desired Redline views by using the  Preset Camera Tools. For
usage of these please see the Zoom Toolbar documentation.

-o-
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 Create Interactive Dimension - CII
Usage: Click on this icon and you'll see the "Dimension Controls" window appear on the left hand
side of the TransMagic interface:

Note: For complete instructions on creating dimensions, please see the "Creating and
Editing Dimensions" Tutorial in the "Tutorials" section under "Query Tools".

Dimension Orientation - Click on the "X", "Y" or "Z" button to orient your dimensions in that
reference plane.  To help visualize these planes click on the "Show Axis" check box.  Use the
"Dimension Spacing" to set your initial spacing.  Note that you can always freely click and drag
your dimensions to another position interactively.  This setting simply gives your dimensions a
guide for initial placement.  At any time you can change your spacing or orientation by clicking
on a dimension, and then clicking "Apply" to force that dimension into the spacing and
orientation settings you have chosen.
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Interactive Dimension Behaviors:

- As you move your mouse around the entities in the display you will notice that the applic able
selection types interactively highlight such as Face, Edge and Vertex.

- Click and drag from a Vertex to a Vertex, or a Face to a Face, or an Edge to an Edge to create
the dimension.

Note: Like types must be selected and dragged to create a dimension.  If you click on a
vertex and drag your mouse, for example, the final selection must be another vertex. 

Otherwise you will see the following message:

- After creating the dimension you can easily move the dimension by simply clicking on the
dimension and dragging it to a new position.  A currently selected dim ension will highlight.
selecting the Cursor Pick Dimension Type, it's usage is as follows:  Select the Dimension Tool.
Left-Click anywhere on the part and drag - then release to show the dimension. 

- If you select a single radius edge then a radius dimension will created.

- If you click on one radius edge and then drag and click on another radius edge then the "Arc
Dimension Behavior" dialog will be launched and you will be prompted to select one of four
possible dimensions:
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- If you select a single edge then a dimension between the edges endpoint's will created.  This is
intended primarily for linear edges; however, it works on any edge.

- If you click on one linear edge and then drag and click on another linear edge: If the edges are
parallel then a distance dimension will be created; however, if the edges are at an angle to each
other then this will launch the "Distance or Angle" dialog and prompt you to choose which
dimension type you wish to create:

- If you move away from Interactive Dimensioning, i.e. clicking another button, then you will not
be able to re-position dimensions until you click the "Create Interactive Dimension" button again.

Clear Previous Dimensions - As the name implies check this box to clear any previous
dimensions.  Each time you create a new dimension the previous dimension will be cleared.  In
this way the Interactive Dimensioning interface becomes more of a real-time measuring
interface.
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Show Axis - Check this box to show a graphical axis element in the lower left-hand corner of the
viewing window.  This is  helpful when trying to determine the initial dimension placement using
the "Dimension Orientation" function above.

-o-
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 Create Manual Dimension - CII
Usage: This function is necessary for certain types of dimensions.  When you click Orbit, Pan,
Zoom, or Window while in Interactive Dimensioning mode - to re-orient a part for exam ple - this
means that your mouse is necessary for this orientation operation and thus disables and takes
control away from the Interactive Dimensioning mouse functions.  An example of when this
function is necessary:

- When you wish to create an overall dimension from a face on top of a part to a face on the
bottom of the part.  Selecting the top face is simple however in order to select the bottom face
the part must be rotated so that the bottom face can be selected.

- In this case Manual Dimensioning is required.

- Click the  Single Select icon.  Then right-click and select Filter Selection->Face.  Now you
are ready to select only Faces.

- Click the Face on the top of the part, click the  Orbit icon and orient the part so the bottom
Face can be seen.

- Click the  Single Select icon, hold down the CTRL key on your keyboard and select the
bottom Face on the part.

- Click the Create Manual Dimension to create the dimension.  The dimension will now be
created.

- In order to move the dimension to a new location you must re-enter Interactive Dimensioning

mode by clicking on the  Create Interactive Dimension function.

-o-
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 Show/Hide Product Manufacturing Information -
CII
Usage: This function will be enabled if the part you have loaded into TransMagic contains PMI
data.  The PMI data will be rendered in the same location it was found in the original file.

PMI data follows these guidelines:
 This technology is available for CATIA V5, UG/NX and Pro/Engineer Read formats only.  It is

not currently possible to write out PMI data.
 Currently the PMI data supported by TransMagic is as follows:

o General Dimensions 
 Length & Distance 
 Tangent, Cylindrical & Edge Radius 
 Angle, Arc Length & Dimension Slope Angular 
 Curvilinear & Circular Length 
 Ordinate 
 GD&T 

o Geometric Dimensioning 
 Manufacturing Tolerancing 
 Surface Roughness 
 3D Annotation (text) 
 Manufacturing Notes 
 Materials 
 Could be many things attached as 3D Annotations

 Your TransMagic License Key must support PMI data or this functionality will be disabled.
function.

 See also:
o Under the "Contents" tab, see File->Settings Pages, select the General Page and see

the "Enable PMI Translation" option on that page.
o "Show/Hide Product Manufacturing" function in the Index.
o Under the "Contents" tab, see Menu Functions->Right-Click Menu->No Selection for

instructions on selecting the PMI data and operations that can be performed with the
PMI data.

o Under the "Contents" tab, see Menu Functions->Right-Click Menu->PMI Selected for
instructions on orienting the view to the PMI views.

o Under the "Contents" tab, see Menu Functions->View Menu->Split Window for creating
multi-view docs as seen here:

TransMagic Displaying PMI Data with a Split Window:
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Main Toolbar - CII

 New Document - CII
Click the New Document Icon to create a new document. This differs from File->Open in that you
can use File->Import to read in multiple disparate parts into a single document. For example if
you create a new document, you can now use File->Import to read IGES, STEP, Pro/E, Catia, etc.
parts all into the same document. You can then click File->Save As… to translate all the read-in
parts to a new file format.

-o-
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 Open Document - CII
Click the Open Document Icon to read in a supported file type.

-o-
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 Save As…
Click the Save As… Icon to save the currently selected document to a supported file format.

-o-

 



p232

TransMagic R10 User Guide

© TransMagic Inc, 2013

 Copy To Clipboard - CII
Click the Copy To Clipboard Icon to capture a bitmap image of the currently selected document.
You can now paste this bitmap into any applicable application.

-o-
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 Print Document - CII
Click the Print Document Icon to send the currently selected document to a printer.

-o-
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Operations Toolbar - CII

 Auto Repair Wizard - CII
The Magic Button launches the Auto Repair Wizard.  See the documentation for the Auto Repair
Wizard for more information.

-o-
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 Delete Selection - CII
After first selecting a part or multiple parts with either the Single or Window Select Tool, click the
Delete Selection Tool permanently from the display.

-o-
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 Lite Repair - CII
Note: Before using this tool, please read the “Getting Started Guide” for the intended usage

of this function in the proper context. 

Note: It is a serious mistake to select  Lite Repair after  Window Selecting a
collection of solid parts. What you are telling TransMagic to do is, in effect, Repair all of the

selected parts together! This will actually attempt to Repair and stitch all of the parts
together and combine them into one part and will most likely result in ambiguous parts

that have been Repaired together.  Lite Repair should only ever be used on individual
part, a collection of surfaces that describe a single part, or parts that are visibly far enough
apart from each other to ensure that they won't be Repaired together into a single part.  To

repair multiple solid parts simultaneously, see the documentation for Assembly Repair.

After selecting a part or a collection of surfaces with the Single or Window Select Tool, click the
Lite Repair Tool to perform Lite Repair on the selected entities. Refer to the output window for
repair results.

Lite Repair performs the following functions on a part:

1) Repair Initialization.  Examines the part and attaches intelligent attributes that are used to
establish tolerances for stitching, simplification and Repair.

2) Repair Pre-processing.  Find and remove zero-length edges, zero-area faces, and duplicate
vertices.  These are common, extraneous, & unnecessary geometry.

3) Geometric Simplification. The intelligent attributes established in Repair Initialization are
analyzed for the purposes of Geometric Simplification.  Geometric Simplification attempts to
simplify spline surfaces into analytic surfaces (planes, cylinders, cones, tori, and spheres). 

4) Geometric Stitching. The intelligent attributes established in Repair Initialization are analyzed
for the purposes of Geometric Stitching.  Geometric Stitching attempts to "pair up" edges of free
faces and stitch them together.  No stitching is performed if two faces are farther away than the
minimum tolerance established in Step 1, meaning, they are presumed to be free floating
surfaces.

5) Repair Post-processing.  After Geometric Simplification, Geometric Stitching, and Geometric
Creation and Repair, there are often artifacts left over from the operations that can affect the
fidelity of the translation.  These artifacts can be zero-length edges, zero-area faces, negative
area faces, duplicate vertices, or duplicate edges.  All of these artifacts are again analyzed and
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removed during this phase.  Finally, "tolerant attributes" are placed on gaps in the model that
could not be Repaired.  There are several reasons for a gap not being able to be properly
Repaired such surface domains that could not be extended, surface domain boundaries that are
coincident with trimming curve boundaries, varying speed tangent normal's at surfaces
boundaries (can't be extended because they would result in a surface self-intersection).  Gaps
that can not be fully "closed" to within TransMagic's extremely high 10e-6 mm, are given a
tolerance that indicate that the gap is still closed, though not accurate to 10e-6.  These gaps can

be seen by Selecting the model and then selecting the Show Gaps Tool .  It's important to
note; however, that what TransMagic perceives as a gap, the receiving application may deem to
be more than accurate enough based on it's own tolerances.  For this reason it should be noted
that the "gaps" in a model are only a measure relative to TransMagic only that help to illustrate
what corrections have been made.

6) Geometric Cleaning.  After Repair Post-processing, the part is again analyzed for unnecessary
faces, edges, vertices, and associated data.  These unnecessary geometries are then removed. 

7) Repair Termination.  All intelligent attributes created during Repair Initialization are rem oved.

-o-
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 Full Repair - CII
Note: Before using this tool, please read the “Getting Started Guide” for the intended usage

of this function in the proper context. 

After selecting a part using the Single Select Tool, click the Full Repair Tool to perform  Full Repair
on the selected entities. Refer to the output window for repair results.

Full Repair performs the following functions on a part:

1) Repair Initialization.  Examines the part and attaches intelligent attributes that are used to
establish tolerances for stitching, simplification and Repair.

2) Repair Pre-processing.  Find and remove zero-length edges, zero-area faces, and duplicate
vertices.  These are common, extraneous, & unnecessary geometry.

3) Geometric Simplification. The intelligent attributes established in Repair Initialization are
analyzed for the purposes of Geometric Simplification.  Geometric Simplification attempts to
simplify spline surfaces into analytic surfaces (planes, cylinders, cones, tori, and spheres). 

4) Geometric Stitching. The intelligent attributes established in Repair Initialization are analyzed
for the purposes of Geometric Stitching.  Geometric Stitching attempts to "pair up" edges of free
faces and stitch them together.  No stitching is performed if two faces are farther away than the
minimum tolerance established in Step 1, meaning, they are presumed to be free floating
surfaces.

5) Geometric Creation and Repair. The intelligent attributes established in Repair Initialization
are analyzed for the purposes of Geometry Creation and Repair.  Geometry Creation and Repair
performs all the geometry related Repair operations, including fixing of edge geometries by
intersections, snapping surfaces for fixing tangencies, and refitting spline surfaces.

6) Repair Post-processing.  After Geometric Simplification, Geometric Stitching, and Geometric
Creation and Repair, there are often artifacts left over from the operations that can affect the
fidelity of the translation.  These artifacts can be zero-length edges, zero-area faces, negative
area faces, duplicate vertices, or duplicate edges.  All of these artifacts are again analyzed and
removed during this phase.  Finally, "tolerant attributes" are placed on gaps in the model that
could not be Repaired.  There are several reasons for a gap not being able to be properly
Repaired such surface domains that could not be extended, surface domain boundaries that are
coincident with trimming curve boundaries, varying speed tangent normal's at surfaces
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boundaries (can't be extended because they would result in a surface self-intersection).  Gaps
that can not be fully "closed" to within TransMagic's extremely high 10e-6 mm, are given a
tolerance that indicate that the gap is still closed, though not accurate to 10e-6.  These gaps can

be seen by Selecting the model and then selecting the Show Gaps Tool .  It's important to
note; however, that what TransMagic perceives as a gap, the receiving application may deem to
be more than accurate enough based on it's own tolerances.  For this reason it should be noted
that the "gaps" in a model are only a measure relative to TransMagic only that help to illustrate
what corrections have been made.

7) Geometric Cleaning.  After Repair Post-processing, the part is again analyzed for unnecessary
faces, edges, vertices, and associated data.  These unnecessary geometries are then removed. 

8) Repair Termination.  All intelligent attributes created during Repair Initialization are rem oved.

-o-
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 Check (Discontinued in R8)

This function has now been replaced by the Auto Repair Wizard .  If you want to operate
TransMagic in a "classic mode" you can turn off the "Auto Repair Wizard" options on the General
Page.  If the Auto Repair Wizard is fully disabled then instead of the Auto Repair Wizard you will
see the traditional verbose logs displayed for part geometry Checking and Repair operations.

-o-
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 Show Gaps

After selecting a part using the Single Select Tool, click the Show Gaps Tool to highlight (in red)
gaps in the model. This is a good measure of the accuracy of the model. After Full Repair or
Super Repair you should see the number of gaps go down and in many cases go to zero. No
gaps, or tolerant edges, means that the surface boundaries of adjacent surfaces intersect
precisely. Gaps are OK and your translations will be successful; however, less gaps will generally
mean better translations out of TransMagic.

-o-
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 Move
After first selecting a part or multiple parts with either the Single or Window Select Tool, click the
Move Tool to transform the selected entity(ies) by dragging the left mouse button. Note, the
translation direction will always be horizontal to the view direction. To perform a perfect lateral or
vertical transformation make sure you first click on the Top, Front or Right Side View Tool
buttons to first orient the view into a standard perpendicular orientation.

-o-
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 Change Color - CII
To change the color of a part or collection of parts after first selecting them with Single/Window
Select, click the Color Tool button. A standard Windows color dialog window will then be
displayed for your to manipulate the colors.

-o-

 



p244

TransMagic R10 User Guide

© TransMagic Inc, 2013

 Scaling
After first selecting a part or multiple parts with either the Single or Window Select Tool, click the
Scaling Tool to apply a scaling factor to the part(s). Sometimes an exporting application can
inadvertently write out a model scale larger or smaller than what the part was designed in. This
results in a part being translated into TransMagic very large or very small. For example a part
designed in mm that was 100 mm long and written out to Meters would come into TransMagic as
100 Meters long! In this case applying a scaling factor of .001 would bring the part back down to
mm.

-o-
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 Create X, Y, or Z Cutting Planes - CII

Click the Create X, Y, or Z Cutting planes tool, which will launch the "Cutting Planes" dialog which
will allow you to interactively create and manipulate X, Y, or Z Cutting Planes.

 

X-Axis: Click the X-Axis button to create a section plane that centered at the center of the part.
To position the cutting plane run your mouse over the Cutting Plane Manipulator graphical icon. 
As your mouse passes over the Cutting Plane Manipulator two rotational axis elements will
highlight or one linear translation element.  Left-Click on any of these graphical elem ents when
highlighted and drag to rotate or linear-translate the Cutting Plane.

Click the X-Axis button again to turn of the Cutting Plane.

Y-Axis: Click the Y-Axis button to create a section plane that centered at the center of the part.
To position the cutting plane run your mouse over the Cutting Plane Manipulator graphical icon. 
As your mouse passes over the Cutting Plane Manipulator two rotational axis elements will
highlight or one linear translation element.  Left-Click on any of these graphical elem ents when
highlighted and drag to rotate or linear-translate the Cutting Plane.

Click the Y-Axis button again to turn of the Cutting Plane.

Z-Axis: Click the Z-Axis button to create a section plane that centered at the center of the part.
To position the cutting plane run your mouse over the Cutting Plane Manipulator graphical icon. 
As your mouse passes over the Cutting Plane Manipulator two rotational axis elements will
highlight or one linear translation element.  Left-Click on any of these graphical elem ents when
highlighted and drag to rotate or linear-translate the Cutting Plane.

Click the Z-Axis button again to turn of the Cutting Plane.

Cutting Plane Manipulators: After you have positioned the Cutting Planes to your liking you
can hold SHIFT and click any  of the X, Y, or Z-Axis buttons to remove the Cutting Plane
Manipulator graphical icon for that plane - leaving just the plane itself and the cross-section it
gnerates.
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Show Axis: Check this box to show a graphical axis element in the lower left-hand corner of the
viewing window.  This is helpful when you have rotated your part around and don't have a good
concept of which direction the X, Y, or Z axis are pointing.

Close: Close the dialog box.

-o-
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 Bounding Box - CII
Select a part or a collection of parts using the Single or Window Select Tool. Then click the
Bounding Box Tool button to create a transparent bounding shape that encompasses the selected
entity(ies). This box will show the precise dimensions of the box. This tool is useful in
determining the minimum material required to machine a part for example.

-o-
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 Mass Properties

After selecting a part using the Single or Window Select Tool, click the  Mass Properties Tool.
The Mass Properties Tool allows you to check:

 Cubic Volume

 Weight based on density via a catalog of materials or is user selectable material

 Center of Mass (CoM) and the ability to create a true geometric representation of the CoM
with planar intersection graphs.  The CoM is read/writeable to any supported TransMagic
format.

 Inertial Properties: Principal Axes of Inertia, Principal Moments of Inertia, & Inertia Tensor.

After you invoke the Mass Properties a dialog box will appear as below:
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Volume and Mass
Volume - The volume of the part in cubic units.

Note: To change the units of the Mass Properties calculations see "Units" in the
documentation for the "General Page" under "File->Settings Pages".  The Units settings can

be found under File->Settings, General Tab, Units pull-down.

Mass - The mass of the part in mass units.  This value is based on the Material Density.
Changing the Material Density will change the value of this measurement.  See "Material Density"
under "Settings" in this section.

Center of Mass
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The Center of Mass is given in x, y, z coordinates.

Draw Center of Mass (CoM) - Click this button to draw a graphical representation of the Center
of Mass.  The graphic is 3 planes, the xy plane, the xz plane and the yz plane intersecting the
part at the Center of Mass.  If you Single Select the part and then right-click and select Hide
Selection, you'll notice that there is also a precise intersection graph that represents the 3 planar
intersections of the part and the CoM.  You can use these intersections to check edge
measurements, etc.  You can also save this CoM shape out to any supported file format.
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Apply "Fudge Factor" If CoM Intersection Fails - Sometimes the Center of Mass planes
coincide identically with existing edges.  These coincident edges are especially common with
symmetrical parts and parts that were mirrored.  In certain cases this coincident geometry to the
intersection planes can cause the CoM intersections to fail.  The "Fudge Factor" will be invoked if
the intersection fails and it will allow you to slightly shift the CoM plane geometry so that the
intersection will complete.  If the CoM planar intersection fails the following dialog will launch:
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This dialog allows you to shift the CoM geometry via global X,Y,Z translations or by rotations
around X,Y,Z global axes.  You can apply any combination of translations and rotations.  These
settings will be saved when you click OK so you don't have to re-enter information every time
this dialog is launched.

Note: For reference you can turn on the global X,Y,Z axes on in TransMagic by going into
the File->Settings area, select "Appearance", find the "View Settings" section and check the

"View Axis" check box.

Note: If the initial CoM intersection fails you may also want to consider applying  Full
Repair to the part first.  Many times the intersections fail because of precision issues at the
coincident geometry.  Running Full Repair on a part will virtually always increase precision
in these areas and will usually allow the CoM intersections to complete without applying a

Fudge Factor.

Settings
Material Density

Material - This pull-down box allows you to select various materials for your part.  Changing the
Material Density will change the value of the Mass measurement (weight) in the Volume and
Mass section.

Density - This is the value of the currently selected Material.

Enter Custom Density - Check this box if your Material is not in the pull-down list or if you simply
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want to enter your own value.  By checking this you will disable the Material Density pull-down
and the system will default to .036 lb/in^3 which corresponds to the industry default of 1.0
gm/cm^3.  You can enter your own value in this box.

Note: After entering a new Custom Density you must click the Recalculate button in order
to update the Mass value calculation to the new Custom Density.

Recalculate - Click this button to update the Mass value calculation after entering a new Custom
Density.

Precision
Decimal Places - Use this pull-down box to change the decimal precision in all Mass Property
calculations from 2 to 6 decimal places.  This value is saved in the TransMagic system settings
and the next time you run a Mass Property calculation, it will calculate based on this precision.

Note: Changing the Decimal Place precision will affect processing time.  If you have a very
complex part and your Decimal Precision is set to 6 places, be patient as it may take a while to
calculate Mass Properties at this level of precision.

Calculate Inertia Properties - Checking this box will enable the calculation of the parts
Principal Axes of Inertia, Principal Moments of Inertia and Inertia Tensor.

Note: The Principal Axes of Inertia and the Principal Moments of Inertia are take at the
Center of Mass.

Note: Calculating the Inertia Properties of a part will add processing time to the Mass
Properties calculations.

Copy to Clipboard - Clicking this button will place all the Mass Properties of the dialog box in
tabulated form to the Windows clipboard.  

Note: The way TransMagic copies text data to the Windows clipboard is called Unicode and
it's very nice for pasting into office documents.  For example if you paste the copied data
from the TransMagic Mass Properties dialog box to a Microsoft Excel spreadsheet, Excel or

any other spreadsheet application will paste the data as a nicely columnized data set.

Reset Defaults - Click this button to reset the Mass Properties dialog box to it's original default
settings.

OK - Click this button when you are done reviewing the Mass Properties data.

-o-
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 Surface Area - CII
After first selecting a part, or face of a part, click on Check Area Tool to get the part or face's
surface area.

Note: To select an individual face, simply Right-Click on the display and select Filter
Selection->Face.  If a Body is selected, the surface area will be that of the entire part.

-o-
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Orientation Toolbar - CII

 Top View - CII

Click button, this will orient the display to the top view.

-o-
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 Front View - CII
Click button, this will orient the display to the front view.

-o-
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 Right Side

Click button, this will orient the display to the left view.

-o-
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 Isometric View - CII
Click button, this will orient the display to the isometric view.

-o-
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Placement Toolbar - CII

 Orbit
Click button, depress left mouse button and slide across the screen to rotate the view.

-o-
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 Zoom - CII

Click button, depress left mouse button and slide the mouse up and down to zoom in and out on
the view.

-o-
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 Pan - CII
Click button, depress left mouse button and slide the mouse across the screen to laterally
position the view.

-o-
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 Continuous Orbit - CII
Click button, then use the Orbit Icon to rotate the view, then release. The view will continue to
orbit in the direction of rotation when the mouse button was released. The speed of rotation
depends on the speed that the mouse was moving when the button was released.

-o-

 



p263

TransMagic R10 User Guide

© TransMagic Inc, 2013

Projection Toolbar - CII

 Perspective Projection - CII
Click to switch view to perspective projection.

-o-
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 Parallel Projection - CII
Click to switch view to perspective projection.

-o-
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Rendering Toolbar - CII

 Shaded Rendering - CII
Click for smooth shaded rendering.

-o-
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 Hidden Line Rendering - CII
Click for hidden line rendering.

-o-
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 Wireframe Rendering - CII
Click for wireframe rendering.

-o-
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 Make Transparent - CII
After first selecting a part or multiple parts using the Single or Window Select Tool, click this
button to turn the selected parts transparent.

-o-
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 Undo Transparency - CII
After first selecting a part or multiple parts using the Single or Window Select Tool, click this
button to turn transparent parts back to solid parts.

-o-
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Selection Toolbar - CII

 Single Select - CII
Click the Single Select Tool to select a single part, surface, cutting plane etc. in TransMagic.

-o-
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 Window Select - CII
Click the Window Select Tool to draw a rectangular window around a collection of objects in a
document and select them all at once.

-o-
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 Set Color Filter
This tool will enable you to select a Color filter for selecting parts of a certain color.  This is
especially useful when you bring in a surface model assembly that contains many parts of
different colors that need to be stitched into solids.  You must first select a part with the color
you want to filter.  Then click the Set Color Filter icon.  Now any selection you make will filter for
this color and only select and highlight the parts whose color match that specified by the Set
Color Filter function.

-o-
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 Clear Color Filter
The Color Filter is active until cleared by clicking the Clear Color Filter function.  Once you're
done using the Color Filter, use this function to clear the Color Filter and turn the filter OFF.

-o-
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Zoom Toolbar - CII

 Zoom To Extents - CII
Click button to zoom all the parts in the view so that they all fit in the view.

-o-
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 Zoom To Window - CII
Click button then left mouse button and drag to create rectangular window in the view, then
release the mouse button. The view will then update to reflect the contents of the window.

-o-
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 Zoom To Selection - CII
After first selecting anything with the Single Select Tool or the Window Select Tool, select the
Zoom To Selection Icon and the view will update to contain all the selected items centered in the
view.

-o-
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 Preset Camera Position 1 - CII
Hold down the shift key and simultaneously select the Preset Camera Position 1 Icon. The view
orientation will be captured in memory so that the next time you click the Preset Camera 1 Icon
(with-out holding the Shift key), the view will return to the captured orientation with any
Redlining you may have saved as well.

-o-
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 Preset Camera Position 2 - CII
Hold down the shift key and simultaneously select the Preset Camera Position 2 Icon. The view
orientation will be captured in memory so that the next time you click the Preset Camera 2 Icon
(with-out holding the Shift key), the view will return to the captured orientation with any
Redlining you may have saved as well.

-o-
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 Preset Camera Position 3
Hold down the shift key and simultaneously select the Preset Camera Position 3 Icon. The view
orientation will be captured in memory so that the next time you click the Preset Camera 3 Icon
(with-out holding the Shift key), the view will return to the captured orientation with any
Redlining you may have saved as well.

-o-
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Advanced Toolbar - CII

 Set Restore Point - CII*
Clicking the Set Restore Point button will tell TransMagic to "record" Restore Points.  These
Restore Points will be recorded before any operation that will change or add geometry to the
currently selected document.  During Manual or Automatic Repair operations in TransMagic
various factors may contribute to changing the geometry in a negative/erroneous way, including
user error.  Restore Points allow you to change the model without fear of changing the geometry

negatively as you can always call the  Recall Restore Point (Undo) function.

Tip: Set Restore Point does consume additional processor resources so you may want to
consider this before leaving it on all the time.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 Recall Restore Point - CII*
Click the Recall Restore Point(Undo) function to Recall a previously recorded Restore Point. 
TransMagic will save up to and Recall up to 10 Restore Points.  

Tip: If for some reason TransMagic crashed while the Set Restore Point function was

enabled you can re-start TransMagic, open a New document (File->New) and click the 
Recall Restore Point function to restore the file to its state before the crash occurred.

Tip: Set Restore Point does consume additional processor resources so you may want to
consider this before leaving it on all the time.

Tip: Set Restore Point automatically creates TransMagic native *.tmr file in the users
"TEMP" directory.  If you want to manually create an individual Restore Point, then simply

select File->Save As and select the TransMagic *.tmr file format.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 MagicSurface: Find Nex Open Edge*
Click the Find Next Open Edge function to find the next open circuit of edges.  This function is the
first step in a MagicSurface Repair scenario.  This function will find one of two types of edge
circuits:

- A hole in a model - in which case the MagicSurface tools are the next logical tools to cover the
hole with a surface.  

- A disjoint surface floating in space which isn't the same as a hole in a model but it is still
considered an open circuit of edges.  In this case the MagicSurface tools will no be applicable;
however, you will have possibly identified a useless surface that you may want to consider Hiding
or Deleting.  Many CAD formats will include useless construction geometry or duplicate surfaces
when read into TransMagic.  This can be a useful too for finding these surfaces and handling
them appropriately by deleting or hiding.

- Whether or not you decide to do anything with the currently highlighted open circuit of edges,
you can continue to click this button to cycle successively through all the open circuits in a part. 
This can be useful for first assessing what type of problems you are dealing with before
proceeding with Repair operations.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 MagicSurface: Cover Current Selection - CII*
This function will not highlight until an open circuit of edges has first been identified using the 

 "Finding Next Open Edge" function documented above.  After finding the next open circuit of
edges you would click this button to cover the open hole in a part with a TransMagic
MagicSurface.  

- When TransMagic creates a surface, note the purple color of the surface.  This surface color will
travel with the model to the export format and it is your visual cue that the surface was not
created by the original CAD system.

- There are many possible surfaces that can be created by the MagicSurface tools.  Pay attention
to any messages that TransMagic will display.  In many cases these are not error messages but
rather information messages.  If additioanl steps are required to completely Repair the open
circuit then TransMagic will offer suggestions via these messages.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 MagicSurface: Set Smooth Edge - CII*

This function is intended to be used concurrently with both the  "MagicSurface: Cover

Current Selection" (above) or  "MagicSurface: Cover Edge Circuit"  (below) tools.  When
TransMagic creates a MagicSurface it creates what is called a "m inimum energy surface" - that is
to say the surface that requires the minimum amount of surface tension to cover the open circuit
of edges.  However, if the open circuit you intend to cover was a missing radius blend surface, for
example, then it is likely that you want the replacement surface to include adjacent surface
curvature so that the new surface blends in smoothly with adjacent surfaces.

- If you select a single edge and then click this function it will automatically find the entire open
circuit and apply a "smooth" attribute to all of the edges in the circuit.

- TransMagic will identify edges marked with a "smooth" attribute by highlighting them GREEN.

- If you don't want TransMagic to apply the "smooth" attribute to every edge in the circuit then
hold down the CTRL key and then click this function.  Holding down the CTRL key while clicking
this function will tell TransMagic to only apply the "smooth" attribute to any currently selected
edges.

- To select single edges in TransMagic, first right-click and set your filter selection to Edge.

- To select more than one disparate edge at a time simply hold down CTRL while selecting the
edges.  The while still holding down the CTRL key, click this function and it will apply the
"smooth" attribute only to the selected edges.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 MagicSurface: Set Sharp Edge - CII*

This function is intended to be used concurrently with both the  "MagicSurface: Cover

Current Selection" (above) or  "MagicSurface: Cover Edge Circuit"  (below) tools.  All edges
to be covered are automatically considered "sharp" edges and thus don't need this attribute
applied manually.  However, during a MagicSurface Semi-Auto Repair operation it is possible that
you may have applied a "smooth" or "hole" attribute to an edge and you now want to remove
that attribute from a single edge or from selected edges.  This function will allow you to remove
any previously placed attributes on the selected edges with a "sharp" attribute - that is to say
"none".

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 MagicSurface: Set Hole Edge - CII*

This function is intended to be used concurrently with both the  "MagicSurface: Cover

Current Selection" (above) or  "MagicSurface: Cover Edge Circuit"  (below) tools.  You may
encounter situations in a MagicSurface Semi-Auto Repair session that you need to cover a circuit
of edges with a surface; however, there are other edge circuits that would normally exist as
"holes" or "pockets" in the surface that should not be covered.  You would use this function to
identify "hole" or "pocket" surfaces before you create the surface so that the MagicSurface that is
created takes into account these internal circuits and instead of covering them, leaves them
open.

- If you select a single edge and then click this function it will automatically find the entire open
circuit and apply a "hole/pocket" attribute to all of the edges in the circuit.

- TransMagic will identify edges marked with a "hole/pocket" attribute by highlighting them
LIGHT BLUE.

- If you don't want TransMagic to apply the "hole/pocket" attribute to every edge in the circuit
then hold down the CTRL key and then click this function.  Holding down the CTRL key while
clicking this function will tell TransMagic to only apply the "hole/pocket" attribute to any currently
selected edges.

- One interesting feature of applying this attribute to a single edge would be that this tells
TransMagic, instead of this being an edge that belongs to a circuit representing a hole, it tells
TransMagic to create a surfaces that actually PASSES through this edge.  This is a creative way to
"constrain" a surface to pass through curves while being created.

- To select single edges in TransMagic, first right-click and set your filter selection to Edge.

- To select more than one disparate edge at a time simply hold down CTRL while selecting the
edges.  The while still holding down the CTRL key, click this function and it will apply the
"smooth" attribute only to the selected edges.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 MagicSurface: Clear All Edges - CII*
During a MagicSurface Repair session you may have applied, "smooth", "hole/pocket" attributes
to edges and decide that you'd like to clear them all at once.  Clicking this button will remove any
MagicSurface attributes attached to any edge.  This function will only be enabled if there is an
attribute to be removed.  This function can also be used to clear out any and all selections in
TransMagic - such as clearing out currently set "Split-Trim" geometry.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 MagicSurface: Cover Hole or Boss - CII*
This is a special condition function that addresses a certain case of surface covering.  It's possible
to see a hole in the top of a surface that represents where a bore or drill hole should be in the
part.  You may also have the bottom surface of this hole; yet the cylindrical sidewall surface of
the bore is missing.  You would select one edge from each side where the missing suface(s)
should connect the two.  Then click this button to create the cylindrical surface between the two.

- This function works not only with a cylindrical surface but also if you had all of the surfaces of a
pocket or boss missing.  You would still simply select one edge from each side and TransMagic
will automatically find all edges in the circuits and "skin" a surface between each c ircuit.

- This function works even if there are not an equal number of edges on either circuit.

- TransMagic will split the surfaces into multiple surfaces if necessary to satisfy the conditions
and create a surface "skin" between both sides.

- If you don't want TransMagic to select the involved circuits automatically but just want
TransMagic to create a "skin" surface between only the edges that you have selected then simply
down the CTRL key while clicking this function and TransMagic will create the "skin" surface only
between the edges you have selected.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 MagicSurface: Revover Face - CII*
You may find that well surface may exist, they appear visually incorrect and in need of

replacement.  It is first recommended that you select the Face and then run the  Full Repair
function only on the face first.  If the surface is still visually incorrect, then select the Face and
then click this function to recover the face with a new, high quality, MagicSurface.  If the face still
appears erroneous, you should consider deleting the Face altogether and then re-covering the
open circuit with a new MagicSurface as covered in the functions listed above.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 Show Missing Surfaces - CII*
Click on the Show Missing Surfaces function to show all open circuits in all visible entities.  This
function will allow you to visually inspect where open holes are in  a part.  If TransMagic reports
that there are open edges then you may need to apply Semi-Auto Repair using the MagicSurface
tools or you may even need to delete or hide geometry. 

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 Show Bad Geometry - CII*
Click on the The Show Bad Geometry function to launch the Un-Repaired Geometry Dialog.  This
dialog highlights erroneous geometry that remains.  For more information see the documentation
for the Un-Repaired Geometry Dialog.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 Create Wire-Body - CII*
Wire-Bodies are required as a "frame" for creating a surface.  To create a surface on a Wire-Body
a Wire-Body must first consist of a closed loop of Edges.  To use this function you must first set
your selection level to Edge and then select a chaining of edges individually.  When doing so it is

sometimes helpful to use  Zoom To Window function and the set the view to 
Wire-Frame mode.  When you have a continuous loop of edges selected, you may then click the 

 Create Wire-Body tool to create a Wire-Body.

Tip: You may create Wire-Bodies in TransMagic that do not form closed loops simply by

selecting one ore more edges and clicking the  Create Wire-Body Tool.

Note: When TransMagic creates a new Wire-Body, it will automatically launch the Assembly
Browser.  If you scroll to the bottom of the list in the Assembly Browser you will notice the

newly created entities named "TM Wire-Body".

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 Create Linear Edge - CII*
As TransMagic's current limitation for creating non-planar surfaces is 3 or 4 edges, it is
sometimes necessary to sub-divide a "hole" into groups of Wire-Bodies that conform to this 3 or
4 edge requirement.  You must first Right-Click anywhere in the display and select
Show->Vertices and the Right-Click again and select Filter Selection->Vertices to set your
selection filter and visibility to Vertices.  Now Single Select your first Vertex and Single Select
your second Vertex.  You'll notice that when two and only two Vertices are Selected that this Tool
will be enabled.  When you click this tool it will created a linear edge between the two vertices. 

You can use this edge as an input edge when using the  Create Wire-Body Tool.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 Group - CII*
Select a collection of models using the Select Window Tool, then click the Group Tool to combine
the parts into a single selectable part.  This is very helpful when "piecing together" groups of
surfaces that belong to a single part for the eventual purpose of stitching them together with Lite
Repair.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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 Ungroup - CII*
To ungroup a collection of parts that have been group simply select the group with the Single
Select Tool, then click the Ungroup Tool. This will separate this collection of "lumps" into
individual parts that can be selected individually.

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.
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 Boolean Union - CII*

Although  Lite Repair is the recommended function for stitching surfaces into existing parts,
it is possible to stitch a single surface into a part with the Boolean Union Tool.  First make sure
that the face is oriented in the right direction by performing these steps: 1) Select
View->Options->Shade Surface and select Front.  By default TransMagic renders both sides of a
surface to avoid confusion but then you don't know which direction surfaces may be facing.  Next
determine if the face you want to Boolean Union is facing in the proper direction.  You can tell
because you can see it.  If you are looking at the back of a surface it will appear as though you're
looking "through" the surface.  If the surface is facing in the wrong direction, orient the part so
that you can select the surface, select the surface (set your Filter Selection to Face), and then
select Geometry->Reverse Faces.  This will flip the face to the opposite direction.  Now to
Boolean Union the surface into the model first Single Select the model and then Single Select the
surface.  Finally, click the Boolean Union Tool to Unite the surface into the model.

Tip: It will generally always be easier to simply Window-Select the model and the surface

at once and then select the   Lite Repair Tool.  Lite Repair will handle any surface
orientation  issues automatically. 

* Depending on your version of TransMagic you may not have access to the tools in the
Advanced Toolbar.

-o-
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